Bug Hunting Session
Bug 82710 - EDITING: "Add to Dictionary" forgets after restart
Summary: EDITING: "Add to Dictionary" forgets after restart
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-16 20:32 UTC by Anonymous
Modified: 2014-08-18 20:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anonymous 2014-08-16 20:32:15 UTC
Problem description:
Right-click --> "Add to Dictionary" function's usefulness compromised.

Steps to reproduce:
1. Create new document
2. Type an unusual word (e.g. longsuffering)
3. Type a space or something else to make auto-check underline the word with a red zigzag.
4. Right-click word, select "Add to Dictionary". Notice red line is gone.
4. Save doc and restart LibreOffice.
5. Open document. Notice red line is back.


Current behavior:
"Add to Dictionary" only adds the word temporarily, until I restart LibreOffice.
Expected behavior:
"Add to Dictionary" should keep the word in the dictionary.
Operating System: Linux (Other)
Version: 4.2.6.2 release
Comment 1 Anonymous 2014-08-16 20:45:54 UTC
May be duplicate of 60833, but I'm still getting the problem in version 4.2.6.2.
Comment 2 Julien Nabet 2014-08-17 15:35:41 UTC
On pc Debian x86-64 with 4.2.6 LO Debian package, I don't reproduce this.

For the test, could you rename your LO directory profile and give it a new try? (see https://wiki.documentfoundation.org/UserProfile#GNU.2FLinux)

(I also put fdo#79276 because I had made some changes about dictionaries for this one and perhaps I made something wrong)
Comment 3 Anonymous 2014-08-18 19:40:27 UTC
Solved the problem for me. Thank you.
Comment 4 Julien Nabet 2014-08-18 20:14:07 UTC
Thank you for your feedback, I'll put WFM.