Download it now!
Bug 60945 - FILESAVE launches 'Open' dialog
Summary: FILESAVE launches 'Open' dialog
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: All All
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval, skillCpp, topicQA
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-02-16 08:36 UTC by Urmas
Modified: 2015-12-15 22:38 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2013-02-16 08:36:19 UTC
With recent master, Save command in Writer uses an 'Open' common dialog, which cannot be used to give a name of a new file.
Comment 1 Julien Nabet 2013-02-16 14:54:06 UTC
On pc Debian x86-64 with master sources updated today (commit 1cc6db3c6014b36c2452b6e382559119c8093884), I don't reproduce this.

Could you give details about the version? Do you compile from sources?
Do you have the open dialog in every case?
- icon save
- shortcut Ctrl-S
- menu file/Save
Comment 2 Urmas 2013-02-16 16:35:27 UTC
The build ID is 2b9394f0c009b385756a0c5d75e3c1cd412f723
This apparently affects all applications and is a Windows-specific bug.
Comment 3 Julien Nabet 2013-02-16 17:34:28 UTC
Urmas: thank you for your feedback.
Rainer: would you have some time to reproduce this?
Comment 4 Rainer Bielefeld Retired 2013-02-16 18:17:47 UTC
 [Reproducible] with parallel Dev-installation of  "Version 4.1.0.0.alpha0+ (Build ID: 2b9394f0c009b385756a0c5d75e3c1cd412f723) TinderBox: Win-x86@6, Branch:master, Pull Time: 2013-02-14_00:13:52" ENGLISH UI / German Locale  on German WIN7 Home Premium (64bit) with LODev/4 Masters User Profile:

1. Launch LibO
2. If necessary: Menu 'Tools -> Options -> LO -> General - Uncheck 
   "Use LibO file dialogs" <ok>
3. Create New Writer Document from LibO start Center
4. Menu 'File -> Save as'
   Expected: 'Save' Dialog with <Save> button , ...
   Actual: 'Open' dialog with <Open> Button, missing check boxes for 
            'Auto extension', 'Save with Password'

Same problem in Calc, with Save Icon, ...

Was still ok with  4.1.0.0.alpha0+ (Build ID: bdfd8de57bf5767ce5c179a5e8705c7587f7b32) TinderBox: Win-x86@6, Branch:master, Time: 2013-02-06_22:06:22


@Urmas: 
Do you use own builds from git? If not, please contribute complete Version info, especially time stamp.

@Julien:
Are you planning to take this one or do we need a dev. wiht WIN?
Comment 5 Julien Nabet 2013-02-16 18:35:52 UTC
Rainer: Sorry, I don't know where to investigate about this so we need a dev here.
Comment 6 Jorendc 2013-02-16 19:01:58 UTC
I can confirm this bug with Mac OSX 10.8.2 also. Therefore -> versions to 'all'. Set priority to 'high' because this is not a windows-only bug. I don't set priority to 'highest' because this isn't reproducable using Linux (so far tested) and there is a workaround.

LibreOffice Version 4.1.0.0.alpha0+ (Build ID: 9d6bb5daa67fef7abe07cfbfa22cd52ce73d804)
TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2013-02-15_23:41:25

I can't confirm this behavior with Linux Mint 14 x64 latest master (build today, using git, ./autogen.sh --enable-debug && make && make dev-install).
Comment 7 Jorendc 2013-02-16 19:04:57 UTC
Although, when I do 'file > open' my directory is in the last directory I opened a file ... that's correct.

When I try to 'save' using file > save (or shortcut or icon on toolbar) the starting directory is 'Documents' ... and that's the good (default) behavior when I would like to save something... In previous versions this was the start directory when I click on 'save'. So it looks like only the dialog is wrong, not the code that process/shows things.
Comment 8 Rainer Bielefeld Retired 2013-02-16 19:15:50 UTC
@kendy
Can you please help here? What do you think about EasyHack, can yo be mentor?
Comment 9 Jorendc 2013-02-16 19:36:01 UTC
Can't reproduce using: 

LibreOffice Version 4.1.0.0.alpha0+ (Build ID: a2a8a159df82bc5e75c0c56af6ffef0f024c7b1)
TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2013-02-11_19:39:03

Can't reproduce using:

LibreOffice Version 4.1.0.0.alpha0+ (Build ID: 658c35878c14044029ca7f708fbde32b98cb226)
TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2013-02-11_23:36:51

Can reproduce using:

LibreOffice Version 4.1.0.0.alpha0+ (Build ID: 871712ad62bb01359c29713a148a5673e26df1a)
TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2013-02-13_00:15:32

Therefore this bug is introduced between 2013-02-11_23:36:51 and 2013-02-13_00:15:32
Comment 10 Jorendc 2013-02-25 22:21:28 UTC
I can't reproduce this anymore using Mac OSX 10.8.2 and LibreOffice Version 4.1.0.0.alpha0+ (Build ID: 80f57172833ec720a2bc0d7d9c8f82f8bc5fc70)
TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2013-02-24_11:53:07

Can please someone can verify so we can mark this as RESOLVED WORKSFORME (or FIXED if we know which commit it fixed)?

Kind regards,
Joren
Comment 11 Regina Henschel 2013-02-25 22:39:22 UTC
For me too it works now, using
Version 4.1.0.0.alpha0+ (Build ID: 74f74aa5470fe631c7827897742c0ccbddcf6ad)
TinderBox: Win-x86@6, Branch:master, Time: 2013-02-23_23:21:01
Comment 12 Robinson Tryon (qubit) 2015-12-15 22:38:26 UTC
Migrating Whiteboard tags to Keywords: (ProposedEasyHack -> needsDevEval,   SkillCpp TopicQA)
[NinjaEdit]