Bug 60946 - FILESAVE: Writer crashes upon trying to open odt document containing text-range comments
Summary: FILESAVE: Writer crashes upon trying to open odt document containing text-ran...
Status: RESOLVED DUPLICATE of bug 60668
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-02-16 09:07 UTC by johndwriting
Modified: 2013-02-21 20:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description johndwriting 2013-02-16 09:07:16 UTC
Problem description: .odt file becomes unreadable/corrupt after saving the file if text-range comments exist in the document.

I was using Writer to write a short story, nothing fancy. Only text formatting was underline. I had only three comments made on my 1500 word document and I saved it no problem.

But when I tried to open the file again, Writer would crash and not load the document. This was on Lubuntu 12.04. I tried the same file on Windows 7 (both are LibreOffice 4.0.0.3) and got an error message saying the file could not be read.

So I uploaded the doc to Google Docs to get at the text and this worked fine, with Google Drive converting the document to Google Docs format. Everything was fine except of course the comments did not carry over. I used this text to create a new .odt file and remake my document.

It worked fine and would save and open fine until I added the text-range comments back into it (only three of them). After that, the file would save, but then I couldn't open it. I got the same crashing problem I described above.

And that's it. It's weird because I've had those comments for a day or two without any problem, but I added more words to the document today and saved it and stopped working, then went to open the document again and got this problem.

I tried resetting my user profile, but that did not affect the issue.
              
Operating System: Linux (Other)
Version: 4.0.0.3 release
Last worked in: 3.6.5.2 release
Comment 1 Florian Oberleitner 2013-02-21 15:54:38 UTC
Hello folks,

got the same problem with a template of mine (Mac OSX 10.7.5, LO 4.0.3).
It boils down to having the pagenumber in the footer.

The pagenumber in the textbody does not matter but as soon I move it to the footer and there are comments present anywhere, Writer crashes on opening the doc.

Windows XP with LO 4.0.3 shows the same behaviour.


The windows 4.1.0 alpha seems to have the problem solved.


Greets,
Florian
Comment 2 Karl Zeiler 2013-02-21 17:24:50 UTC
I described a similiar behaviour on the German discuss list:
http://www.mail-archive.com/discuss@de.libreoffice.org/msg14473.html
Compare: Meine Ergebnisse Ziffer (3)

Please note:
The complete comment function seems to be buggy. Even have a look to:
https://bugs.freedesktop.org/show_bug.cgi?id=34800

Tested under Windows XP/7.

Regards
Karl
Comment 3 Michael Stahl (CIB) 2013-02-21 19:11:24 UTC

*** This bug has been marked as a duplicate of bug 60668 ***
Comment 4 Karl Zeiler 2013-02-21 20:01:58 UTC
@ Michael Stahl

Are you sure? - Sorry for my question.
IMHO: The bug above mentioned concern original odt-files, not converted doc-files.