Bug Hunting Session
Bug 60962 - EDITING: Copy (OLE) object sets "document changed" flag
Summary: EDITING: Copy (OLE) object sets "document changed" flag
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Formula-Editor Chart Cut-Copy
  Show dependency treegraph
 
Reported: 2013-02-16 19:07 UTC by Rainer Bielefeld Retired
Modified: 2018-07-27 16:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document (16.79 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-02-16 19:07 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-02-16 19:07:35 UTC
Created attachment 74947 [details]
Sample Document

Steps how to reproduce [Reproducible] with  "LibreOffice 3.6.5.2 " German UI/ German Locale [Build-ID: 5b93205] {pull date 2013-01-18} on German WIN7 Home Premium (64bit) :

1. Open attached sample document
2. Click on Chart
3. <Control+c>
   Unexpectedly "Save" Icon becames active 
   but
   No Undo

Not visible in Writer (tested with Chart)

Same with Math Formula in sample document, but not with Draw shapes

Very old bug, already in AOOo 3.4.0 and LibO 3.3.3, so inherited from OOo
Comment 1 Jorendc 2013-06-02 23:09:27 UTC
I can reproduce this using Mac OSX 10.8.3 with LibreOffice 4.0.4.1 rc1.

Kind regards,
Joren
Comment 2 QA Administrators 2015-03-16 23:14:36 UTC Comment hidden (obsolete)
Comment 3 Jean-Baptiste Faure 2015-03-28 20:45:49 UTC
Still reproducible with LibreOffice 4.4.3.0.0+ built at home under Ubuntu 14.10 x86-64.
With the master the Save icon is activated as soon as the file is loaded, so no test possible.

Best regards. JBF
Comment 4 tommy27 2016-04-16 07:23:34 UTC Comment hidden (obsolete)
Comment 5 Jean-Baptiste Faure 2016-05-01 08:29:27 UTC
Still reproducible in LO 5.1.4.0.0+ and master, both build at home under Ubuntu
16.04 x86-64.

That said, the file is marked as modified as soon as it is opened. I need to save it first to be able to test this bug. The problem is linked to the chart; indeed if I remove the chart, this problem disappears.

Best regards. JBF
Comment 6 QA Administrators 2017-05-22 13:40:18 UTC Comment hidden (obsolete)
Comment 7 Jean-Baptiste Faure 2017-07-23 20:54:12 UTC
Still reproducible with LO 5.4.1.0.0+ built at home under Ubuntu 16.04 x86-64. 

Best regards. JBF
Comment 8 QA Administrators 2018-07-24 02:37:24 UTC Comment hidden (obsolete)
Comment 9 Jean-Baptiste Faure 2018-07-27 16:08:09 UTC
Reproducible with LO 6.0.5 but seems to be fixed in LO 6.1.1.0.0+ built at home under Ubuntu 16.04 x86-64

Closing as WorksForMe. Please feel free to reopen if you still encounter the bug.

Best regards. JBF