Bug 61002 - support for var.p and var.s needed
Summary: support for var.p and var.s needed
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: low enhancement
Assignee: Winfried Donkers
QA Contact: Joel Madero
URL:
Whiteboard: target:4.2.0
Keywords: needsDevEval
Depends on:
Blocks: 70798
  Show dependency treegraph
 
Reported: 2013-02-17 12:49 UTC by Justin
Modified: 2015-12-18 10:16 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
testcase file created with Excel 2013 (8.35 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-10-30 17:53 UTC, Eike Rathke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Justin 2013-02-17 12:49:44 UTC
Current functions varp and vars are deprecated by MS.  Excel 2010 and forward uses the var.p and var.s functions in place.  Excel still supports varp and vars for backward compat with excel 2007 and previous.

Documentation shows them as the same except the range of values for var.p is 2 to 254, whereas the varp shows 2 to 255.  

Should be a simple matter of adding an alias to var.p.  Currently it looks like the function is converted to =_xlfn.var.p()when its imported into Calc.


This is a bit unwieldy to work with and would be nice just to add the additional functions since they would use the same code as the current functions.
Comment 1 Joel Madero 2013-03-21 20:16:59 UTC
I can confirm that this is a valid enhancement request, currently it's just not supported so adding it is an additional feature.

Version 4.1.0.0.alpha0+ (Build ID: 9a46e5614f5a0e0bdce3c497f81ca529da8fb5c)
Date:   Mon Mar 18 18:59:09 2013 +0100 
Platform: Bodhi Linux 2.2 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm the enhancement request I am marking as:

New (confirmed)
Enhancement
Low - might prevent specific users from being able to use Spreadsheet (not many most likely), probabyl quite easy to fix though

Keywords - 

Whiteboard Status - ProposedEasyHack

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 Winfried Donkers 2013-10-19 15:38:52 UTC
@Justin:
Could you upload an xlsx file with the var.p and var.s functions used as an attachment to this bug?

And possibly with more functions as listed in
http://office.microsoft.com/en-us/excel-help/what-s-new-changes-made-to-excel-functions-HA010355760.aspx
(except covariance.p/covariance.s, these have been fixed with bug 70000)
?

I know how to fix it, but I haven't got Excel, so I can't test the fix...
Comment 3 Eike Rathke 2013-10-30 17:53:33 UTC
Created attachment 88375 [details]
testcase file created with Excel 2013
Comment 4 Commit Notification 2013-10-30 18:02:05 UTC
Winfried Donkers committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=781363934af5c0ff3401161c385c6c93c9352c2c

fdo#61002 add Excel 2010 functions VAR.P and VAR.S



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Robinson Tryon (qubit) 2015-12-18 10:16:08 UTC
Migrating Whiteboard tags to Keywords: (ProposedEasyHack -> needsDevEval)
[NinjaEdit]