Download it now!
Bug 61031 - Draw objects included in Writer document not printed
Summary: Draw objects included in Writer document not printed
Status: RESOLVED DUPLICATE of bug 60280
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-17 23:34 UTC by a.s.
Modified: 2013-12-15 23:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Print test for bug (21.54 KB, application/vnd.oasis.opendocument.text)
2013-02-18 15:46 UTC, a.s.
Details
Printing in a pdf pdfprinter (Not with built-in pdf) (19.19 KB, application/pdf)
2013-02-19 01:10 UTC, m.a.riosv
Details
ToPages_First_with_PDFcreator_Second_Directly from LibreOffice. (26.17 KB, application/pdf)
2013-04-16 19:43 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description a.s. 2013-02-17 23:34:47 UTC
My 4.0.0.3 release does not print Draw OLE-objects I have included in a Writer document although it can be seen in every preview, even the one in the window where you choose the printer.
Comment 1 m.a.riosv 2013-02-17 23:59:34 UTC
Hi a.s.,
please verify if you have enable:

Menu/Tools/Options/LibreOffice Writer/Print/Contents - Pictures and objects.

Menu/File/Print/LibreOffice Writer/Contents - Pictures and objects.
Comment 2 a.s. 2013-02-18 15:46:01 UTC
Created attachment 75048 [details]
Print test for bug

Printing the attached document only shows the two small a on an plain white page.
Comment 3 a.s. 2013-02-18 15:46:54 UTC
Hi Mario, both options are enabled, bug remains.
Comment 4 a.s. 2013-02-18 15:56:09 UTC
sorry, failed to post attachment. i made a document typing a single a, included an ole object (draw) with circles, made a circle within writer document and included ole object (calc) with black framed cells typing there another a. Printing all just shows two lonely a on white surface.
Comment 5 m.a.riosv 2013-02-19 01:10:54 UTC
Created attachment 75079 [details]
Printing in a pdf pdfprinter (Not with built-in pdf)

Printing with PDFCreator (a pdf printer) I get the same that I can see in LibreOffice.
Comment 6 Rainer Bielefeld Retired 2013-04-16 16:23:01 UTC
[Reproducible] with parallel Dev-installation of  "Version 4.1.0.0.alpha0+ (Build ID: 049ce78144650d92eb6bd73292868f73d37c901) TinderBox: Win-x86@6, Branch:master, Pull Time: 2013-03-29_23:59:42" ENGLISH UI / German Locale on German WIN7 Home Premium (64bit) with LODev/4 Masters User Profile 

So this one is a DUP of "Bug 60280 - PRINTING of TABLE borders, borders around paragraphs and footer, some graphic elements suppressed by OLE objects in document" or a related one. AFAIK WIN only.

@mariosv
Without info with what OS you tested your comment does not help very much

@a.s.:
Thank you for your attention!

*** This bug has been marked as a duplicate of bug 60280 ***
Comment 7 m.a.riosv 2013-04-16 19:43:04 UTC
Created attachment 78108 [details]
ToPages_First_with_PDFcreator_Second_Directly from LibreOffice.

With:
Windows7x64 Ultimate.
Version 4.0.2.2 (Build ID: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3)

Attached a pdf with two pages, the first created trough PDFcreator, the second one with the button export to pdf. Created from a.s. sample file.

If I am not in an error, I can not reproduce the issue.

And Rainer Sorry, I confess sin committed, and I hope can achieve your pardon.:)