Download it now!
Bug 61058 - User dictionary is not truncated when words are removed
Summary: User dictionary is not truncated when words are removed
Status: RESOLVED DUPLICATE of bug 42122
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-18 12:16 UTC by Urmas
Modified: 2013-02-19 18:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2013-02-18 12:16:01 UTC
When the words are removed from user dictionary, the file is not truncated, creating either parasite entries, or, if invalid UTF-8 was produced, the entire dictionary is no longer available.
Comment 1 Jorendc 2013-02-18 19:28:25 UTC
Hi Urmas,

I don't want to be rude, but following your backlog (https://bugs.freedesktop.org/buglist.cgi?query_format=advanced&emailreporter1=1&list_id=235619&email1=davian818%40gmail.com&product=LibreOffice&emailtype1=substring) you are experienced enough to know how to report a good bug report. 

Reading your bug report Description I have no clue how to reproduce your reported behavior, or what you're actually meaning... So I need to mark this bug as NEEDINFO to ask you for *steps* how we can reproduce your behavior.

Please read https://wiki.documentfoundation.org/BugReport#Detailed_explanation_of_bug_reports_content and especially 'Steps to reproduce the problem'. Try to see it from our, the QA team, point of view. You know what's wrong, and you know what you're talking about... be we don't and we would like.

I hope you understand.
Thanks for helping LibreOffice

Kind regards,
Joren
Comment 2 Urmas 2013-02-19 01:33:50 UTC
OF COURSE you don't understand what I was talking about.

1. Create a user dictionary with some words
2. Remove a word from it
3. See the file having the same size and remnants of the last word in the end.

Now, which part of this is not clear from my original description? I smell a troll.
Comment 3 Joel Madero 2013-02-19 03:08:05 UTC
Urmas - Joren is a dedicated contributor and has correctly pointed out that you routinely fail to provide steps to reproduce. Please don't attack him for pointing out our policies
Comment 4 Urmas 2013-02-19 07:21:29 UTC
Code pointer
core/linguistic/source/dicimp.cxx:447
Comment 5 Joel Madero 2013-02-19 16:24:53 UTC
a code pointer still isn't what QA needs to verify the bug. Please take a look at Rainer's reports:

https://bugs.freedesktop.org/show_bug.cgi?id=59958

As you can see he clearly outlines the steps for every bug that he submits, on top of this he gives us exactly what version he's using as well as his operating system. We ask that our more experienced bug reporters + QA staff do this to make the QA workflow work as we expect it to
Comment 6 manj_k 2013-02-19 17:11:55 UTC
@Urmas (in reply to comment #2):

Do you 
1. create the user-defined dictionary, and 
2. remove the words 
via menu 'Tools > Options > Language Settings > Writing Aids'?

Then it is apparently a duplicate of 'Bug 42122 - Deleting entries from user-defined dictionaries does not work properly'.
Comment 7 Urmas 2013-02-19 18:25:07 UTC
For 16 month no basement dweller had an attention span enough to produce a one-liner fix...

*** This bug has been marked as a duplicate of bug 42112 ***
Comment 8 manj_k 2013-02-19 18:27:29 UTC

*** This bug has been marked as a duplicate of bug 42122 ***
Comment 9 Joel Madero 2013-02-19 18:32:57 UTC
https://wiki.documentfoundation.org/FreeDesktop_Rules_Procedures#Policies

Urmas - as you have violated #4 above, I am linking you to the official policies for FDO.