Bug 61073 - Calc, functionality request: add Support for embedded fonts in .ods file format
Summary: Calc, functionality request: add Support for embedded fonts in .ods file format
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
QA Contact: Jorendc
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-18 16:59 UTC by Gerry
Modified: 2014-11-20 22:11 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2013-02-18 16:59:00 UTC
Please add the possibility to embed fonts into the .ods file format of Calc.

This bug is a follow-up bug to bug 42195 which already completed this feature of embedding fonts in Writer files .odt.
Comment 1 Jorendc 2013-02-22 18:35:34 UTC
I didn't saw any commit passing by regarding embedded fonts in .ods, like I did in Bug 61072. Therefore I mark this as NEW.

Thanks for requesting!
Comment 2 Gerry 2013-02-22 19:11:36 UTC
@Jorendc: There seems to be a first basic patch with regards to this bug: http://cgit.freedesktop.org/libreoffice/core/commit/?id=1d0f45ee2efb5dc8d3c40f33ba1494807c117729 
As it seems, there is no UI yet.
Comment 3 Jorendc 2013-02-22 19:13:49 UTC
@Gerry: You're right; Thanks for hunting!

@Noel: this is a duplicate of an existing enhancement request (can't find any). What's the status of this?

Thanks in advance,
Joren
Comment 4 Noel Power 2013-02-25 09:22:39 UTC
there are additional commits to do with this that you missed ( which include the api )

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c4a8e6b62e80d79d98743af022b3d5e5d1f22f51

http://cgit.freedesktop.org/libreoffice/core/commit/?id=db28ed792e08d3eef3e901eaedb255bdc66d1db1

Do these fixes address the issue? I don't know, when I last tested it they didn't ( there was some bug in the the generic code that deals with font embedding ) that bug is being looked at ( don't think there is a bug number ) it could even be fixed by now, it would be worth checking the most recent master
Comment 5 Noel Power 2013-02-25 14:23:46 UTC
(In reply to comment #4)
> there are additional commits to do with this that you missed ( which include
> the api )
^^^^^^^^^
UI!!!!!
Comment 6 Lubos Lunak 2013-03-08 15:22:00 UTC
This should have been already implemented and working.
Comment 7 Gerry 2013-03-09 10:05:40 UTC
Thanks a lot. Will this be in version 4.1? 

I added it to the release notes for 4.: https://wiki.documentfoundation.org/ReleaseNotes/4.1
Comment 8 kurt.pfeifle 2014-02-12 21:11:01 UTC
The implementation does not work (at least not on v4.2.0.4 on Mac OS X). See also bug #74890
Comment 9 Joel Madero 2014-11-06 22:36:13 UTC
We need reconfirmation that this bug still exists - the bug pointed to in the last comment is closed so it's unclear if this is still an issue.

If it's not please close as RESOLVED-> FIXED. Thanks
Comment 10 raal 2014-11-20 22:11:07 UTC
For calc this works for me in LO 4.3.3, linux. I checked "embed fonts in the document" and in the ods file is folder named fonts with embedded fonts. Closing bug.