Download it now!
Bug 74890 - [Embedding fonts in document] Checkbox in "document properties" has no effect
Summary: [Embedding fonts in document] Checkbox in "document properties" has no effect
Status: RESOLVED DUPLICATE of bug 72456
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-12 14:23 UTC by kurt.pfeifle
Modified: 2014-02-13 08:17 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Screenshot of "Document Properties" dialog with "Embed fonts in the document" (32.90 KB, image/png)
2014-02-12 14:23 UTC, kurt.pfeifle
Details
Sample ODT saved with checkbox "Embed fonts in document" unchecked (79.70 KB, application/vnd.oasis.opendocument.text)
2014-02-12 14:25 UTC, kurt.pfeifle
Details
Sample ODT saved with checkbox "Embed fonts in document" enabled (79.71 KB, application/vnd.oasis.opendocument.text)
2014-02-12 14:26 UTC, kurt.pfeifle
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kurt.pfeifle 2014-02-12 14:23:11 UTC
Created attachment 93934 [details]
Screenshot of "Document Properties" dialog with "Embed fonts in the document"

If you open the "document properties" dialog (menu "File -> Properties...") and go to the "Fonts" tab there is a checkbox named "Embed fonts in document".

Checking or unchecking the box does not change anything in the saved output file. Contrary to what the UI suggests, it is not possible to embed fonts into the saved ODT document so that it may be editable on a different system where the used fonts are not locally installed.

Attached are screenshots and ODT files which demonstrate the problem.
Comment 1 kurt.pfeifle 2014-02-12 14:25:24 UTC
Created attachment 93935 [details]
Sample ODT saved with checkbox "Embed fonts in document" unchecked
Comment 2 kurt.pfeifle 2014-02-12 14:26:46 UTC
Created attachment 93936 [details]
Sample ODT saved with checkbox "Embed fonts in document" enabled
Comment 3 kurt.pfeifle 2014-02-12 14:38:06 UTC
I filed this bug against the Writer component.

Meanwhile I tested: it is not different with the Calc/Spreadsheet document.

I suspect it to be the same for all other components too.
Comment 4 Adolfo Jayme 2014-02-13 08:17:25 UTC
I don’t have a Mac, but this is very likely to be a dupe of...

*** This bug has been marked as a duplicate of bug 72456 ***