Bug 61128 - FORMATTING: Merged cells split across pages seemingly break vertical alignment of other cells
Summary: FORMATTING: Merged cells split across pages seemingly break vertical alignmen...
Status: RESOLVED DUPLICATE of bug 73955
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0 all versions
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-19 17:20 UTC by Krisztian Pinter
Modified: 2018-01-08 14:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file, see the included comment for instructions to reproduce the bug (11.04 KB, application/vnd.oasis.opendocument.text)
2013-02-19 17:20 UTC, Krisztian Pinter
Details
Screenshot showing the bug (148.70 KB, image/png)
2013-02-19 17:21 UTC, Krisztian Pinter
Details
A table with merged cells (15.83 KB, application/vnd.oasis.opendocument.text)
2015-11-02 12:03 UTC, Joe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Krisztian Pinter 2013-02-19 17:20:20 UTC
Created attachment 75122 [details]
Example file, see the included comment for instructions to reproduce the bug

If a table has a vertical cell merge, and this cell is split across two pages, all cells in the row at the bottom of the page on which the merged cell begins seem to lose their vertical alignment.
"Format/Alignment" menu shows "Center" checked when this happens.

Updating a cell in this row eg. by inserting a linebreak before the text makes the text "remember" its centeredness. Updating the row by resizing it updates all cells and fixes all of them.
Comment 1 Krisztian Pinter 2013-02-19 17:21:31 UTC
Created attachment 75123 [details]
Screenshot showing the bug
Comment 2 QA Administrators 2015-04-19 03:21:21 UTC Comment hidden (obsolete)
Comment 3 Gordo 2015-04-28 12:28:01 UTC
Can confirm.

Windows Vista 64
Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Comment 4 Joe 2015-11-02 12:03:42 UTC
Created attachment 120202 [details]
A table with merged cells

The table does not have to be split across pages, it is enough to include too much text. Just add one more letter to the last paragraph to see how "Title 2" moves to the top.
Comment 5 Joe 2015-11-02 12:11:02 UTC
Apparently this bug is triggered when adding too much content to adjacent cells. I just added a new attachment that shows the behaviour nicely. Add one more letter to the last bullet list and see hot the middle alignment of the left "Title2" moves to the top.

Tested this on Windows, Mac and GNU/Linux versions. This happens also with OpenOffice.

The files are displayed wrongly, but the formatting is correct. Opening the same files with MS Office does not show this bug.
Comment 6 QA Administrators 2016-11-08 11:57:34 UTC Comment hidden (obsolete)
Comment 7 Joe 2016-11-09 17:11:40 UTC
Still happening on Windows 7 and LO Versión: 5.2.3.3
Comment 8 Lars Jødal 2017-02-15 10:20:27 UTC
This bug appears to be a duplicate of bug 73955 (or the other way around - but IMHO, bug 73955 has the clearest and simplest example document).

*** This bug has been marked as a duplicate of bug 73955 ***