Bug 61144 - Pdf import of technical drawings gives wrong line widths and colors
Summary: Pdf import of technical drawings gives wrong line widths and colors
Status: RESOLVED DUPLICATE of bug 45065
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-19 23:58 UTC by brian.bj.parker99
Modified: 2016-05-10 12:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Original pdf (88.69 KB, application/pdf)
2013-02-19 23:58 UTC, brian.bj.parker99
Details
Pdf after opening and exporting in LO (216.25 KB, application/pdf)
2013-02-20 00:00 UTC, brian.bj.parker99
Details
Exported PDF from LO (12.62 KB, application/pdf)
2014-02-22 20:13 UTC, Luiz Angelo Daros de Luca
Details
Exported PDF from LO imported into LO (12.89 KB, application/pdf)
2014-02-22 20:19 UTC, Luiz Angelo Daros de Luca
Details
Exported PDF from M$OFFICE (85.13 KB, application/pdf)
2014-02-22 20:20 UTC, Luiz Angelo Daros de Luca
Details
Exported PDF from M$OFFICE imported into LO (14.56 KB, application/pdf)
2014-02-22 20:20 UTC, Luiz Angelo Daros de Luca
Details
pdf produced by LO draw reading in and then exporting the original pdf (193.69 KB, application/x-download)
2016-04-16 16:01 UTC, brian.bj.parker99
Details
screen shot using LO draw 5.1.2.2 after loading the original pdf (559.00 KB, image/png)
2016-04-16 16:04 UTC, brian.bj.parker99
Details

Note You need to log in before you can comment on or make changes to this bug.
Description brian.bj.parker99 2013-02-19 23:58:47 UTC
Created attachment 75142 [details]
Original pdf
Comment 1 brian.bj.parker99 2013-02-20 00:00:43 UTC
Created attachment 75144 [details]
Pdf after opening and exporting in LO
Comment 2 brian.bj.parker99 2013-02-20 00:07:51 UTC
Importing technical drawings into LibreOffice (LO) Draw for editing almost works except for a few visual artifacts. If this could be made reliable then LO would be a great alternative to Illustrator for tweaking images for scientific publications, and I am sure would be widely used for that.

I have attached a typical pdf (from the UCSC genome browser web site at:
http://genome.ucsc.edu/cgi-bin/hgTracks) and a version of the pdf after opening and exporting in LO. 

The main defects after processing by LO are that line widths are wrong and line colors are not correct.
Also, occasional lines are too long e.g. the one at "Sequences".
Text seems mostly correct (although strangely the "i" in "Zebrafish" disappeared).
Comment 3 Thomas van der Meulen 2013-06-20 17:52:31 UTC
Thank you for your bug report, I can reproduce this bug running LibreOffice Version: 4.1.0.1
Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155 on Mac osx 10.8.4.
Comment 4 Luiz Angelo Daros de Luca 2014-02-22 20:12:40 UTC
I have similar problem with current 4.2.1.1 version. LO imports its own exported PDF file changing colors completely. It's like if PDF declared a colorscheme (YMC) and LO read another (RGB). I'll attach an example (the default LO chart). However, I got not artifacts with it. 

I also did the same with an Microsoft Office chart (also exported as PDF). In this case, the colors are OK while the grid lines are misplaced. If lines are draw from bottom to up, it seems that someone forget reset the x variable for the second line and on.
Comment 5 Luiz Angelo Daros de Luca 2014-02-22 20:13:18 UTC
Created attachment 94583 [details]
Exported PDF from LO
Comment 6 Luiz Angelo Daros de Luca 2014-02-22 20:19:37 UTC
Created attachment 94584 [details]
Exported PDF from LO imported into LO
Comment 7 Luiz Angelo Daros de Luca 2014-02-22 20:20:10 UTC
Created attachment 94585 [details]
Exported PDF from M$OFFICE
Comment 8 Luiz Angelo Daros de Luca 2014-02-22 20:20:22 UTC
Created attachment 94586 [details]
Exported PDF from M$OFFICE imported into LO
Comment 9 brian.bj.parker99 2015-03-24 11:00:02 UTC
In LO 4.4.1.2 on OS-X the original examples are much improved with the only remaining defect being a horizontal line that is drawn too long.
Comment 10 tommy27 2016-04-16 07:28:53 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16
Comment 11 brian.bj.parker99 2016-04-16 16:01:48 UTC
Created attachment 124406 [details]
pdf produced by LO draw reading in and then exporting the original pdf

There remains a line extending on the left beyond the image boundary.
Comment 12 brian.bj.parker99 2016-04-16 16:04:52 UTC
Created attachment 124407 [details]
screen shot using LO draw 5.1.2.2 after loading the original pdf

In Draw (LO 5.1.2.2) the original pdf shows two lines extending to the left beyond the original figure boundary (interestingly, when the pdf is exported, only the black line remains extended in the saved pdf.)
Comment 13 Heiko Tietze 2016-05-10 12:53:41 UTC

*** This bug has been marked as a duplicate of bug 45065 ***