Bug Hunting Session
Bug 61159 - LibreOffice Can't Print From Temp Folder
Summary: LibreOffice Can't Print From Temp Folder
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-20 10:04 UTC by Frederic Parrenin
Modified: 2013-11-18 14:29 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample PDF file generated as described in my comment #14. (73.61 KB, application/pdf)
2013-11-17 19:32 UTC, Tom Williams
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Parrenin 2013-02-20 10:04:45 UTC
steps to reproduce:
- In ubuntu, open a .doc attachment in gmail
=> the file is stored in /tmp and is opened in read-only
- now print the file
=> the printing process occurs in LO but nothing is sent to the printer
This bug basically means you cannot directly open a file in gmail and print it. You have first to save the file (once you have first found out that this is the problem).
Comment 1 Jorendc 2013-07-02 22:09:24 UTC
Joel: you mind testing this as dedicated gmail user ;-)?
Comment 2 QA Administrators 2013-07-02 23:21:13 UTC
Marking as WFM - tested on Bodhi Linux with gmail. 

1. Sent file to myself
2. Download file but select "open"
-- opens read only
3. Print

Observed:
Prints fine

LibreOffice version 4.0.4 

If this is still a problem with version 4 please let us know.
Comment 3 Joel Madero 2013-07-02 23:22:50 UTC
My mistake - was logged into wrong account :-/ But yes, tested and it seems to work :)
Comment 4 Frederic Parrenin 2013-07-03 14:17:58 UTC
This bug is still present for me on ubuntu 13.04.
Maybe this is an ubuntu specific problem?
Comment 5 Joel Madero 2013-07-03 14:37:58 UTC
Can you print anything from within your temp folder? I think it's very unlikely that it's gmail specific. 

Try downloading something else from the web and open directly in LibreOffice - see if you can print.

Adding our resident Canonical employee to the mix :-D


Bjoern - thoughts on this one?
Comment 6 Frederic Parrenin 2013-07-03 14:46:24 UTC
It does not work either when directly opening the file in /tmp.
Indeed, it is not linked to gmail but rather linked to firefox, which stores the downloaded file in /tmp.
Comment 7 Frederic Parrenin 2013-07-03 15:30:18 UTC
OK, the title should be 'LO is unable to print a file opened from Firefox' but apparently, I don't have the permission to change the title.
Comment 8 Björn Michaelsen 2013-07-04 03:08:52 UTC
possibly related to: https://bugs.freedesktop.org/show_bug.cgi?id=43895
Comment 9 Björn Michaelsen 2013-07-04 03:16:58 UTC
Cant reproduce: 4.0.2 on Ubuntu Saucy (13.10) print a /tmp attachment to file just fine here.

So this needs a more specific reproduction scenario ... => NEEDINFO
Comment 10 Joel Madero 2013-07-21 03:29:36 UTC
I updated title - Freeric can you test on Version 4.0 and give us as detailed steps to reproduce as possible. Also please try with a fresh profile - which should happen with version 4 regardless but just in case https://wiki.documentfoundation.org/UserProfile. 


If the problem still exists on a fresh profile - and you provide whatever steps you can and details about your setup - mark as UNCONFIRMED and we will check it out
Comment 11 Frederic Parrenin 2013-07-22 12:24:59 UTC
Steps to reproduce:
- open any document from the internet using firefox, e.g.:
http://www.google.fr/url?sa=t&rct=j&q=&esrc=s&source=web&cd=15&cad=rja&ved=0CJ8BEBYwDg&url=http%3A%2F%2Fdpernoux.free.fr%2Ftables.doc&ei=QiTtUbfZJeWT0AXBjYCIDg&usg=AFQjCNGC8tdeuOa3S0fXb1UOU1U6qOzvrQ&sig2=ZohHSPV9t9wnWVJEGaCVow&bvm=bv.49478099,d.d2k
- print it
=> nothing is printed.

I tested with a fresh install of the latest LibreOffice and the problem still appears.
Comment 12 Joel Madero 2013-07-22 14:41:42 UTC
Again - please provide ALL information that is needed. What version of LibreOffice are you testing against? Have you tried version 4 since the bug is against 3.6.2? Also when you say "still present in 13.04", what original version did you test on (Ubuntu 12.10?)

please give as much details about your system as possible and then mark the bug as UNCONFIRMED. Until it is marked as UNCONFIRMED, QA will do little more with the bug.


Thanks
Comment 13 Frederic Parrenin 2013-07-23 13:26:51 UTC
The bug was originally discovered on Ubuntu 12.10 but it is still present on 13.04.
It has been tested using LibreOffice 4.0.2.2 as packaged by ubuntu.

Actually, the bug is not present when using LO as provided by the LO.org website (version 4.0.4.2).
So this is really an ubuntu-package specific bug.
Comment 14 Tom Williams 2013-11-17 19:31:16 UTC
I was able to "print" the sample Word document at this URL:

http://www.google.fr/url?sa=t&rct=j&q=&esrc=s&source=web&cd=15&cad=rja&ved=0CJ8BEBYwDg&url=http%3A%2F%2Fdpernoux.free.fr%2Ftables.doc&ei=QiTtUbfZJeWT0AXBjYCIDg&usg=AFQjCNGC8tdeuOa3S0fXb1UOU1U6qOzvrQ&sig2=ZohHSPV9t9wnWVJEGaCVow&bvm=bv.49478099,d.d2k

to a PDF file using LibreOffice Writer 4.1.2.3 on Ubuntu 13.10 (64-bit) just fine.  I used Firefox 25 to do this.  Here is what I did:

1)  Loaded this URL into Firefox 25: 
http://www.google.fr/url?sa=t&rct=j&q=&esrc=s&source=web&cd=15&cad=rja&ved=0CJ8BEBYwDg&url=http%3A%2F%2Fdpernoux.free.fr%2Ftables.doc&ei=QiTtUbfZJeWT0AXBjYCIDg&usg=AFQjCNGC8tdeuOa3S0fXb1UOU1U6qOzvrQ&sig2=ZohHSPV9t9wnWVJEGaCVow&bvm=bv.49478099,d.d2k

2)  Chose the option to open the file using the default application, which was LibreOffice Writer

3)  When the document loaded, I clicked "File", then "Print" to print it.

4)  When the print dialog window opened, I clicked "Options", then "Print to File".

5)  I then proceeded to print the file and was prompted to save the file. I chose to save it as a PDF file.

6)  After the save was complete, I confirmed the PDF file was properly created. I'll attach it to this bug report.

I presume "printing to file" would function similarly to printing to an actual printer.  My local printer is currently down, which is why I didn't print it to paper.

Hope this helps!

Peace...
Comment 15 Tom Williams 2013-11-17 19:32:03 UTC
Created attachment 89372 [details]
Sample PDF file generated as described in my comment #14.
Comment 16 Frederic Parrenin 2013-11-18 13:52:44 UTC
This bug is no longer present in ubuntu 13.10.
Comment 17 Joel Madero 2013-11-18 14:29:35 UTC
Since we don't know what patch or who fixed it - correct status is WFM. Thanks for the update  :)