Bug 61178 - FILEOPEN .odp from LibO 3.x: MathType equation OLE objects shown as placeholders
Summary: FILEOPEN .odp from LibO 3.x: MathType equation OLE objects shown as placeholders
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: (target:4.1.0) (target:4.0.2) (targe...
Keywords: regression
: 61548 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-20 17:52 UTC by Massimo
Modified: 2013-12-17 13:12 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the bug (179.78 KB, image/jpeg)
2013-02-20 17:52 UTC, Massimo
Details
Sample document (2.05 MB, application/vnd.oasis.opendocument.presentation)
2013-02-20 22:30 UTC, Massimo
Details
ODF Validation (18.97 KB, application/vnd.oasis.opendocument.text)
2013-02-27 18:34 UTC, Rainer Bielefeld Retired
Details
Simple presentation containing a Mathtype equation created in 3.6 (13.14 KB, application/vnd.oasis.opendocument.presentation)
2013-02-28 14:13 UTC, Massimo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Massimo 2013-02-20 17:52:07 UTC
Created attachment 75195 [details]
Screenshot of the bug

Impress 4.0 does not show OLE objects which are correctly shown by 3.6. See the attached screenshot comparing the rendering of the SAME slide by the two versions. The OLE objects are Mathtype equations.
Comment 1 Rainer Bielefeld Retired 2013-02-20 21:48:43 UTC
@pincopallino@orange.fr (In reply to comment #0):
Please attach a sample document!
Comment 2 Massimo 2013-02-20 22:30:50 UTC
Created attachment 75212 [details]
Sample document

Sample document attached. Same problem on a different PC with the same configuration (only difference Win7 64 bit instead of 32)
Comment 3 Massimo 2013-02-21 06:25:55 UTC
Requested file uploaded, change status to unconfirmed - I hope somebody will soon confirm this bug but you may perhaps need mathtype installed to see the equations.
Comment 4 A (Andy) 2013-02-21 21:42:20 UTC
Reproducible with LO 4.0.0.3 (Win7 Home, 64bit) and it worked in previous releases

This seems to be a general problem and it does not depend on and is not confined to Mathtype equation objects.

Changed Importance to High and Critical.
Comment 5 Jorendc 2013-02-27 11:44:38 UTC
*** Bug 61548 has been marked as a duplicate of this bug. ***
Comment 6 Joel Madero 2013-02-27 15:09:41 UTC
And this is not limited to just Windows. 

Marking as ALL/ALL

bibisectrequest (I will do this if no one else does within the next hour or so)
Comment 7 Joel Madero 2013-02-27 17:02:03 UTC
This sample document doesn't work with any version of LibreOffice on Linux - very strange.

Are we sure that this particular document works with 3.6?

Did you create this document with 3.6 or 4? Has this exact document been tested on 3.6 and worked on Windows?
Comment 8 Massimo 2013-02-27 17:15:08 UTC
Document created with 3.6 and works perfectly under Windows - the screenshot is the proof. No idea about Linux, I never used it. Completely messed-up with 4.0.
Comment 9 Joel Madero 2013-02-27 17:32:41 UTC
Changing back to Windows - seems like Linux is a separate issue (related)
Comment 10 Rainer Bielefeld Retired 2013-02-27 18:34:25 UTC
Created attachment 75647 [details]
ODF Validation

Already  [Reproducible] with  "LibreOffice 3.6.5.2 " German UI/ German Locale [Build-ID: 5b93205] {pull date 2013-01-18} on German WIN7 Home Premium (64bit):

I opened the sample document from LibO Start Center File dialog, already only placeholders.

Very many ODF errors in the document, I can't tell whether that might be related to the problem.

@Reporter:
Please check rour results with 3.6.5
Did you already use that sample document in an other bug?
Comment 11 Rainer Bielefeld Retired 2013-02-27 18:43:27 UTC
Here anything is unclear except that the bug exists, so back to Needinfo!

Related to "Bug 53365 - FILESAVE particular .docx as odt: Formula no longer editable" (very very vague suspect).

@Reporter:
What's the history of that document, how has it been created?
Comment 12 Rainer Bielefeld Retired 2013-02-27 19:02:36 UTC
For me already [Reproducible] with Server Installation of "LibreOffice 3.3.3  English UI/ German Locale [OOO330m19 (Build:301) tag libreoffice-3.3.3.1] on German WIN7 Home Premium (64bit) and OOo 3.1.1

I am pretty sure that this problem has nothing to do with LibO Version and / or our problems.

@reporter:
Have you MathType installed on your PC? May be a trial version what expired?

@A(In reply to comment #4):
"Worked in previous versions" is your own test result or only summary of comments before?

@Jorendc:
I doubt that "Bug 61548 - UI: Images/shapes are only displayed as OLE icons" is a DUP

@all:
May I remind yo to keep the summary up to date? "MathType" distinguishes this one from other more general OLE object problems
Comment 13 Massimo 2013-02-28 08:30:22 UTC
@Rainer Bielefeld
"I am pretty sure that this problem has nothing to do with LibO Version and / or our problems."
Then, why it worked perfectly fine up to 3.6.5.2 and the suddenly stopped working with 4.0? Same file, the only difference is LO version. Three different PCs, all with Win7, two 32 bit editions, one 64 bit edition.
Comment 14 Rainer Bielefeld Retired 2013-02-28 13:35:59 UTC
pincopallino (In reply to comment #13):
The most simple way to get some progress here is that you answer questions instead of asking new ones.

Currently we do not get that working on any PC with any Office Software. That's the difference to your problem, what appeared with 4.0. 
So your task is to contribute an instruction how to get it working with an older version (may be it will start with "install MathType).
Comment 15 Massimo 2013-02-28 13:44:37 UTC
@Rainer Bielefeld,
if you tell me how I can contribute, I'll do. But apart from sending the file that works with 3.6 and does not work with 4.0 as well as the screenshots, I have no idea what else I can do.
Others have found that the problem is not restricted to Mathtype (A  2013-02-21 21:42:20 UTC). But sure, if you install Mathtype you may have a solid starting point.
Comment 16 Rainer Bielefeld Retired 2013-02-28 13:57:26 UTC
pincopallino (In reply to comment #13):
I did  a quick test with installation of MathType, but that did not help.
I see that your sample document has been edited with LibO 4.0 (suffers from Bug 61040), so that it is not suitable as a test document. Please contribute a document as simple as possible (no background, only 1 single MathType object) created and last edited with a LibO Version where it worked for you, with menu 'Tools -> Options -> Load/Save -> General - ODF format version = 1.2 (strict!) before you save the document.

So it might be possible to see it working with an old version, the other instructions I asked can wait, until we have results with a new test document.
Comment 17 Massimo 2013-02-28 14:13:25 UTC
Created attachment 75694 [details]
Simple presentation containing a Mathtype equation created in 3.6

@Rainer Bielefeld,
I have attached a very simple presentation created following your instructions. The formula has no meaning, it's just a collection of symbols. I have not tested it with 4.0 because on this PC I have downgraded to 3.6 in order to be able keep working. I can test it this evening at home, where I have a PC still with 4.0
Comment 18 Rainer Bielefeld Retired 2013-02-28 14:29:24 UTC
@pincopallino@orange.fr  (In reply to comment #17)
Yeah, that works for me with 3.4.5, no longer NEEDINFO, more results later!
Comment 19 Joel Madero 2013-02-28 14:54:50 UTC
Works on Bodhi Linux 2.2 
Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)

with new test document. If I save it as something new and open it with 3.6.4.3 still works.

@Rainer - maybe Windows only? (seems strange to me)
Comment 20 Massimo 2013-02-28 14:58:04 UTC
By the way... I remember that when I tried to add a Mathtype under object 4.0 by the usual procedure - OLE -> Further objects - it didn't work, it showed an error message. Now I do not remember the exact message, as said I downgraded to 3.6.
Comment 21 Rainer Bielefeld Retired 2013-02-28 15:24:00 UTC
[Reproducible] with Server Installation of "LibO  4.0.0.3   -  GERMAN UI / German Locale  [Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)]"  {tinderbox: @6, pull time 2013-01-31 11:30(?)} on German WIN7 Home Premium (64bit) with separate  new User Profile 

Works fine again with 
* Server Installation of "LibO LibO  4.0.1.1 rc   -  German UI / German Locale  [Build ID: 2c0c17a6e4bee0ee28131ea4bdc47edc700d659)]"  {tinderbox: @6, pull time  2013-02-1920:00(?)} on German WIN7 Home Premium (64bit) with newly created user profile ….\LODev\4\
* Server Installation of "LibO  4.0.2.0+   -  English UI / German Locale  [Build ID: 01f8d0a1dffce854a66c0f957e81e6df6d361a8)]"  {tinderbox: @6, pull time  2013-02-26 09:45:35} on German WIN7 Home Premium (64bit) with newly created user profile ….\LODev\4\
* 4.1.0.0.alpha0+ (Build ID: 576da8db5577f84d9c7e0e40ef3e166a7938c98)
TinderBox: Win-x86@6, Branch:master, Time: 2013-02-11_23:54:45

So it seems that was a slip with 4.0.0.fix will be in 4.0.1

OLE object should be visible also without installed MathType. But for editing you will need that software installed.

@pincopallino:
Thank you for the report!
Comment 22 Massimo 2013-02-28 15:33:17 UTC
@Rainer Bielefeld,
thank you for fixing it and apologies for not being clear enough from the beginning.
Looking forward to getting 4.0.1!
Comment 23 Rainer Bielefeld Retired 2013-02-28 15:37:25 UTC
Comment on attachment 75212 [details]
Sample document

Damaged test document (from LibO 4.0.0.3), does not show OLE objects with any LibO version, so obsoleted.