Download it now!
Bug 61192 - In PDF printing mode greyscale printing not possible
Summary: In PDF printing mode greyscale printing not possible
Status: RESOLVED DUPLICATE of bug 47278
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-20 21:39 UTC by crxssi
Modified: 2014-05-16 07:55 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description crxssi 2013-02-20 21:39:52 UTC
In LO 4 when in PDF printing mode, it is not possible to print documents to color postscript printers in greyscale mode using the "Color" options in the print dialog.  This might only affect Linux/CUPS and possible MacOS/CUPS printing with postscript printers.

Steps to reproduce:

* On a Linux system with CUPS printing, open LibreOffice in PDF printing mode.
* Start Writer or Draw or Calc and create a document that contains color objects.
* File-> Print-> General, select a color postscript printer.
* File-> Print-> General-> Properties-> Device-> Color select "Greyscale"
* Print the document and it will still print in color.

If you change to Postscript printing mode (uncheck Tools-> Options-> LibreOffice-> Print-> Printer-> "PDF as Standard Print Job Format") and perform this test, the job will print in greyscale instead of color.

With our Color Xerox Phaser there is a suitable workaround because in the PPD there is a variable called "Color Correction." That can be set to "Black and White" under "device" in the LO print dialog and it works under both PDF and PS printing.  But not all printers will have such an option and users wishing to avoid unnecessary, expensive color printing might have no options (other than to change to postscript printing mode).

Tested with LibreOffice 4.0.0 under RHEL 6 using CUPS 1.4.2 and traditional PPD files.
Comment 1 Joel Madero 2013-02-20 22:10:37 UTC
Hey crxssi,

Can you just quickly tell me what "open LibreOffice in PDF printing mode" means, I've never heard of it before. I'll confirm this one as soon as I know what that means. 

This may go under enhancement request depending on my findings. 

Thanks for reporting these tricky print issues
Comment 2 crxssi 2013-02-20 23:28:52 UTC
(In reply to comment #1)
> Can you just quickly tell me what "open LibreOffice in PDF printing mode"
> means, I've never heard of it before. I'll confirm this one as soon as I
> know what that means. This may go under enhancement request depending on
> my findings. 

When I said "open LibreOffice in PDF printing mode" I meant to launch LibreOffice, and make sure you are in the PDF printing mode for the test.

LibreOffice currently has two ways to deal with printing (at least it does under Linux, I don't use MacOS or MS-Windows, so I can't speak to those).  Recently it was switched to be PDF mode, which is the new default method of printing for LibreOffice.  This means that when LibreOffice prints, it actually generates a PDF file and sends that to CUPS (the Common Unix Printing System).  This is relatively new behavior.  The other/older/traditional method is that LibreOffice creates a Postscript file when you print and sends that to CUPS.

The mode is controlled via Tools-> Options-> LibreOffice-> Print-> Printer-> "PDF as Standard Print Job Format."  The default is PDF (the box will be checked).   If you uncheck the box, you will be notified to restart LibreOffice and then printouts will be generated in PS (PostScript) instead of PDF (Portable Document Format).

Since greyscale printing used to work under PS printing and now it does not under PDF, I consider it a regression.  The field that controls if the output should be color or black and white does nothing useful anymore.
Comment 3 Joel Madero 2013-04-14 18:59:59 UTC
hey crxssi -

so I can confirm the behavior, what I'm unsure about are two things:

1. Regression - to me this is basically an enhancement request. While I understand that you're saying our default used to be PS and bw worked, now it's PDF and it doesn't, the feature wasn't implemented into print to PDF and therefore it's an additional feature you are requesting.  But this is a tough case which I will be bringing up during our next QA call, basic question is:

"what constitutes a regression, is it end user experience regardless of it's not the same exact feature being looked at" or is it "a feature that used to behave like x, now does not, and therefore is a regression"

Personally I lean towards #2, especially in this case as you can still do PS printing and get the behavior you are looking for.

Lastly, unless I am mistaken you can use the printer itself to just print in grayscale, even if the document is in color, because of this alone I think this is quite minor -> very easy workaround.

Please correct me if I'm wrong anywhere. For now:

Marking as:
New - confirmed
Minor - doesn't prevent high quality work, can slightly slow it down
Low - easy work around for anyone who wants to print grayscale, simply use the printer settings to do so.
Comment 4 crxssi 2013-04-14 20:28:11 UTC
I totally agree that it is minor issue and low priority, especially since we had to revert to PS printing (due to the MUCH more serious bug 61189 ) and it works OK in PS.  Seems odd to classify it as a feature request, but whatever ya gotta do!

As far as specifying with the printer- yes, on most PPD files for color printers, there is an option for choosing color or non-color.  I believe the one we use has such an option.  So that is another workaround.
Comment 5 Joel Madero 2013-05-29 15:41:56 UTC
Apparently not the first one to request this :)

Duplicate of 47278

*** This bug has been marked as a duplicate of bug 47278 ***
Comment 6 crxssi 2013-05-29 22:57:36 UTC
(In reply to comment #5)
> Apparently not the first one to request this :)
> 
> Duplicate of 47278
> 
> *** This bug has been marked as a duplicate of bug 47278 ***

I don't really see this as a duplicate of Bug 47278 although I can see they are related.

When you export as a PDF, there is no option at all for specifying color or not. That is what Bug 47278 apparently seeks.

THIS bug (61192) has to do with printing documents from LO with the new PDF engine ignoring the file->print->properties->device->color setting. It produces a color print job regardless.  Has nothing to do with PDF files or PDF exporting.
Comment 7 Jesus Caudeli 2014-05-16 07:55:56 UTC
(In reply to comment #4)
> I totally agree that it is minor issue and low priority, especially since we
> had to revert to PS printing (due to the MUCH more serious bug 61189 ) and
> it works OK in PS.  Seems odd to classify it as a feature request, but
> whatever ya gotta do!
> 
> As far as specifying with the printer- yes, on most PPD files for color
> printers, there is an option for choosing color or non-color.  I believe the
> one we use has such an option.  So that is another workaround.

Did you revert the whole CUPS behaviour to print using PS instead of PDF? How did you do it? I really need to know it.

I have the same issue, and I think it's not a problem of LO but of CUPS. I can't print in grayscale from ANY application. At least in LO I can make the workaround choosing PS, but what can I do with the other software?

I think reverting to PS printing would fix this, but I can't find how to do it, and I'm also worried of creating new problems caused by the "regression".

Thanks in advance

  Jesús