Bug Hunting Session
Bug 61224 - EDITING: Footers/headers break SHIFT+PGDN selection
Summary: EDITING: Footers/headers break SHIFT+PGDN selection
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All Linux (All)
: highest normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-02-21 10:33 UTC by Krisztian Pinter
Modified: 2016-01-19 07:20 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Multipage document for easier testing (27.39 KB, application/vnd.oasis.opendocument.text)
2013-02-21 10:33 UTC, Krisztian Pinter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Krisztian Pinter 2013-02-21 10:33:11 UTC
Created attachment 75245 [details]
Multipage document for easier testing

Overview:

Inserting a footer/header in a document make SHIFT+PGDN selection stop randomly. Deleting the footer/header doesn't solve the problem.

Steps to Reproduce: 

1) Open a multipage document. (See attachment for one.)

2) Press SHIFT+PGDN when at the top of the document. Observe that page selection works.

3) Insert a footer.

4) Try selecting pages with SHIFT+PGDN again, from the top of the document. Observe that page selection stops randomly, regardless of repeated SHIFT+PGDN presses.

5) Delete the footer.

6) SHIFT+PDGN still doesn't work.
Comment 1 Cor Nouws 2013-02-21 11:03:09 UTC
thanks for the report.
I've noticed the breaking of selection too, but never spent time to find out what caused it ...
A quick test confirms that inserting a header on the second page, indeed causes the effect. And removing a sort of reverts it.

It's an older problem: started in LibreOffice 3.5.0. And introduced with the (neat) new header/footer funcionality.

I do not see it in 3.5.0 beta (Build ID: ef91e38-b1d4df6-090bcba-45cf606-05891e7)
Comment 2 Cor Nouws 2013-02-21 11:04:10 UTC
@Krisztian Can you confirm that selecting with Shift + arrows does work properly?
Comment 3 Cor Nouws 2013-02-21 11:04:45 UTC
(platform to all, since I run Ubuntu on x86)
Comment 4 Krisztian Pinter 2013-02-21 11:11:07 UTC
(In reply to comment #2)
> @Krisztian Can you confirm that selecting with Shift + arrows does work
> properly?

@Cor Yep, Shift+arrows work properly for me, with and without footers.
Comment 5 jcompton 2014-02-06 22:03:37 UTC
I have been encountering this bug on OSX release versions 4.1 and 4.2, regardless of headers and footers. The selection always breaks after no greater than two PGDN keypresses.
Comment 6 Joel Madero 2015-05-02 15:41:10 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 7 Cor Nouws 2015-05-03 10:19:54 UTC
still a problem on 4.4.3.2
Speaking with a developer here, he suggests this to be a MAB. It's extremely annoying in selecting.
Will mark as such.
Comment 8 Cor Nouws 2015-10-03 09:28:52 UTC
reading good news in https://bugs.documentfoundation.org/show_bug.cgi?id=94679#c4

When that is applied, should be available in daily's soon and give the opportunity to test and backport :)
Comment 9 Justin L 2016-01-19 07:20:05 UTC
Unable to reproduce anymore in 4.4.7, 5.0.4 or 5.1.   Marking as "Works for me" since various code changes have resolved the problem.