Download it now!
Bug 61230 - writer slow scrolling when svg image in document
Summary: writer slow scrolling when svg image in document
Status: RESOLVED DUPLICATE of bug 58420
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.1 rc
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-02-21 13:36 UTC by Roberto braga
Modified: 2013-11-19 00:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The exampledoc with the svg (68.23 KB, application/vnd.oasis.opendocument.text)
2013-02-21 13:36 UTC, Roberto braga
Details
The svg file (9.61 KB, image/svg+xml)
2013-02-21 13:41 UTC, Roberto braga
Details
svg rendered in yEd (4.20 KB, image/svg+xml)
2013-03-16 12:50 UTC, Glutanimate
Details
svg rendered in LaTex/Inkscape (17.36 KB, image/svg+xml)
2013-03-16 12:51 UTC, Glutanimate
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roberto braga 2013-02-21 13:36:24 UTC
Created attachment 75250 [details]
The exampledoc with the svg

I have a doc with an svg image in it.
When you scroll the doc it get very slow when scrolling the image.
I tried with the same image but as png and no problem.

The doc with LO 3.5 was working perfectly with svg.
Attached a document that has the same behaviour.
Comment 1 Roberto braga 2013-02-21 13:41:21 UTC
Created attachment 75251 [details]
The svg file

If it can help the svg file was generated using Yed http://www.yworks.com using the export function
Comment 2 Thomas van der Meulen 2013-02-21 15:25:31 UTC
Thank you for reporting this bug,
I can reporduce this bug running LibreOffice 4.0.1.1 rc on Mac osx 10.6.8.
Comment 3 Glutanimate 2013-03-16 12:50:36 UTC
Created attachment 76605 [details]
svg rendered in yEd

I can confirm this bug on with LO 4.0.2.1 pre-release but I can't confirm it with LO 3.6.5.2, so this appears to be a regression introduced with 4.x.

I have attached two additional test cases, one rendered in yEd and one with LaTex/Inkscape. Scrolling speed seems to depend on the scaling: The larger the SVG, the worse the performance.
Comment 4 Glutanimate 2013-03-16 12:51:39 UTC
Created attachment 76606 [details]
svg rendered in LaTex/Inkscape
Comment 5 Glutanimate 2013-03-16 12:52:14 UTC
My platform is Ubuntu 12.04.2 LTS.
Comment 6 Glutanimate 2013-03-16 13:00:19 UTC
This bug might be related:

https://bugs.freedesktop.org/show_bug.cgi?id=61899
Comment 7 ape 2013-03-20 11:59:11 UTC
(In reply to comment #6)
> This bug might be related:
> 
> https://bugs.freedesktop.org/show_bug.cgi?id=61899

Look at bug 62461 please.
Comment 8 A. Fakhouri 2013-04-17 20:26:00 UTC
I can confirm this issue in version 4.0.2.1 on Fedora i686. not only when using svg, but also when using big and/or multiple images, especially when some image(s) is/are transparent. This also affects exporting to PDF. This issue exists in earlier versions as well.
Comment 9 Björgvin Ragnarsson 2013-05-15 20:23:19 UTC
results from bibisecting with bibisect-4.0:

$ git bisect start latest oldest
Bisecting: 129 revisions left to test after this (roughly 7 steps)
[16b0b88cbd4ef0f51816e97277e40c5cf78f7bf9] source-hash-099198a4224778fe6e43f5dc13b5b9b1b4dc828c
$ git bisect good
Bisecting: 64 revisions left to test after this (roughly 6 steps)
[f28b8f9a6c47fa59bf98fffe937a2f2db7a2445a] source-hash-a581d31b227623e09d2970a91214fda398f98eda
$ git bisect skip # the image disappears less than a second after the file is opened - scrolls correctly
Bisecting: 64 revisions left to test after this (roughly 6 steps)
[aefa1263d1642e8d9677d385f492530ae0725fc6] source-hash-e63bba0013e5ce34cd04559632206bb7c891eebe
$ git bisect good
Bisecting: 26 revisions left to test after this (roughly 5 steps)
[1bd592a0f084c04b718ab1ec1cfbe1565f5e9b6c] source-hash-1692cf6854ff7adbb2bd47f2f7ec2b3de51864f3
$ git bisect good
Bisecting: 12 revisions left to test after this (roughly 4 steps)
[5dddcff8ae35692d89751ae98ab8acbbf802b5b4] source-hash-d85fd8a85501547d5bb87822d2589a07aed7f2d6
$ git bisect skip # the image doesn't appear - scrolls correctly
Bisecting: 12 revisions left to test after this (roughly 4 steps)
[47498a36f7af8f54e6e3dda89cd4708802a409e6] source-hash-19f4ebd8a54da0ae03b9cc8481613e5cd20ee1e7
$ git bisect skip # the image doesn't appear - scrolls correctly
Bisecting: 12 revisions left to test after this (roughly 4 steps)
[eb01a04acbb7373331312a2ee3d9d90d20548fca] source-hash-ce90f99a2d66c2b998ad3f9f028e2ea623a757f5
$ git bisect bad
Bisecting: 11 revisions left to test after this (roughly 4 steps)
[915b1e16f20d5ce2a32f911ef051103455600845] source-hash-9210b95bcfd65ae558f445666d9b880e794d4c74
$ git bisect skip # the image doesn't appear - scrolls correctly
Bisecting: 11 revisions left to test after this (roughly 4 steps)
[5655f1571312ca27537c9c147c69d6431986b76d] source-hash-b67a51b40a4876f4bd97a2917103112006710b0c
$ git bisect bad
Bisecting: 10 revisions left to test after this (roughly 3 steps)
[9ec4be63ed5281f2e9364b140da69291c7abc348] source-hash-a1ac2538e9b287444500618ab4d2f0f06c25cf34
$ git bisect skip # the image doesn't appear - scrolls correctly
Bisecting: 10 revisions left to test after this (roughly 3 steps)
[66083171ba534818399937597388d325091fffab] source-hash-9d83ad0e99ab182506be99f7d6a2bec7f6fbe8c6
$ git bisect bad
Bisecting: 8 revisions left to test after this (roughly 3 steps)
[7b32edd2389319e0d394368c4109201528c41f7e] source-hash-44b96a2fce52b6e3e683dc917fab219cf75001db
$ git bisect skip # the image doesn't appear - scrolls correctly
Bisecting: 8 revisions left to test after this (roughly 3 steps)
[7f50375c2cf8bf1e026f61f11ae9666648687164] source-hash-d281a19e1d06856f863788f3344ad42ed1566669
$ git bisect good
Bisecting: 7 revisions left to test after this (roughly 3 steps)
[769583027b0158ac4b497355b0495fca5c54f53b] source-hash-a43a76cd5aa2f145f2cb43fcdbc8f21fb6c89af0
$ git bisect skip # the image doesn't appear - scrolls correctly
Bisecting: 7 revisions left to test after this (roughly 3 steps)
[fb4214f9d134b556582a4a5280e5458de5f8eebd] source-hash-683758efb22d08a4cf211a6d985148f513da2a90
$ git bisect skip # the image doesn't appear - scrolls correctly
Bisecting: 7 revisions left to test after this (roughly 3 steps)
[b17eb9ea515cf4b5bf60dd2b6860febf0806a9bd] source-hash-b6c016da23d309b4ac7d154bc33a22397974ed73
$ git bisect skip # the image doesn't appear - scrolls correctly
Bisecting: 7 revisions left to test after this (roughly 3 steps)
[9a5620ca6473969359f262802c76daf35cbcbb5d] source-hash-ae4e4a11d4300f7448cb6bd170fcb034542caddc
$ git bisect skip # the image doesn't appear - scrolls correctly
Bisecting: 7 revisions left to test after this (roughly 3 steps)
[6095212a5bd192017c6a20ee10de26a163372e8c] source-hash-a599f5b4b51848e3b397d471c9d12b373caadcef
$ git bisect skip # the image doesn't appear - scrolls correctly
Bisecting: 7 revisions left to test after this (roughly 3 steps)
[99fa32bfa0d6116217da0834f3a630b3775aa16a] source-hash-246ffb108c7e1f762f8d497750ad2414b85b99ef
$ git bisect bad
Bisecting: 5 revisions left to test after this (roughly 3 steps)
[e2e46267c18c2706de771a08472ebfce19f68520] source-hash-4316e643ef345b0f673b4a03a80a4b7cb3185588
$ git bisect good
Bisecting: 5 revisions left to test after this (roughly 3 steps)
[fad6aba1675531a031872af655be5756c5012cb9] source-hash-d38a2e3ea04d354492df18aa16d2304babe87dfb
$ git bisect bad
There are only 'skip'ped commits left to test.
The first bad commit could be any of:
47498a36f7af8f54e6e3dda89cd4708802a409e6
9ec4be63ed5281f2e9364b140da69291c7abc348
769583027b0158ac4b497355b0495fca5c54f53b
7b32edd2389319e0d394368c4109201528c41f7e
6095212a5bd192017c6a20ee10de26a163372e8c
915b1e16f20d5ce2a32f911ef051103455600845
b17eb9ea515cf4b5bf60dd2b6860febf0806a9bd
fb4214f9d134b556582a4a5280e5458de5f8eebd
5dddcff8ae35692d89751ae98ab8acbbf802b5b4
9a5620ca6473969359f262802c76daf35cbcbb5d
fad6aba1675531a031872af655be5756c5012cb9
We cannot bisect more!
Comment 10 Björgvin Ragnarsson 2013-05-15 20:43:53 UTC

*** This bug has been marked as a duplicate of bug 58420 ***