Download it now!
Bug 61278 - FORMATTING: Connectors created in Draw and pasted into Writer don't appear after saving/reopening
Summary: FORMATTING: Connectors created in Draw and pasted into Writer don't appear af...
Status: RESOLVED DUPLICATE of bug 62617
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-02-22 13:10 UTC by Joao Campos
Modified: 2013-03-22 16:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joao Campos 2013-02-22 13:10:21 UTC
Problem description: 
When pasting flowchart from Draw to Writer, smart connectors disappear after saving/reopening.

Steps to reproduce:
1. Create a simple flowchart in Draw that includes connectors.
2. Copy that flowchart to a new Writer document.
3. Save and close the Writer document.
4. Reopen the Writer document.

Current behavior:
The connectors aren't visible, although they reappear if you copy/paste into Draw.

Expected behavior:
The connectors should be visible.
Operating System: Windows 7
Version: 4.0.0.3 release
Comment 1 Joel Madero 2013-02-22 16:45:39 UTC
Version 4.1.0.0.alpha0+ (Build ID: 9601a571d42b0199bdccf2256fc8be82e14af8a)
Date:   Mon Feb 18 23:22:17 2013 +0100
Bodhi Linux 2.2

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

New (confirmed)
Major (can prevent high quality/professional work, looks like a loss of data, would be an issue if you sent a document that looked fine but upon saving it messes up connectors)
High (default, no need to change this)


@Joao - did you happen to notice if this issue existed in 3.6?
Comment 2 Joao Campos 2013-02-22 16:55:22 UTC
Don't know about 3.6, but I just tried it on a 3.3.0 and this bug doesn't occur.
Comment 3 Joao Campos 2013-02-22 17:03:16 UTC
Tested it on 3.6.1 and this bug also doesn't occur.
Comment 4 Joel Madero 2013-02-22 18:26:28 UTC
Thanks for the additional info:

adding:

Whiteboard - bibisectrequest (I'll do this myself if no one else tackles it shortly)

Keywords - Regression
Comment 5 Michael Stahl (CIB) 2013-03-22 16:31:40 UTC
this was introduced by same commit as bug 62617

*** This bug has been marked as a duplicate of bug 62617 ***