Bug 62617 - displaying of object groups having subobjects on different layers is broken
Summary: displaying of object groups having subobjects on different layers is broken
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: David Tardon
URL:
Whiteboard: BSA target:4.1.0 target:4.0.2 target:...
Keywords: regression
: 61278 62233 62718 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-03-21 23:22 UTC by Gajdos Tamás
Modified: 2013-06-19 15:25 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
The inserted drawing has missing lines. (31.62 KB, application/vnd.oasis.opendocument.text)
2013-03-21 23:22 UTC, Gajdos Tamás
Details
The export to pdf, when it was still good. (110.22 KB, application/pdf)
2013-03-21 23:24 UTC, Gajdos Tamás
Details
The drawings file, which contains the used drawings (16.52 KB, application/vnd.oasis.opendocument.graphics)
2013-03-21 23:25 UTC, Gajdos Tamás
Details
reproducer for broken handling of groups having subobjects on different layers (10.22 KB, application/vnd.oasis.opendocument.graphics)
2013-03-24 13:35 UTC, David Tardon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gajdos Tamás 2013-03-21 23:22:18 UTC
Created attachment 76883 [details]
The inserted drawing has missing lines.

Problem description: 
The insterted drawing has missing lines and shapes in it.

Steps to reproduce:
0. Copy a drawing from an older file to a new one.
1. Insert a previously copy/pasted drawing from a LibreOffice Drawing file to a Writer file.
2. Save the file
3. Reopen the file

Current behavior:
Save does not work.
Expected behavior:
To reopen the file as I left it.
              
Operating System: Ubuntu
Version: 4.0.1.2 release
Comment 1 Gajdos Tamás 2013-03-21 23:24:17 UTC
Created attachment 76884 [details]
The export to pdf, when it was still good.
Comment 2 Gajdos Tamás 2013-03-21 23:25:07 UTC
Created attachment 76885 [details]
The drawings file, which contains the used drawings
Comment 3 Gajdos Tamás 2013-03-21 23:28:48 UTC
I have installed this libreoffice version from the ppa for precise https://launchpad.net/~libreoffice/+archive/libreoffice-4-0

On windows with a 4.0.0.x version it works. The save is ok.
Comment 4 Michael Stahl (CIB) 2013-03-22 14:28:23 UTC
indeed copy any of the shapes in the ODG bugdoc to Writer,
save and reload, only some boxes remain.

regression was introduced between 4.0 beta 2 and 4.0 RC1
by this commit:

commit 75118d2f9ebdf96250d3a4c78b695085c3527e4e
Author: David Tardon <dtardon@redhat.com>
Date:   Tue Dec 18 15:24:28 2012 +0100

    fdo#56267, fdo#56980 propagate shape change to subclasses
    
on master i'm getting even more annoying problems, can't paste
to Writer at all, last known working version was 5a61e283.
i have already fixed an exception from FontEmbed feature
but it still doesn't work, will try to bisect a bit...
Comment 5 Michael Stahl (CIB) 2013-03-22 16:31:40 UTC
*** Bug 61278 has been marked as a duplicate of this bug. ***
Comment 6 David Tardon 2013-03-23 12:24:29 UTC
the stuff is still there, it's just not displayed...
Comment 7 Michael Stahl (CIB) 2013-03-23 22:06:54 UTC
the other master regression breaking copy/paste is:

commit a82f7b20539e60f1cf599afcceaf865bef297a66
Author: Michael Meeks <michael.meeks@suse.com>
Date:   Tue Feb 26 15:25:22 2013 +0000

    port horrible tools temp directory abstraction to sal.

which causes ConstructTempDir_Impl caller of GetSystemTempDirPath_Impl
to see a system path instead of a file URL.

this was then fixed by 916d898209449bc88edfbf0d7a727bd0945124b7.

then this commit breaks it again:

commit a548924aece3dc99b2aa36b5c9b0fa52de9951ae
Author: Thomas Arnhold <thomas@arnhold.org>
Date:   Wed Mar 6 02:24:16 2013 +0100

which unfortunately introduces a different regression of calling CreateTempName_Impl with bDir=True from the no-argument TempFile ctor,
creating a directory instead of a file.
(although granted the code in ConstructTempDir_Impl removed
 in this commit is really ridiculous)

which gets me to the question why we need to refactor the horrible
tools fsys code in the first place; isn't the goal to get rid of that?

so with 2098b720dd9cdfef5b214802f0b37f49ad42982c at least pasting
works again on master now;
doesn't do anything for the 4.0 branch which dtardon is fixing.
Comment 8 David Tardon 2013-03-24 13:34:40 UTC
dtardon->mstahl: I am innocent :-)
Comment 9 David Tardon 2013-03-24 13:35:34 UTC
Created attachment 76961 [details]
reproducer for broken handling of groups having subobjects on different layers
Comment 10 Commit Notification 2013-03-24 13:41:37 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=09d4525b11f396a68ca7c5cbb1ae3462db40c77c

fdo#62617 display groups on multiple layers correctly



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Gajdos Tamás 2013-03-24 14:02:56 UTC
Thank you very much for fixing this problem.
I also found a workaround: I had to "Arrange" the drawing "To Foreground", and the missing lines reappered.
Comment 12 Commit Notification 2013-03-24 14:52:04 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7016708ef411a7112c2acc504441ef7c10f570cc&h=libreoffice-4-0

fdo#62617 display groups on multiple layers correctly


It will be available in LibreOffice 4.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Thomas Arnhold 2013-03-24 17:08:20 UTC
Sorry, my fault. But for my conscience I must say that it was on gerrit (https://gerrit.libreoffice.org/#/c/2558/)...

I didn't really know that the tools folder at all is obsolete and will get removed in the future.
Comment 14 David Tardon 2013-03-25 10:03:38 UTC
*** Bug 62718 has been marked as a duplicate of this bug. ***
Comment 15 Michael Meeks 2013-03-25 10:10:29 UTC
> which gets me to the question why we need to refactor the horrible
> tools fsys code in the first place; isn't the goal to get rid of that?

Grief - sorry for that. Yes, there's currently an intern writing out tools/fsys - we hope to have every call-site removed in the next few weeks: though that is a new initiative. Duplicating that /tmp/ dir creation stuff all over the place is a problem that looked more tractable at least to me then.

Thanks for fixing it !
Comment 16 Commit Notification 2013-03-25 20:45:24 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-0-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3535986f37406508b2fd84f6a79ed1c4f33b3e8a&h=libreoffice-4-0-2

fdo#62617 display groups on multiple layers correctly


It will be available already in LibreOffice 4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 17 David Tardon 2013-05-03 14:03:29 UTC
*** Bug 62233 has been marked as a duplicate of this bug. ***
Comment 18 Commit Notification 2013-06-19 15:25:51 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ff7280bbb169deaaa5b813ba07a7bfdb715a0482&h=libreoffice-3-6

fdo#62617 display groups on multiple layers correctly


It will be available in LibreOffice 3.6.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.