Download it now!
Bug 62718 - EDITING: Paste of drawing from DRAW into WRITER looses parts of the diagram
Summary: EDITING: Paste of drawing from DRAW into WRITER looses parts of the diagram
Status: RESOLVED DUPLICATE of bug 62617
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-25 09:54 UTC by mr.banana
Modified: 2013-03-25 10:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
I have attached the original drawing example dtest1.odg (9.97 KB, application/vnd.oasis.opendocument.graphics)
2013-03-25 09:54 UTC, mr.banana
Details
Here is the document (dtest2.odt) that was pasted into for the two tests (14.62 KB, application/vnd.oasis.opendocument.text)
2013-03-25 09:56 UTC, mr.banana
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mr.banana 2013-03-25 09:54:09 UTC
Created attachment 76985 [details]
I have attached the original drawing example dtest1.odg

Problem description: 

If I paste a diagram from draw into a text document parts of the drawing such as associated text boxes disappear, but only after the document has been saved and re-openend.

Steps to reproduce failure:
1. Select all of the diagram in dtest1.odg and Edit->Copy
2. Now open new text document and Edit->Paste it there
3. Save, then close the text document
4. Re-open the text document and the top and bottom text boxes are gone

This works:
1. Repeat the Copy operation 1. from the drawing document
2. Do Edit->Paste Special and choose GDI metafile as the type
3. Save and close the document
4. Re-open the text document and the drawing is correct

Current behavior:
Loss of some parts of pasted image after saving and re-opening file.

Expected behavior:
All of the image should be preserved

              
Operating System: Ubuntu
Version: 4.0.0.3 release
Comment 1 mr.banana 2013-03-25 09:56:18 UTC
Created attachment 76986 [details]
Here is the document (dtest2.odt) that was pasted into for the two tests
Comment 2 David Tardon 2013-03-25 10:03:38 UTC

*** This bug has been marked as a duplicate of bug 62617 ***