Bug 61331 - UI: Dialog 'format - AutoFormat' deletes first item in styles list together with intendedly deleted one
Summary: UI: Dialog 'format - AutoFormat' deletes first item in styles list together w...
Status: RESOLVED DUPLICATE of bug 94173
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.0.alpha1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-23 08:35 UTC by t.guilbert17
Modified: 2015-09-16 12:17 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description t.guilbert17 2013-02-23 08:35:15 UTC
Problem description: 
Deleting an autoformat style or unselecting an option erases the first item

Steps to reproduce:
1. Select cells
2. Go into the "Format/Autoformat" menu
3. Select a style to delete or unselect an option
4. Press the "Ok" or "Close" button
5. Re-enter into "Format/Autoformat" menu

Current behavior:
The first item has been deleted too.

Expected behaviors:
- When we want to delete an autoformat style, erase only the selected item.

- Selected or unselect an option into the autoformat window doesn't delete the first item of the list box.

Good luck !

              
Operating System: Windows 7
Version: 4.0.1.1 rc
Comment 1 Thomas van der Meulen [retired] 2013-02-23 09:01:57 UTC
Thank you for reporting this bug,
I can reproduce this bug running LibreOffice 4.0.1.1 rc on Mac osx 10.6.8.
Comment 2 Rainer Bielefeld Retired 2013-02-23 09:50:21 UTC
Already [Reproducible] with Server installation of  Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 475d0c5-829fc92-39746e8-206648e-fefd87]" (2012-02-14)

@Spreadsheet Team
Please change  Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf (and remove others in team from CC)
Comment 3 harryparry2011 2014-04-16 18:56:46 UTC
Reproducible in LO Version: 4.2.3.3 (Build-ID: 882f8a0a489bc99a9e60c7905a60226254cb6ff0) running Win7 Home 64bit
Comment 4 QA Administrators 2015-06-08 14:41:46 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.3 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results;
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-06-08
Comment 5 Julien Nabet 2015-09-16 12:17:41 UTC

*** This bug has been marked as a duplicate of bug 94173 ***