Download it now!
Bug 61370 - SLIDESHOW: During presentation, objects with transitions and text boxes inside superpose each other
Summary: SLIDESHOW: During presentation, objects with transitions and text boxes insid...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: Other Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-23 22:40 UTC by Francisco
Modified: 2016-05-01 09:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
File created with LibO 4.0.0.3, which exhibits the problem (30.39 KB, application/vnd.oasis.opendocument.presentation)
2013-02-23 22:43 UTC, Francisco
Details
another test with different disposition (25.38 KB, application/vnd.oasis.opendocument.presentation)
2013-03-07 19:03 UTC, Francisco
Details
Screenshot of the presentation with LibO 4.0.3 (68.48 KB, image/png)
2013-05-12 03:21 UTC, Francisco
Details
Presentation which shows the problem (215.49 KB, application/vnd.oasis.opendocument.presentation)
2013-06-06 18:31 UTC, Francisco
Details
Screenshot of Slideshow on Ubuntu 12.04 (149.41 KB, image/png)
2013-06-07 04:07 UTC, ign_christian
Details
Screenshot of Slideshow on Ubuntu 12.04 (H/W accel enabled) (159.71 KB, image/png)
2013-06-07 05:18 UTC, ign_christian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco 2013-02-23 22:40:10 UTC
Problem description: 
File: Presentation with objects, each of one has personalized animation. 
During a presentation, text boxes of these animated objects (chart and text boxes) superpose each other.

Steps to reproduce:
1. Make a chart (one with text inside), add it an animation.
2. Add some text box, with an animation. It should appear after the first chart
3. Add another chart. It could have text, and animate it. 
4. Add some text box and animate it.
5. etc...

Current behavior:
During the presentation, text from objects that are below appear over objects that are above

Expected behavior:
Text from underneath objects should remain below the objects that are above.
              
Operating System: Ubuntu
Version: 4.0.0.3 release
Comment 1 Francisco 2013-02-23 22:43:48 UTC
Created attachment 75428 [details]
File created with LibO 4.0.0.3, which exhibits the problem

Although this problem is present in LibO 4, I already found it in LibO 3.4, 3.5 and 3.6.
Comment 2 Jorendc 2013-02-23 23:32:57 UTC

*** This bug has been marked as a duplicate of bug 59629 ***
Comment 3 Francisco 2013-02-24 00:12:48 UTC
I'm not sure it's the same bug, although they are maybe related. Just because it seems to be that bug 59629 is a regresion, and I have been experimenting this bug since 3.4 era...
Comment 4 Jorendc 2013-02-24 15:26:26 UTC
(In reply to comment #3)
> I'm not sure it's the same bug, although they are maybe related. Just
> because it seems to be that bug 59629 is a regresion, and I have been
> experimenting this bug since 3.4 era...

Ok, I'm sorry about that.
Therefore I mark this bug as a 3.4 bug (this is the oldest version you can reproduce the problem).
Comment 5 Jorendc 2013-02-24 15:29:17 UTC
I can confirm this behavior using Linux Mint 14 x64 using LibreOffice 4.0.1.1 release.
Comment 6 Francisco 2013-03-06 13:23:47 UTC
It seems to be that this does not happens *only* with LibO charts (I mean, the OLE object)... but also with charts pasted as GDI metafiles. I checked this because I though it could be a workaround, but it didn't work
Comment 7 Francisco 2013-03-07 00:31:42 UTC
Still reproducible with LibO 4.0.1 on Kubuntu 12.04 with packages downloaded from LibO site.
Comment 8 Francisco 2013-03-07 19:03:54 UTC
Created attachment 76131 [details]
another test with different disposition

I have checked that this problem happen just when there is a textbox over the chart, as this new file attached (exampl2.odp) shows, with LibO 3.5.7 and 4.0.0.
Comment 9 ign_christian 2013-05-12 02:31:00 UTC
I see nothing wrong with LO 4.0.3.3 (Win7 Home Premium 32bit)
Animations play as ordered (but I think direction & speed are not proper)
Comment 10 Francisco 2013-05-12 03:21:56 UTC
Created attachment 79185 [details]
Screenshot of the presentation with LibO 4.0.3


I can still reproduce it with Linux 

(In reply to comment #9)
> I see nothing wrong with LO 4.0.3.3 (Win7 Home Premium 32bit)
> Animations play as ordered (but I think direction & speed are not proper)

Ign:

Animations are displayes in correct order, I didn't stayed that that was the problem, but that text of below objects appear over above objects, as in this screenshot, using LibO 4.0.3 on Kubuntu 12.04 64 bits
Comment 11 Francisco 2013-05-12 04:12:29 UTC
Interestingly, I'm not able to reproduce it under Windows XP SP2 32 bits, although I have been able to do it with previous versions
Comment 12 ign_christian 2013-05-14 14:42:24 UTC
Set status to UNCONFIRMED 

Because we need confirmations from other Linux tester as on Win7 it's not reproducible
Comment 13 ign_christian 2013-05-18 05:50:49 UTC
Strange...I don't see this bug with LO 3.6.6.2 (Ubuntu 12.04 32bit, system updated today)

Both my 32bit system on LO 4.0.3 (Win7) & LO 3.6.6 (Ubuntu 12.04) showed same result.

This bug specific to 64bit system?
Comment 14 Francisco 2013-05-18 16:57:25 UTC
> Because we need confirmations from other Linux tester as on Win7 it's not 
> reproducible

As I said, in Win XP either :-/

In reply to comment #13)
> Strange...I don't see this bug with LO 3.6.6.2 (Ubuntu 12.04 32bit, system
> updated today)
> 
> Both my 32bit system on LO 4.0.3 (Win7) & LO 3.6.6 (Ubuntu 12.04) showed
> same result.
> 
> This bug specific to 64bit system?

Noup, I had tested this bug previously with libO 3.4 and 3.5 on WinXP 32 bits, and it was there.
Comment 15 Francisco 2013-06-05 22:37:30 UTC
Well, it seems that my memory has played tricks. I have tested the file I attached with LibO 3.4.0 and I couldn't reproduce the bug, and I was sure I'd been able to do it, but it seems to be that I was wrong :-/. 

Maybe the problem was that I checked the bug with a portable version of LibO (or maybe it was OOo!) under a laptop which I don't own, in March of 2010.

But, no, I cannot reproduce the bug in Windows. So I think I must give information of my system:

Kubuntu 12.04, with Linux 3.2.0-45-generic x86_64
Video: NVidia 8200 GM, with driver 304.88 (though I can assure I was able to reproduce the bug with previous versions, since 2010...).

> Set status to UNCONFIRMED 

> Because we need confirmations from other Linux tester as on Win7 it's 
> not reproducible

Jorendc was able to reproduce this bug using Linux. Do we need a 3º tester to mark it as "NEW"?
Comment 16 ign_christian 2013-06-06 02:01:59 UTC
Are you sure it's reproducible on latest stable release (3.6.6 or 4.0.3) ?
Because I can't reproduce that on Ubuntu 12.04 32bit using generic-pae kernel (default kernel). Maybe you could try using generic-pae kernel?

And let Jorendc decide.. :)
Comment 17 Francisco 2013-06-06 11:36:13 UTC
(In reply to comment #16)
> Are you sure it's reproducible on latest stable release (3.6.6 or 4.0.3) ?
> Because I can't reproduce that on Ubuntu 12.04 32bit using generic-pae
> kernel (default kernel). Maybe you could try using generic-pae kernel?
> 
> And let Jorendc decide.. :)

Yes, even removing the folder $HOME/.config/libreoffice/4. When I have time, I will try a 32 bits installation.

Thank you
Comment 18 Francisco 2013-06-06 18:31:26 UTC
Created attachment 80426 [details]
Presentation which shows the problem

I have been able to reproduce this bug with Xubuntu 12.04, with LibO 3.5.7 installed from repositories and LibO 4.0.3 installed from PPA.

$ uname -a 
Linux Xubuntu-NB 3.2.0-45-generic #70-Ubuntu SMP Wed May 29 20:11:31 UTC 2013 i686 athlon i386 GNU/Linux

Comment: This machine is running over VirtualBox

(In my system (Kubuntu 12.04), LibO is obtained from www.libreoffice.org, not from repos)
Comment 19 Jorendc 2013-06-06 19:27:41 UTC
Hi,

I don't have that much time due exams now, but lets mark this as NEW. It looks like this is a Linux only bug, which I confirmed a while ago on Linux too. As far I can see I can't confirm it on Mac OSX 10.8.3 with LibreOffice 4.0.4.1.
I hope you agree with that?

Kind regards
Joren
Comment 20 Francisco 2013-06-06 19:39:49 UTC
@Joren

Me or Ign? If you have tested it in OSX and the bug isn't there, so it should be a Linux-only bug. But Ign wasn't able to reproduce it :-/
Comment 21 ign_christian 2013-06-07 04:07:13 UTC
Created attachment 80448 [details]
Screenshot of Slideshow on Ubuntu 12.04

Hi Francisco

Tried again using your new file & same kernel as you, my result on attached file.
- Linux ubuntu 3.2.0-45-generic #70-Ubuntu SMP Wed May 29 20:11:31 UTC 2013 i686 i686 i386 GNU/Linux
- Ubuntu 12.04 32bit (system updated today), Unity disabled
- LO 3.6.6.2 from LibreOffice PPA (sorry currently I can't use 4.0.3 on my Ubuntu)
- H/W accel disabled
Menu: Tools > Option > under 'Graphics Output' uncheck 'Use hardware acceleration' 
- Video: Mobile Intel® GM45 Express Chipset x86/MMX/SSE2 

But it seems I found a clue, with H/W accel enabled I saw a misbehavior:
-> After 3rd click at Slide2, when animating "antes", legends & X axis labels from  1st chart (which appear on 1st click at Slide2) displayed. Then continuing until last animation will show same result as attached.

Suspected problem: H/W accel enabled

Could you try disabling H/W accel ?
Comment 22 ign_christian 2013-06-07 05:18:22 UTC
Created attachment 80449 [details]
Screenshot of Slideshow on Ubuntu 12.04 (H/W accel enabled)

> But it seems I found a clue, with H/W accel enabled I saw a misbehavior:
> -> After 3rd click at Slide2, when animating "antes", legends & X axis
> labels from  1st chart (which appear on 1st click at Slide2) displayed. Then
> continuing until last animation will show same result as attached.

Sorry..slightly different result with H/W accel enabled (see attached). Label "Column 1" & "Column 2" from 1st chart appear on final show.

Same result using kernel 3.2.0-45-generic-pae.
Comment 23 Francisco 2013-06-07 20:31:23 UTC
I confirm that when disabling hardware acceleration, all objects are displayed properly
Comment 24 QA Administrators 2015-03-16 23:02:26 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

    Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
    https://www.libreoffice.org/download/

    If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
  
  If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

    Update the version field
    Reply via email (please reply directly on the bug tracker)
    Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-03-16
Comment 25 Francisco 2015-03-17 17:10:18 UTC
I have been able to reproduce this bug with
Versión: 4.4.1.2
Id. de compilación: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Configuración regional: es_AR

However, I can't reproduce it with versión:
4.5.0.0.alpha0+
Build ID: 62b124b2704adf11a63681164d05a8eb49dfb105
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-03-11_09:59:13
Locale: es_AR

In both cases, I've use a new user prefix.
Comment 26 Jean-Baptiste Faure 2015-03-24 06:00:52 UTC
I reproduce the problem with attachment 76131 [details] in LibreOffice 4.4.3.0.0+ built at home under Ubuntu 14.10. With hardware acceleration enabled, the y-axis legend of the top right diagram is visible at the end. It is not if hardware acceleration is disabled.

With the master it works as expected, even with hardware acceleration enabled
Version: 4.5.0.0.alpha0+
Build ID: 817fefa5a2a85e5ee36a01340a7dbfcc24d11162
Ubuntu_14.10_x86-64
Locale: fr_FR  

Best regards. JBF
Comment 27 tommy27 2016-04-16 07:25:13 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16
Comment 28 Jean-Baptiste Faure 2016-05-01 09:02:03 UTC
Still not reproducible with versions 5.1 and master.

Closing as WorksForMe as we don't know which commit fixed this bug. Feel free to reopen if you disagree.

Best regards. JBF