Bug 59629 - Custom animation: only the first line is animated
Summary: Custom animation: only the first line is animated
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta2
Hardware: x86-64 (AMD64) Linux (All)
: highest critical
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard: bibisected40
Keywords: regression
: 60206 60446 60505 60571 60735 60774 60779 61006 61044 61107 61170 61360 61414 61601 (view as bug list)
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2013-01-20 17:04 UTC by vulcain
Modified: 2013-03-23 11:53 UTC (History)
22 users (show)

See Also:
Crash report or crash signature:


Attachments
File for exemple (16.84 KB, application/vnd.oasis.opendocument.presentation)
2013-01-20 17:04 UTC, vulcain
Details
Bug Impress (46.67 KB, application/vnd.oasis.opendocument.presentation)
2013-02-14 09:47 UTC, Ticrob
Details
Two bullets with animation (12.93 KB, application/vnd.oasis.opendocument.presentation)
2013-02-19 21:45 UTC, Joel Madero
Details
bibisect40 log (2.81 KB, text/plain)
2013-02-23 17:51 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vulcain 2013-01-20 17:04:07 UTC
Created attachment 73338 [details]
File for exemple

In LibreOffice 4.0.0.0.beta2 (Build ID: 4104d660979c57e1160b5135634f732918460a0) on Ubuntu 12.04.1.

1) Make some long text with two or more bullet
2) Custom animation: select the text of the first bullet and animate it
3) Do the them for the other bullet
4) Launch slide show (F5)
5) See that on line the first line of the bullet's text are animated (see video for example)

Expected: animate all the text like with LibreOffice 3.5
Comment 1 vulcain 2013-01-20 17:11:12 UTC
Video: file test with LibreOffice 3.5 and 4.0:
http://ubuntuone.com/5tV4gocwpaKSDfU4R6eDlC
Comment 2 cyrille grosdemange 2013-01-23 16:03:41 UTC
Tested in :
Version 4.0.0.1+ .0.1 (Build ID: 65634f0aea686be7cdf313f66893a06ccd44880)

same problem : Only first line of a list item is animated and the text on lines following the first line is displayed, also before animation ...
Comment 3 Joel Madero 2013-01-27 18:36:09 UTC
Can't reproduce on:

Version 4.1.0.0.alpha0+ (Build ID: daa3de275b74ecb85eea3e1d3764ca357a8e2b5

Bodhi Linux

Marking as WORKSFORME

@reporter - please test with Release Candidate 2 with a fresh profile, if it's still an issue reopen the bug and we'll get a 2nd QA member to check it out.


Thanks!
Comment 4 vulcain 2013-02-05 13:07:32 UTC
@ Joel Madero:
I reproduce the bug with a fresh profile on Ubuntu 12.04 with LibreOffice 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89
Comment 5 Joel Madero 2013-02-09 17:47:07 UTC
This bug shouldn't be marked as NEW until an independent QA tester verifies it. Moving back to UNCONFIRMED until that happens.
Comment 6 Joel Madero 2013-02-09 17:48:10 UTC
Also, in general it is against policy for a reporter to report their own bug as a MAB. QA or an independent person should do this. Lastly, only confirmed bugs (again independently confirmed) can be a MAB, removing MAB blocker.
Comment 7 vulcain 2013-02-09 21:02:20 UTC
@ Joel Madero: My apologize
Comment 8 Joel Madero 2013-02-09 23:26:28 UTC
No worries :-D One of the QA team members will look at it shortly (possibly myself), thanks for your understanding!
Comment 9 Ticrob 2013-02-14 09:47:31 UTC
Created attachment 74800 [details]
Bug Impress
Comment 10 Ticrob 2013-02-14 09:49:42 UTC
Comment on attachment 74800 [details]
Bug Impress

Hi,

I have a similar problem than Vulcain.
I use LibreOffice 4.0.1.0+ (Build ID: a5acd33bc54cbc00f2194c923641fbd0ab45d80)
My problem doesn't exist with LibreOffice 3.6
I have created a slide with 2 blocks (text).
The first text is not animated.
The second one is animated with the animation "Apparition" after mouse click.
When I start the display of the slide, the two blocks appear with on line missing in the first block ! If I click on my mouse, the missing line appears !
Comment 11 Joel Madero 2013-02-19 21:44:27 UTC
I was unable to verify on:
Version 4.1.0.0.alpha0+ (Build ID: 6c89f2e74aa9b202d6d6a41a178ba9aadb2b10e)
Date:   Mon Feb 18 23:17:44 2013 +0100

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Because of this I am updating this bug again to RESOLVED - WFM

I am also attaching a document that I just created that shows that animation indeed works.

@ Those seeing the issue - please open my attachment and see if it works for you

@ Ticrob - that seems like a separate issue and should be reported separately

Thanks all for your patience, understanding and assistance
Comment 12 Joel Madero 2013-02-19 21:45:26 UTC
Created attachment 75134 [details]
Two bullets with animation
Comment 13 Jorendc 2013-02-19 22:00:44 UTC
I can still reproduce this behavior using Linux Mint 14 x64 with LibreOffice 4.0.0.3 release and Version 4.1.0.0.alpha0+ (Build ID: c5c5d87e8838b372968481483a5e20f5c5f56e3) with YOUR attachment. Can't reproduce using Joel's attachment or try it from scratch.
Comment 14 Jorendc 2013-02-19 23:50:34 UTC
*** Bug 60735 has been marked as a duplicate of this bug. ***
Comment 15 Jorendc 2013-02-19 23:53:28 UTC
*** Bug 61044 has been marked as a duplicate of this bug. ***
Comment 16 Jorendc 2013-02-19 23:54:13 UTC
*** Bug 61107 has been marked as a duplicate of this bug. ***
Comment 17 Jorendc 2013-02-19 23:54:47 UTC
*** Bug 61006 has been marked as a duplicate of this bug. ***
Comment 18 Jorendc 2013-02-19 23:55:58 UTC
*** Bug 60779 has been marked as a duplicate of this bug. ***
Comment 19 Jorendc 2013-02-19 23:58:40 UTC
Okay, due all those duplicates... let's reopen this one.

I can reproduce this behavior only when I add a custom animation to the whole Textbox.
Comment 20 Jorendc 2013-02-20 00:01:36 UTC
@thorsten, Radek: following 'FindTheExpert' I think both of you are the one to 'ping'?
Following these many duplicates I think many people are affected + regression. I hope I can bibisect this one.

Kind regards,
Joren
Comment 21 Jorendc 2013-02-20 00:03:05 UTC
I'll place this bug on the MAB4.0 list, following duplicate bugs this is a regression 3.6 vs 4.0. (I'll try to investigate this later).
Comment 22 Frank Busse 2013-02-20 09:11:41 UTC
*** Bug 60446 has been marked as a duplicate of this bug. ***
Comment 23 Jorendc 2013-02-23 17:40:29 UTC
*** Bug 61360 has been marked as a duplicate of this bug. ***
Comment 24 Jorendc 2013-02-23 17:51:02 UTC
Created attachment 75415 [details]
bibisect40 log

@Thorsten: see attachment :-). I hope that'll help kill this bug.

Thanks in advance,
Joren
Comment 25 Jorendc 2013-02-23 23:26:11 UTC
*** Bug 61170 has been marked as a duplicate of this bug. ***
Comment 26 Jorendc 2013-02-23 23:30:47 UTC
Due the massive amount of duplicate bug reports and thus affected users, I raise priority to 'Critical Highest'.

Thanks for your time reporting and bughunting.
Kind regards,
Joren
Comment 27 Jorendc 2013-02-23 23:32:57 UTC
*** Bug 61370 has been marked as a duplicate of this bug. ***
Comment 28 rosgnilk 2013-02-24 12:18:44 UTC
Same problem for me
Ubuntu 12.04 LibreOffice 4.0.0.3

if the animation has one line per bullet/number it works fine, as soon as one bullet/number has more than one line of text it animates only some lines.
Comment 29 Joel Madero 2013-02-25 04:48:49 UTC
*** Bug 61414 has been marked as a duplicate of this bug. ***
Comment 30 Joel Madero 2013-02-25 17:32:28 UTC
*** Bug 60505 has been marked as a duplicate of this bug. ***
Comment 31 Joel Madero 2013-02-25 17:33:58 UTC
It seems like this one is a bit wider problem then just custom animation being only first line - see comment 30. I believe these are all duplicates with the same root cause.
Comment 32 Thorsten Behrens (CIB) 2013-02-25 20:00:21 UTC
Regression caused by rebasing on AOO 3.4, found & adapted one more fix from Armin.
Comment 33 Joel Madero 2013-02-25 20:05:10 UTC
Nice! Thanks Thorsten :) Just pinged Michael about this also just to see if he knew anything about it.

Again, thanks for the fix, seems like this was a super MAB
Comment 34 Thorsten Behrens (CIB) 2013-02-25 20:10:27 UTC
Cherry-picked to 4-0, 4-0-1 review pending.
Comment 35 Massimo 2013-02-26 10:57:53 UTC
Forgive my ignorance, but I see that this bug has been marked as "resolved - fixed" but I do not see a patch or a new version where it is has been fixed. Am I missing something?
Comment 36 Thorsten Behrens (CIB) 2013-02-26 12:07:27 UTC
Commits in master and libreoffice-4-0, reviews for -4-0-1 pending here currently:

https://gerrit.libreoffice.org/#/c/2405/
Comment 37 Jacques Guilleron 2013-02-26 19:03:47 UTC
*** Bug 60774 has been marked as a duplicate of this bug. ***
Comment 38 Gene Kohlenberg 2013-02-27 01:27:53 UTC
(In reply to comment #35)
> Forgive my ignorance, but I see that this bug has been marked as "resolved -
> fixed" but I do not see a patch or a new version where it is has been fixed.
> Am I missing something?

I tested my custom animation case which failed in 4.0.0.3 using last night's version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89) and it presented properly, so I say that it is fixed.
Comment 39 Joel Madero 2013-02-27 01:30:09 UTC
Per last comment, marking as verified
Comment 40 rosgnilk 2013-02-27 10:44:05 UTC
I'm sorry but I don't get it: how can I install this fix?

thanks
Comment 41 Thorsten Behrens (CIB) 2013-02-27 11:27:44 UTC
(In reply to comment #40)
> I'm sorry but I don't get it: how can I install this fix?
> 
The 4.0.1 update will have it (planned for next week)
Comment 42 Thorsten Behrens (CIB) 2013-02-28 10:00:21 UTC
*** Bug 61601 has been marked as a duplicate of this bug. ***
Comment 43 Jonathan Barr 2013-03-01 11:21:42 UTC
Hello Jacques,
Just to set the scene - I have just bought a projector that has an inbuilt
display program to project Microsoft Office files, including
ppt presentations, from a memory stick.  I therefore (for the first time)
saved my presentation as a Microsoft ppt file and the result was disastrous
with lots of missing pictures and text when displayed using the projector’s
Office Viewer, but appeared okay when I reimported back into Libre Office
on my computer.
Saving it as a pptx file was even worse on the projector and it did not
re-import correctly back into Libre Office.
Any ideas?

Best regards,
Jonathan
Sent from Laptop

 *From:* bugzilla-daemon@freedesktop.org
*Sent:* 27 February 2013 12:27
*To:* jonathan0barr@gmail.com
*Subject:* [Bug 59629] Custom animation: only the first line is animated


 *Comment # 41 <https://bugs.freedesktop.org/show_bug.cgi?id=59629#c41> on bug
59629 <https://bugs.freedesktop.org/show_bug.cgi?id=59629> from
tbehrens@suse.com *

(In reply to comment #40
<https://bugs.freedesktop.org/show_bug.cgi?id=59629#c40>)> I'm sorry
but I don't get it: how can I install this fix?
>
The 4.0.1 update will have it (planned for next week)


------------------------------
You are receiving this mail because:

   - You are on the CC list for the bug.
Comment 44 vulcain 2013-03-01 13:48:27 UTC
@Jonathan

It's for the bug here, not for a projector who could not read a closed format like ppt or complex format like pptx /Oxml. Test with odp/ODF ;-)
For your problem, give a call to your vendor or to the constructor or ask to a forum http://nabble.documentfoundation.org/Users-f1639498.html
Comment 45 gmolleda 2013-03-04 12:20:52 UTC
Version 4.0.0.3 release

1.- You create a new presentation.

2.- Erase objects

3.- Create a new TEXT object with a long line (a lot of words).

4.- Remove option "Fit width to text" in context pop menu  "Position and Size..."
See that THREE lines are created.

5.- Select rectangle and Add custom effect Wipe.

6.- Now change Direction to left.

Unwanted effects:
line disappears effects. It makes a mess.
Comment 46 gmolleda 2013-03-04 12:25:04 UTC
If you insert ALL new lines with the enter key the problem does not occur.
Comment 47 Thorsten Behrens (CIB) 2013-03-04 13:21:04 UTC
(In reply to comment #45)
> Version 4.0.0.3 release
> 
We naturally can't fix 4.0.0.3 without a time machine. 4.0.1 (due this week) will have this fixed - please only reopen this bug if you can *still* reproduce the problem with the prerelease builds from http://www.libreoffice.org/download/pre-releases/
Comment 48 gmolleda 2013-03-04 13:47:32 UTC
Perfect with version 4.0.1.2
Fixed is ok. Sorry.
Comment 49 Jorendc 2013-03-04 14:01:43 UTC
(In reply to comment #48)
> Perfect with version 4.0.1.2
> Fixed is ok. Sorry.

Please do not change the bug version! This version should be the oldest version of LibreOffice that reproduce the behavior.
Comment 50 Joel Madero 2013-03-04 14:56:24 UTC
Changed to earliest version.

@EVERYONE - please do not change any of the top information without understanding what we use that information for. We use comments to say we've tested it on newer versions, the version field should NEVER get newer, only older if we can confirm on older releases. Thank you
Comment 51 Renato Lombardo 2013-03-05 17:39:14 UTC
The problem is still present in 4.0.1 RC2 (4.0.1.2).
Animated text is not working. The last lines in any text box are not animated at all.
In addition, the background image that I set in the master slide (a simple blue rectangle) is not shown.

One strange thing is that even if I downloaded and installed the 4.0.1.2 deb package (Ububtu 12.10, gnome shell) the "about" says 4.0.1.1 (Build ID: 400m0(Build:1)). Aptitude (packet manager) confirms that the version installed is 4.0.1.2.

Is it possible that the libreoffice server is giving a 4.0.1.1 version mistakenkly named 4.0.1.2?

Any workaround or suggestion?
This bug really sucks. And tomorrow morning I should be teaching my class...
Comment 52 Renato Lombardo 2013-03-05 18:01:01 UTC
Sorry. I got confused with the package isntallation. I had both the 4.0.1.1 and the 4.0.1.2 installed at the same time. I can now confirm that the animation bug is resolved in the 4.0.1.2 release.
Comment 53 Jacques Guilleron 2013-03-06 20:14:32 UTC
*** Bug 60571 has been marked as a duplicate of this bug. ***
Comment 54 Jacques Guilleron 2013-03-07 08:19:30 UTC
*** Bug 60206 has been marked as a duplicate of this bug. ***
Comment 55 blubb 2013-03-23 11:53:44 UTC
Doesn't occur in 4.0.2.1 anymore. Bug is verfied.