Download it now!
Bug 61391 - : LibreOffice sometimes changes the virtual desktop on Mac OS X
Summary: : LibreOffice sometimes changes the virtual desktop on Mac OS X
Status: RESOLVED DUPLICATE of bug 61257
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-24 11:31 UTC by darkweasel
Modified: 2013-04-17 10:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description darkweasel 2013-02-24 11:31:42 UTC
Problem description: 
I'm on OS X 10.8.2 and I frequently work with several virtual desktops (Mission Control). If you have different LibreOffice windows open on different virtual desktops, and have a floating dialog (no idea if that's the right term) such as the Templates dialog, then switching between virtual desktops sometimes works only on the second try.

Steps to reproduce:
1. Open a LibreOffice window (I used Writer)
2. Open another LibreOffice window, it can be a different component (I used Calc) or the same one (Writer)
3. Open the Templates (German: Formatvorlagen, I hope that's really what it's called in English - I mean the thing you can open with cmd-t) dialog and have it in a separate window, not docked to the document window
4. Move one of the LibreOffice windows to another virtual desktop.
5. Switch between the two virtual desktops using an appropriate touchpad gesture (four-finger swipe in my configuration).

Current behavior:
After switching to the other virtual desktop, you immediately get switched back. If you do the gesture again, it works.

Expected behavior:
The gesture should work at the first try and you should stay on that virtual desktop.

I have succeeded to reproduce this behavior in other ways too, but I cannot reliably say how I did this. In any case, if you do not use a direct four-finger swipe but first use the "show all windows and virtual desktops" feature (four-finger-swipe up in my configuration) and switch desktops there, then you first have to click the LibreOffice window on the new desktop - only then will it show this behavior.
Operating System: Mac OS X
Version: 4.0.0.3 release
Comment 1 Joel Madero 2013-02-26 18:19:29 UTC
Joren - thoughts?
Comment 2 Jorendc 2013-04-17 10:35:17 UTC
Seems to be very related to Bug 61257. Therefore I mark it as such. If someone can prove it is something different/other root causes, please do and REOPEN this bug. Also if that bug is fixed, and this bug still appears, we can REOPEN this bug too.

Kind regards,
Joren

*** This bug has been marked as a duplicate of bug 61257 ***