Bug Hunting Session
Bug 61443 - : french punctuation rules - automatic space deletion
Summary: : french punctuation rules - automatic space deletion
Status: RESOLVED DUPLICATE of bug 57981
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-25 13:51 UTC by joel.tuberosa
Modified: 2013-03-06 10:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description joel.tuberosa 2013-02-25 13:51:06 UTC
Problem description:
In french punctuation, question and exclamation mark are always preceded by a space, unless it is parenthesized. For example, "Hello!" should be translated in "Bonjour !" and "What?" becomes "Quoi ?". In Libreoffice, an inivisible space is automatically added before question/exclamation marks, unless it is followed by a parenthesis ("(" or ")"). This should happen only when the mark is the only parenthesized character.

Steps to reproduce:
1. Open the Writer
2. Activate the french auto-correct
3. Write a word
4. Add a question/exclamation mark
5. Add a parenthesis "(" or ")"

Current behavior:
An automatic insertion of an indivisible space before the question/exclamation mark at step 4, then the automatic deletion of it at step 5.

Expected behavior:
No automatic deletion of the space character because it is not proper french ;)

              
Operating System: Windows 7
Version: 3.6.1.2 release
Comment 1 Olivier R. 2013-03-06 10:57:20 UTC
This is a duplicate with :
https://bugs.freedesktop.org/show_bug.cgi?id=57981

*** This bug has been marked as a duplicate of bug 57981 ***