Bug 61478 - EDITING: unexpected result for range selection with Control+Shift+Down Arrow
Summary: EDITING: unexpected result for range selection with Control+Shift+Down Arrow
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-26 05:27 UTC by jteera5
Modified: 2013-02-28 06:10 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample document (8.26 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2013-02-26 18:36 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jteera5 2013-02-26 05:27:00 UTC
Pressing Ctrl-Arrow moves current cell to last consecutive non-empty cell or skips empty cells in that direction.
Pressing Shift-Ctrl-Arrow which is supposed to select cells from current position to last consecutive non-empty cell or to skip empty cells in the direction of the arrow, it selects all the way to sheet boundary instead. (It works fine in OpenOffice.)
Comment 1 Rainer Bielefeld Retired 2013-02-26 06:33:39 UTC
I do not understand the report. A quick test with WIN-LibO 4.0.0.3 did not show unexpected results concerning <control+arrow> functions.

"... moves current cell ..."? Cells can not be moved, but cell contents. But I believe reporter is taliking about cell cursor?

@jteera5:
Thank you for your report – unfortunately important information is missing.
May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to find out what information will be useful to reproduce your problem? 
Please add all information requested in following:
- Write a meaningful Summary describing exactly what the problem is
  "Editing:" is not a problem description.
- Attach a sample document (not only screenshot) or refer to an existing 
  sample document in an other Bug with a link; to attach a file to this 
  bug report, just click on "Add an attachment" right on this page.
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
  (attachment 68877 [details], attachment 68490 [details])
- Contribute a document related step by step instruction containing every 
  key press and every mouse click how to reproduce your problem 
  (similar to example in Bug 43431)
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
  -- what EXACTLY is unexpected
  -- and WHY do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your PC (video card, ...)
  -- concerning your Operating System (Version, Distribution, Language)
  -- concerning your LibO version (with Build ID if it's not a public release)
     and localization (UI language, Locale setting)
  –- Libo settings that might be related to your problems 
    (video hardware acceleration, Experimental features enabled, ...)
  -- how you launch LibO and how you opened the sample document
  –- Whether your problem persists when you renamed your user profile 
     before you launch LibO (please see
     <https://wiki.documentfoundation.org/UserProfile#User_profile_location>)
  –- If you can contribute an AOOo Issue that might be useful
  -- everything else crossing your mind after you read linked texts

Please do not describe what you see, but tell us what steps are to do to reproduce your problem!
Comment 2 jteera5 2013-02-26 10:36:22 UTC
Sorry, I indeed meant moving cell cursor. Ctrl-arrow is ok. But Shift-Ctrl-arrow does not extend the cell selection in the same way ctrl-arrow does, which is jumping to last consecutive cell or skipping empty cells, which is very convenient. But Shift-Ctrl-arrow extends to sheet boundary instead.
Comment 3 Rainer Bielefeld Retired 2013-02-26 10:54:15 UTC
A quick test with WIN 4.0.0.3 did not show anything unexpected, range selection ends at first empty cell

@jteera5 (In reply to comment #2):
Can you please attach a very simple sample document with a brief description like
1. Click cell A1
2. <control+shift+arrowdown>
    Expected: ..... because .....
    Actual: ...
Comment 4 jteera5 2013-02-26 17:23:45 UTC
1.Suppose that there are data in cell A1..A5 and C1, the rest are empty.
Want to copy C1 and paste to B1..B5. Current cell is C1. Ctrl-C to copy C1.
2. Move cell cursor to B1.
3.Shift-Left to extend selection to B1:A1.
4. Shift-Ctrl-Down
Expected: Extend selection to B1:A5.
Actual: Extend selection to B1:A1048576.
5. Shift-Right
Expected: Shrink selection to B1:B5
Actual: Shrink selection to B1:B1048576
6. Ctrl-V
Expected: Paste C1's data to B1:B5
Actual:Paste C1's data to B1:B1048576
Comment 5 Rainer Bielefeld Retired 2013-02-26 18:36:30 UTC
Created attachment 75594 [details]
Sample document

(In reply to comment #4) I believe I can simplify the latest instruction
I can confirm reporter's observations, but I doubt that it's a bug.

My results  with Server Installation of "LibO  4.0.0.3   -  GERMAN UI / German Locale  [Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)]"  {tinderbox: @6, pull time 2013-01-31 11:30(?)} on German WIN7 Home Premium (64bit) with separate  new User Profile and attached sample:

When I select some cells in first row (does not matter whether with <shift+arrow> or mouse+dragged mouse button), the selection with <control+shift+arrowdown> will select the range down until row as <control+arrowdown> would have reached from cell where cell cursor is visible.

This might differ to behavior in more early versions. I did the same tests with LibO 3.3.3 and it seems that there the selection will go down until the row what would have been reached with <control+arrowdown> in the last column reached when marking first row.

I think the current behavior is very plausible and more predictable than the one in more early versions.

@jteera5:
Why do you think current behavior is a bug? Can you cite help or similar to underpin your suspect?
Comment 6 jteera5 2013-02-28 04:46:39 UTC
I tried attachment "Sample document". If you start at A1 and press Shift-Ctrl-Down the selection extends to A5 as expected. But if you start at B1 as I mentioned in last comment, then press Shift-Left to extend to B1:A1, then press Shift-Ctrl-Down to extend to B1:A5, it does not extend to B1:A5 as expected but skip A6 (empty) and A7 (non-empty) and all the way to last row of sheet.

OpenOffice.org extends the selection to B1:A5 as expected. I'm not sure if I can call this a bug. I think if it's designer's intention then it's not a bug. But at least it's not consistent with former version's behavior (before fork). 

I use OpenOffice.org 3.2.1. (Never upgrade because there is no print "Selected sheet" option in higher version. Now I'm in the process of migrating to LibreOffice in which the feature is kept.)
Comment 7 Rainer Bielefeld Retired 2013-02-28 06:06:45 UTC
No objections to Comment 5, so closed.

@jteera:
Please do not write "as expected" if you mean "as I expect". "OpenOffice did ...." or "I became used to that bug" is not an appropriate reasoning.  ;-)
Please cite Help, manuals, common sense or logical conclusions.

But indeed, the current Help is not very useful, I will put you to CC in Bugs I will submit concerning that problem.