Bug 61528 - Implement Macro Recording for Draw/Impress
Summary: Implement Macro Recording for Draw/Impress
Status: RESOLVED DUPLICATE of bug 64314
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-26 20:22 UTC by patrick.ayoup
Modified: 2014-07-20 04:54 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description patrick.ayoup 2013-02-26 20:22:12 UTC
Problem description: Macro recording is unavailable (greyed out) regardless of whether "Enable experimental features" and "Enable macro recording" is checked in the "Advanced" menu of the options dialog.

Steps to reproduce:
1. Open any presentation file or create a new one.
2. From the "LibreOffice" menu, select "Preferences..."
3. In the dialog that appears, expand the "LibreOffice" node of the tree and select "Advanced".
4. Under "Optional (unstable) options", check "Enable experimental features" and "Enable macro recording".
5. Click "OK".
6. Open the "Tools" menu and hover over "Macros". Observe that "Record Macro" is still greyed out (disabled).

Current behavior: "Record Macro" is disabled regardless of settings, and thus the feature cannot be used.

Expected behavior: "Record Macro" is enabled and usable.
Operating System: Mac OS X
Version: 4.0.0.3 release
Comment 1 Joel Madero 2013-04-16 19:30:33 UTC
Did you try closing and reopening LibreOffice?
Comment 2 patrick.ayoup 2013-04-16 19:34:48 UTC
Yes. Closing and reopening LibreOffice had no effect.

(In reply to comment #1)
> Did you try closing and reopening LibreOffice?
Comment 3 Robinson Tryon (qubit) 2013-04-16 20:26:28 UTC
Hi JohnSUN,

Do you have any knowledge about macro recording in Impress?

Thanks,
Comment 4 Jorendc 2013-04-16 20:42:39 UTC
Because it is also greyed out on Linux Mint and Linux Bodhi too, let's mark platform to 'all'.

Cor mentioned the fact it isn't available in Impress forever. Therefore it is an enhancement.

But, maybe we can have some experienced input to determine "do we need it"/"will it be useful"/... Robinson mentioned JohnSUN is very experienced with LibreOffice in the IRC chat, so It'll be my pleasure to see some input (from others too off course).

Kind regards,
Joren
Comment 5 Joel Madero 2013-04-17 17:47:36 UTC
I am going to go ahead and mark this as NEW, if someone feels like it's not needed feel free to mark as RESOLVED - WONTFIX

To me it seems like a macro could theoretically be useful, let's say you have a set header/footer and other text you want on every slide over multiple slides, you create a macro and it does it every time.

Marking:
New (confirmed)
Enhancement (not a current feature or bug, wanting additional feature created)
Low - seems unlikely this will be used very often, also might be quite difficult as it might require digging into record macro code as well as our Basic code.
Comment 6 Thorsten Behrens (allotropia) 2013-04-18 08:23:10 UTC
Make summary match current evaluation.
Comment 7 Michael Meeks 2013-05-07 10:41:36 UTC
Marking a dup of the long term tracker issue here. Patches more than welcome.

*** This bug has been marked as a duplicate of bug 64314 ***
Comment 8 pranjit 2014-04-30 12:33:39 UTC
I wanted to be able with keyboard shortcuts to paste unformatted text in a text-field. for that i recorded a macro in writer and i was successful. however when i try to do that in impress i am unable to do so. macro recording is not allowed in impress. buttons greyed out. 
please do something otherwise it takes too much time. and is irritating if you have to do it again and again. just think copy , paste special, select unformatted text, press enter
my version is liboff 4.2.3    mac os x   10.9 mavericks
Comment 9 Jorendc 2014-04-30 17:32:34 UTC
(In reply to comment #8) 
> please do something otherwise it takes too much time. 

This doesn't mean you have to change bugzilla fields wrongly. Reverting.
Comment 10 tommy27 2014-07-20 04:54:25 UTC
this is inherited from OOo 

there's a partial workaround...

I found that some macros recorded with Calc macro recorder may work with 
Impress as well.

obviously you can only record macros about text formatting in Calc and reuse them in Impress, but you cannot record typical Impress actions regarding slides management.

more info on this OOoForum topic:

[solved] macros to work with text selections in Impress
http://www.oooforum.org/forum/viewtopic.phtml?t=89894