Bug 61547 - creating Primary key on existing table without primary key is not possibile
Summary: creating Primary key on existing table without primary key is not possibile
Status: RESOLVED DUPLICATE of bug 49708
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 64377
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-27 09:54 UTC by Freya
Modified: 2013-06-07 15:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Freya 2013-02-27 09:54:40 UTC
I tried to create a primary key on an existing table, but it is not saved.

Steps to reproduce:
1) create a Database and a new table without a primary key in it.
2) save it.
3) An error message is popped up:
          "No Primary Key .. Should a primary key be created ,yet?"
3) select "No"
4) enter the edit mode again for this table 
5) The primary key is lost.
Comment 1 Robert Großkopf 2013-02-28 20:10:10 UTC
I have tested this. Seems to be a bug since the start of LO. Doesn't work in LO 3.3.4, LO 3.6.5.2 and LO 4.0.1.1 under OpenSuSE 11.4 32 bit rpm. You couldn't change a table without primary-key to a table with primary key in the GUI.

Only possibility to add a primary-key is to use
Extras → SQL
ALTER TABLE "Tablename" ADD PRIMARY KEY ("Fieldname")

I set this bug to "New" and the Version to 3.3.4.
Comment 2 Julien Nabet 2013-06-06 22:26:51 UTC
Robert: dup of fdo#49708 (see https://bugs.freedesktop.org/show_bug.cgi?id=49708) or just see also?
Comment 3 Robert Großkopf 2013-06-07 15:51:24 UTC
(In reply to comment #2)
> Robert: dup of fdo#49708 (see
> https://bugs.freedesktop.org/show_bug.cgi?id=49708) or just see also?

It's the same problem. Primary key couldn't be added by the GUI, when the table exists without a primary key.

Problem in 49708 was also, that the setting of primary key in the import-wizard is a little bit hidden.

I set this bug to duplicate of 49708.

*** This bug has been marked as a duplicate of bug 49708 ***