Bug 61571 - Error while running libreoffice4.0: no suitable windowing system found, exiting.
Summary: Error while running libreoffice4.0: no suitable windowing system found, exiting.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:4.1.0 target:4.0.1
Keywords:
: 61583 62631 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-27 19:28 UTC by V Stuart Foote
Modified: 2013-11-19 15:39 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
bzip2 strace log (40.38 KB, application/x-bzip2)
2013-02-27 19:28 UTC, V Stuart Foote
Details
Strace of running swriter 4.0.2.1 (7.15 KB, application/gzip)
2013-03-27 13:04 UTC, Grzegorz Grzybek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2013-02-27 19:28:46 UTC
Created attachment 75649 [details]
bzip2 strace log

on 32-bit Fedora 18

TinderBox-34 and receive a "no suitable windowsing system found, exiting." error, similar but not same as bug 60429

Build Info
tinderbox: administrator: Caolán McNamara <caolanm@redhat.com>
tinderbox: buildname: Linux-x86@34-Release-Configuration-RHEL5-Baseline
tinderbox: tree: libreoffice-4-0
tinderbox: pull time 2013-02-26 19:23:37
tinderbox: git sha1s
core:311497d245e67d90aa2630e0c168a03adcddfd41

SELinux disabled. pixman installed.

--strace run attached
Comment 1 Caolán McNamara 2013-02-28 09:28:50 UTC
Does...

yum -y install libpng12

make it work ?
Comment 2 Not Assigned 2013-02-28 09:52:36 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c0f85e6879e527ff0673c82e84e8ee0afcc6a5ec

Resolves: fdo#61571 cairo not linking against internal libpng



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Caolán McNamara 2013-02-28 12:19:06 UTC
assuming its that problem, proposing https://gerrit.libreoffice.org/2462 for 4-0
Comment 4 V Stuart Foote 2013-02-28 15:30:34 UTC
(In reply to comment #1)
> Does...
> 
> yum -y install libpng12
> 
> make it work ?

Caolán,

So yes, adding the older 1.2 libpng did make it work, as opposed to the repo libpng-1.5.13-1.fc18. But assume that just a temporary work around.

Also, this let me confirm your patch for bug 56031 is also working with Orca 

Thanks on multiple counts!
Comment 5 Caolán McNamara 2013-02-28 15:45:26 UTC
hopefully the above commit will resolve this.
Comment 6 Caolán McNamara 2013-02-28 15:46:53 UTC
*** Bug 61583 has been marked as a duplicate of this bug. ***
Comment 7 Caolán McNamara 2013-03-01 16:48:43 UTC
4-0-1 as https://gerrit.libreoffice.org/#/c/2494/
Comment 8 Not Assigned 2013-03-02 05:56:41 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e69aa2d29342e90558e1d86b0f89418b8bdb0e34&h=libreoffice-4-0

Resolves: fdo#61571 cairo not linking against internal libpng


It will be available in LibreOffice 4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2013-03-04 12:50:49 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-0-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c6c886068ab9288a081efc33fa6902383e09aa3e&h=libreoffice-4-0-1

Resolves: fdo#61571 cairo not linking against internal libpng


It will be available already in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 V Stuart Foote 2013-03-04 16:13:36 UTC
issue not limited to TB 34 - adjusting title
Comment 11 V Stuart Foote 2013-03-05 02:55:56 UTC
confirm commits do fix issue on a 4.0.2 build

Build Info
tinderbox: administrator: Caolán McNamara <caolanm@redhat.com>
tinderbox: buildname: Linux-x86@34-Release-Configuration-RHEL5-Baseline
tinderbox: tree: libreoffice-4-0
tinderbox: pull time 2013-03-04 09:56:04
tinderbox: git sha1s
core:aa1d118f9474ca0be4b1fcdc2749dd4020e05ffc
Comment 12 Caolán McNamara 2013-03-07 14:58:13 UTC
*** Bug 61944 has been marked as a duplicate of this bug. ***
Comment 13 V Stuart Foote 2013-03-07 15:27:37 UTC
Added note to tail end of en release notes. Not sure how, or if, that needs to propagate to additional language versions. Or if it should even have been added there, edit if appropriate.
Comment 14 Petr Mladek 2013-03-25 10:10:06 UTC
*** Bug 62631 has been marked as a duplicate of this bug. ***
Comment 15 Grzegorz Grzybek 2013-03-27 13:04:13 UTC
Still doesn't work for me. "CentOS release 6.4 (Final)".

[root@localhost RPMS]# rpm -qa|grep libreo
libreoffice4.0-freedesktop-menus-4.0.2-1.noarch
libreoffice4.0-4.0.2.1-1.i586
libreoffice4.0-writer-4.0.2.1-1.i586
libreoffice4.0-ure-4.0.2.1-1.i586

[root@localhost RPMS]# rpm -qa|grep liboba|sort
libobasis4.0-core01-4.0.2.1-1.i586
libobasis4.0-core02-4.0.2.1-1.i586
libobasis4.0-core03-4.0.2.1-1.i586
libobasis4.0-core04-4.0.2.1-1.i586
libobasis4.0-core05-4.0.2.1-1.i586
libobasis4.0-core06-4.0.2.1-1.i586
libobasis4.0-core07-4.0.2.1-1.i586
libobasis4.0-gnome-integration-4.0.2.1-1.i586
libobasis4.0-graphicfilter-4.0.2.1-1.i586
libobasis4.0-images-4.0.2.1-1.i586
libobasis4.0-librelogo-4.0.2.1-1.i586
libobasis4.0-ooofonts-4.0.2.1-1.i586
libobasis4.0-ooolinguistic-4.0.2.1-1.i586
libobasis4.0-writer-4.0.2.1-1.i586
libobasis4.0-xsltfilter-4.0.2.1-1.i586
Comment 16 Grzegorz Grzybek 2013-03-27 13:04:53 UTC
Created attachment 77100 [details]
Strace of running swriter 4.0.2.1
Comment 17 keellambert 2013-04-01 10:46:26 UTC
installed ok here

Mon 25 Mar 17:45:00 CET 2013
michael@linux-xjw5:~/Updates/Tumbleweed_12.3/libreoffice/LibreOffice_4.0.2.1_Linux_x86-64_rpm/RPMS> rpm -Uhv --test *.rpm
Preparing...                          ################################# [100%]
michael@linux-xjw5:~/Updates/Tumbleweed_12.3/libreoffice/LibreOffice_4.0.2.1_Linux_x86-64_rpm/RPMS> su -
Password: 
linux-xjw5:~ # cd /home/michael/Updates/Tumbleweed_12.3/libreoffice/LibreOffice_4.0.2.1_Linux_x86-64_rpm/RPMS
linux-xjw5:/home/michael/Updates/Tumbleweed_12.3/libreoffice/LibreOffice_4.0.2.1_Linux_x86-64_rpm/RPMS # rpm -Uhv *.rpm
Preparing...                          ################################# [100%]
Updating / installing...
   1:libreoffice4.0-ure-4.0.2.1-1     ################################# [  2%]
   2:libobasis4.0-core01-4.0.2.1-1    ################################# [  4%]
   3:libobasis4.0-core02-4.0.2.1-1    ################################# [  6%]
   4:libobasis4.0-core03-4.0.2.1-1    ################################# [  8%]
   5:libobasis4.0-core04-4.0.2.1-1    ################################# [ 10%]
   6:libobasis4.0-core05-4.0.2.1-1    ################################# [ 12%]
   7:libobasis4.0-core06-4.0.2.1-1    ################################# [ 14%]
   8:libobasis4.0-core07-4.0.2.1-1    ################################# [ 16%]
   9:libobasis4.0-en-GB-4.0.2.1-1     ################################# [ 18%]
  10:libobasis4.0-base-4.0.2.1-1      ################################# [ 20%]
  11:libobasis4.0-impress-4.0.2.1-1   ################################# [ 22%]
  12:libobasis4.0-en-GB-base-4.0.2.1-1################################# [ 24%]
  13:libobasis4.0-en-GB-calc-4.0.2.1-1################################# [ 26%]
  14:libobasis4.0-en-GB-math-4.0.2.1-1################################# [ 28%]
  15:libobasis4.0-en-GB-res-4.0.2.1-1 ################################# [ 30%]
  16:libobasis4.0-en-GB-writer-4.0.2.1################################# [ 32%]
  17:libobasis4.0-calc-4.0.2.1-1      ################################# [ 34%]
  18:libobasis4.0-draw-4.0.2.1-1      ################################# [ 36%]
  19:libobasis4.0-images-4.0.2.1-1    ################################# [ 38%]
  20:libreoffice4.0-4.0.2.1-1         ################################# [ 40%]
  21:libobasis4.0-math-4.0.2.1-1      ################################# [ 42%]
  22:libobasis4.0-writer-4.0.2.1-1    ################################# [ 44%]
  23:libreoffice4.0-writer-4.0.2.1-1  ################################# [ 46%]
  24:libreoffice4.0-math-4.0.2.1-1    ################################# [ 48%]
  25:libreoffice4.0-base-4.0.2.1-1    ################################# [ 50%]
  26:libreoffice4.0-calc-4.0.2.1-1    ################################# [ 52%]
  27:libreoffice4.0-dict-en-4.0.2.1-1 ################################# [ 54%]
  28:libreoffice4.0-draw-4.0.2.1-1    ################################# [ 56%]
  29:libreoffice4.0-en-GB-4.0.2.1-1   ################################# [ 58%]
  30:libreoffice4.0-impress-4.0.2.1-1 ################################# [ 60%]
Comment 18 keellambert 2013-04-01 10:47:35 UTC
  31:libobasis4.0-ogltrans-4.0.2.1-1  ################################# [ 62%]
  32:libobasis4.0-postgresql-sdbc-4.0.################################# [ 64%]
  33:libobasis4.0-en-GB-help-4.0.2.1-1################################# [ 66%]
  34:libobasis4.0-extension-beanshell-################################# [ 68%]
  35:libobasis4.0-extension-javascript################################# [ 70%]
  36:libobasis4.0-extension-mediawiki-################################# [ 72%]
  37:libobasis4.0-extension-nlpsolver-################################# [ 74%]
  38:libobasis4.0-extension-presentati################################# [ 76%]
  39:libobasis4.0-extension-python-scr################################# [ 78%]
  40:libobasis4.0-extension-report-bui################################# [ 80%]
  41:libobasis4.0-graphicfilter-4.0.2.################################# [ 82%]
  42:libobasis4.0-javafilter-4.0.2.1-1################################# [ 84%]
  43:libobasis4.0-kde-integration-4.0.################################# [ 86%]
  44:libobasis4.0-librelogo-4.0.2.1-1 ################################# [ 88%]
  45:libobasis4.0-onlineupdate-4.0.2.1################################# [ 90%]
  46:libobasis4.0-ooofonts-4.0.2.1-1  ################################# [ 92%]
  47:libobasis4.0-ooolinguistic-4.0.2.################################# [ 94%]
  48:libobasis4.0-pyuno-4.0.2.1-1     ################################# [ 96%]
  49:libobasis4.0-xsltfilter-4.0.2.1-1################################# [ 98%]
  50:libreoffice4.0-suse-menus-4.0.2-1################################# [100%]
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
linux-xjw5:/home/michael/Updates/Tumbleweed_12.3/libreoffice/LibreOffice_4.0.2.1_Linux_x86-64_rpm/RPMS # 

Version 4.0.2.1 (Build ID: 7e5467ff8f30d821f4fbf69cb2769163eb64c2c)
starts ok without libpng12-0-1.2.50-3.1.1.x86_64 and libpng14-14-1.4.11-2.5.1.x86_64 installed

libpng15-15-1.5.13-3.1.1.x86_64 and libpng15-15-32bit-1.5.13-3.1.1.x86_64 are installed
Comment 19 V Stuart Foote 2013-05-01 14:50:55 UTC
(In reply to comment #15)
> Still doesn't work for me. "CentOS release 6.4 (Final)".
> 
> [root@localhost RPMS]# rpm -qa|grep libreo
> libreoffice4.0-freedesktop-menus-4.0.2-1.noarch
> libreoffice4.0-4.0.2.1-1.i586
> libreoffice4.0-writer-4.0.2.1-1.i586
> libreoffice4.0-ure-4.0.2.1-1.i586

Grzegorz,

Are you good with current builds (4.0.2 final or a 4.0.3 rc1 build)?

If so will close this bug. 

If not, please let us know and post up a current stack trace.
Comment 20 V Stuart Foote 2013-05-28 15:55:29 UTC
setting back to Resolved Fixed, no response on request and not additional reports