Bug 61589 - LibreOffice 4.0 cmis connection to alfresco over https
Summary: LibreOffice 4.0 cmis connection to alfresco over https
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: All All
: high critical
Assignee: Cédric Bosdonnat
QA Contact:
URL:
Whiteboard: BSA target:4.2.0
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-28 07:28 UTC by Jonas
Modified: 2014-10-15 08:49 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Error https CMIS (26.62 KB, image/png)
2013-11-28 12:03 UTC, Samuel Wolf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonas 2013-02-28 07:28:23 UTC
My test system:
- LibreOffice 4.0.0.3 on Ubuntu 12.10 (32bit)
- Alfresco 4.0.d on CentOS release 5.9

Problem description:
First, I test cmis support with LibreOffice 4 and Alfresco 4.0.d like this:
type: CMIS
server type: Alfresco 4
binding url: http://alfresco1.example.com:8080/alfresco/cmisws/RepositoryService?wsdl

This work fine.

In my next test I connet over https to the alfresco CMIS web service:
type: CMIS
server type: Alfresco 4
binding url: https://alfresco2.example.com/alfresco/cmisws/RepositoryService?wsdl

This test has the apache2 mod_ssl between the LiberOffice and the Alfresco. If I click the reload button for get the list of all repositories, then LibreOffice work for a half minute and don't found any repositories. The log from apache2 mod_ssl say, that the wsdl file has successful downloaded. A browser on the same computer loads the WSDL file also successful.
Operating System: Ubuntu
Version: 4.0.0.3 release
Comment 1 Marcus Svensson 2013-03-19 15:34:30 UTC
I'm experiencing the same problems with a similar setup as Jonas.

Alfresco 4.1.3
LibreOffice 4.0.0.3 on Windows and LibreOffice 4.0.1.2x64 on Ubuntu.
Apache2 with mod_ssl and mod_ajp as proxy in front of Alfresco.

This is critical for real production implementations that this works over SSL.
Comment 2 Cédric Bosdonnat 2013-03-20 18:14:06 UTC
CMIS problem: mine, though unconfirmed yet: libcmis and LibreOffice are known to work over SSL.

Could you check what version of curl is used (system one or not)?
Comment 3 Jonas 2013-03-22 14:19:31 UTC
Curl is not installed in my ubuntu test system. I think, I use the curl module from LibreOffice.
Comment 4 Marcus Svensson 2013-03-26 06:00:19 UTC
(In reply to comment #2)
> CMIS problem: mine, though unconfirmed yet: libcmis and LibreOffice are
> known to work over SSL.
> 
> Could you check what version of curl is used (system one or not)?

Since this is reproducable on both Ubuntu and Windows I guess its the LibreOffice one. I have curl installed on my Ubuntu system though (both binary and libcurl of version 7.27.0).
Comment 5 Cédric Bosdonnat 2013-03-28 11:10:30 UTC
I could reproduce here with a self-signed certificate and tomcat directly serving the pages on https connector.

There is clearly a problem with the SSL certificates verification: libcurl blocks the requests by default. Could you please tell me if your certificate is self-signed or give me the CA for it (as it may not be in the curl default trusted CA list). Can you also try with a valid certificate?

I think libcmis will need to be expanded for it to work with those problems.
Comment 6 Christopher Potter 2013-04-08 15:39:49 UTC
Same problem for me with LibreOffice 4.0.2.2 (Win7) and Alfresco 4.0.d / (CentOS 6.3) with mod_proxy (apache) doing the 8080/tomcat to 443/apache
Comment 7 Marcus Svensson 2013-04-09 07:16:18 UTC
I tried this towards Alfrescos open cmis server: cmis.alfresco.com

Works on both http and https there, so this seems to be related to self-signed certificates just as Cedric proposed.

To test on the cmis.alfresco.com make sure you point the path to a sub-folder since there are alot of folders in the root on the server making the folder list not load in LibreOffice (or its just extremely slow).

You can create your own test-folder using the CMIS workbench tool at https://cmis.alfresco.com/ or just use mine: /mars-test

I will try and test to other https sites if where the certificates are valid.

Is it a big process to allow also self-signed connections in libcmis?
Comment 8 Samuel Wolf 2013-07-25 13:20:56 UTC
Test LibreOffice 4.1 today in the office.
We use as well a self-signed certificate and LibreOffice do not load the repository after ask for the login (username and password).

How can I use LibreOffice CMIS with a self-signed certificate?

LibreOffice 4.1.0.4 on Debian 7.1 amd64
Comment 9 Cédric Bosdonnat 2013-07-25 14:32:15 UTC
Fixed by this commit (needing not-yet-released libcmis 0.4.0)
Comment 10 Samuel Wolf 2013-07-25 16:03:47 UTC
does anyone know when it will release?
Comment 11 Samuel Wolf 2013-08-02 12:12:43 UTC
I install the CA of my server, but CMIS over https do not work.

Which CA database use libcmis?
Comment 12 David Tardon 2013-08-09 06:11:24 UTC
marking this fixed based on comment 9
Comment 13 Samuel Wolf 2013-08-09 12:56:10 UTC
does anyone know in which version this is fixed?
Comment 14 David Tardon 2013-08-12 04:36:55 UTC
None yet. It will be fixed in master when libcmis-0.4.x is imported. I am pretty sure that is going to happen for 4.2.
Comment 15 Samuel Wolf 2013-11-28 12:03:47 UTC
Created attachment 89953 [details]
Error https CMIS

Testing today with LibreOffice Version: 4.2.0.0.beta1
Build ID: f4ca7b35f580827ad2c69ea6d29f7c9b48ebbac7

Not working for me :-(
My root CA certificate is self signed, maybe that's the problem?

"The specified device is invalid."
Comment 16 VnG 2014-10-14 21:16:56 UTC
Dear All,

I would like to join this ticket as I'm working on the LibreOffice 4.2.6 release' qualification for the next MIMO official delivery.

I'm focusing on the LO server integrating CMIS coupled with Alfresco 4.2 and 5 for providing online document checkout/editing/modifiying/checkout directly from the repository contentstore.

Only Linux*s 64 bits are targeted.

It seems this is fixed and planed in LibreOffice 4.2.
However, the last test failed with 4.2.0.0.beta1.

May you please confirm if it is now fixed and available in LibreOffice 4.2.6?

Moreover, do you think it is now possible to use the LibreOffice server instance coupled with the Alfresco server one in order to manage from Share inside the webbrowser the ODF opening?

I thank you very much for your answer.
Best regards, V'n'G
Comment 17 Cédric Bosdonnat 2014-10-15 07:53:51 UTC
You should have a look at bug #72277 too for a complete overview of the fixes for SSL / CMIS fixes. And of course, you can test and report problems instead of asking here.
Comment 18 Marcus Svensson 2014-10-15 08:49:23 UTC
And the issues should be solved in 4.3.1 and later versions.

If you are in need of a share-integration you could look at my addon for it: http://addons.alfresco.com/addons/libreoffice-online-edit-module