Download it now!
Bug 61622 - Problem scaling symbol in Math
Summary: Problem scaling symbol in Math
Status: RESOLVED DUPLICATE of bug 60268
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-28 16:22 UTC by Andrea
Modified: 2013-03-10 09:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Draw formula (14.49 KB, image/png)
2013-02-28 16:22 UTC, Andrea
Details
formula Win7 (73.28 KB, image/png)
2013-03-01 18:43 UTC, Jacques Guilleron
Details
win7-win8 (89.52 KB, image/png)
2013-03-02 08:26 UTC, Andrea
Details
nested square roots (16.29 KB, image/png)
2013-03-04 08:23 UTC, Andrea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrea 2013-02-28 16:22:50 UTC
Created attachment 75699 [details]
Draw formula

I'm using windows 8. I have a problem with symbol scaling in Math, a simple formula as "y=sqrt{ x} < x <= x^2 " is draw in erroneous way, the symbols are little respect the rest of formula. The symbol sqrt is draw with a break between √ and overbar, √ and ≤ are smaller than necessary. What could be the problem?
Comment 1 Robinson Tryon (qubit) 2013-02-28 17:10:35 UTC
(LO 4.0.0.3 + Ubuntu 12.04.2)

Confirmed. Especially at certain scaling levels, the √ symbol and overbar show noticable gap and/or vertical offset difference.
Comment 2 Jacques Guilleron 2013-02-28 17:41:53 UTC
Hello Andrea,

Did you try to play with menu spacing > Root spacing ? 

regards,

Jacques Guilleron
Comment 3 Andrea 2013-03-01 08:30:42 UTC
Hello Jacques, Root Spacing in "format -> Spacing" is 0%. Not only symbol √ is small, also ≤ is smaller than <. If fonts are being used for symbols and √ ≤, it seems that these fonts are reduced. Whether it's a font problem?
Comment 4 Jacques Guilleron 2013-03-01 18:43:24 UTC
Created attachment 75749 [details]
formula Win7
Comment 5 Jacques Guilleron 2013-03-01 20:29:22 UTC
Hello Andrea,

I join an attachment to compare it with yours. I have defaut settings for fonts, so Times New Roman is for me the only font I use. You have Times also for variables, which font did you set for fonctions, operators? I explain those differences in rendering by changes in font settings. Is it true?

Regards.

Jacques Guilleron
Comment 6 Andrea 2013-03-02 08:26:40 UTC
Created attachment 75768 [details]
win7-win8
Comment 7 Andrea 2013-03-02 08:27:09 UTC
Hello Jacques,
I use Time in font settings, default. In win7 i have no problem.
I attach an image for comparison, with the font settings. In the red circle you can see that the character is different. So I tried to change the font for the functions but there have been no changes.
Regards, Andrea.
Comment 8 Jacques Guilleron 2013-03-03 18:03:21 UTC
Hi Andrea,

Just a quick test:
In formula editor paste: y =  sqrt {{x}over {sqrt {{x} over sqrt {x}}}} and give us a screenshot.

Thanks

Jacques Guilleron
Comment 9 Andrea 2013-03-04 08:23:15 UTC
Created attachment 75884 [details]
nested square roots
Comment 10 Andrea 2013-03-04 08:26:06 UTC
Hello Jacques,
attachment added.
Andrea
Comment 11 Jacques Guilleron 2013-03-05 10:57:54 UTC
Hello Andreaa,
If you have installed no extension, no macro, no special use of character, I cannot explain why you have this mix of TimesNewRoman and Liberation fonts.
Correct results with LO 4.0.0.3, LO 3.6 and LO 4.0.1 rc2 on Vista,
LO 4.0.1 rc2 on Ubuntu 10.04 and LO 12.04. (qa-fr lists)
If you get any change, let me know.

regards.

Jacques Guilleron
Comment 12 Robinson Tryon (qubit) 2013-03-05 11:22:18 UTC
Jacques --

Here are my repro steps on Ubuntu 12.04.2 + LO 4.0.0.3:

- Use original function "y=sqrt{ x} < x <= x^2"
- Fonts set as follows:
(TNR = Times New Roman)
 Variables: TNR, Italic
 Functions: TNR
 Numbers: TNR
 Text: TNR

- Zoom at the following levels shows issues (gap between the root symbol and overbar, or the top of the root sign poking above the overbar):

  - 100%
  - 150%
  - 200%
  - 225% - gap
  - 275%
  - 300% - very close
  - 425% - close
  - 475%
  - 500%
  - 675% - small gap
  - 700% - noticeable gap
  - 800% - close

---

Same type of problem noticed with the 2nd function, but different roots experiencing the issue at different zoom levels.
Comment 13 Jacques Guilleron 2013-03-06 00:55:33 UTC
Hello Qubit,

I think there is here two issues. One with the mix of TimesNewRoman and Liberation fonts that i cannot reproduce, and another with the link of root character and overbar.

You writed an excellent report. Short, precise, and easily reproductible. I have no gap under Windows 7, but with Ubuntu perhaps you have it. On the other hand I see the poke above the overbar. So join a screenshot 700 % and report this separately. This will be a chance for an improvement.

regards.

Jacques Guilleron
Comment 14 Robinson Tryon (qubit) 2013-03-06 05:22:37 UTC
(In reply to comment #13)
> You writed an excellent report. Short, precise, and easily reproductible. I
> have no gap under Windows 7, but with Ubuntu perhaps you have it. On the
> other hand I see the poke above the overbar. So join a screenshot 700 % and
> report this separately. This will be a chance for an improvement.
> 
> regards.
> 
> Jacques Guilleron

Hi Jacques,

I just added bug 61886. Please add a comment indicating which rendering issues are visible on Win7.

Thanks!

-Q
Comment 15 Andrea 2013-03-07 10:51:15 UTC
Hello Jacques,
I have the same problem with another windows 8 pc, libreoffice 4.0.0.3.
Regards.
Comment 16 Jacques Guilleron 2013-03-07 21:11:33 UTC
Hello Andrea,

This is confirmed on qa-fr on several machines under Windows 8. So it would be only a Windows 8 bug for LO 4.0. I set it to normal, but not sure, what do do you think of?

Regards.

Jacques Guilleron
Comment 17 Andrea 2013-03-08 08:21:33 UTC
Hello Jacques,
I think it is a high problem, I'm waiting to install windows 8 on my computer until this issue is solved. But i don't change the Importance because I'm not a developer...
Regards. Andrea Antoniel
Comment 18 Jacques Guilleron 2013-03-09 08:55:01 UTC
Hi Andrea,

I'm not a developper. Here, I just try to help bug sorting. You have rights, like anybody, to change bug priority. Just write why. You have a flowchart at:
https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg
that help. For me, this bug prevent users from making professional work, so it have to be set to Normal and perhaps Medium for second set because we cannot change this behavior. We have also to underline this is a Windows 8 special issue. But I don't know how.

Regards.

Jacques Guilleron
Comment 19 Andrea 2013-03-09 13:59:38 UTC
Hello Jacques,
is interesting to me the flow chart, and comments to the bug are aligned with the flow.
Okay.
Regards. Andrea Antoniel
Comment 20 Jacques Guilleron 2013-03-10 09:12:21 UTC

*** This bug has been marked as a duplicate of bug 60268 ***