Bug Hunting Session
Bug 61660 - unhelpful dictionary entries...
Summary: unhelpful dictionary entries...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta2
Hardware: Other All
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:4.1.0 target:3.6.6 target:4.0.2
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-01 11:03 UTC by Michael Meeks
Modified: 2013-03-01 14:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2013-03-01 11:03:57 UTC
It has been pointed out that trans-woman is the correct term, and that tranny-woman is a pejorative term; suggesting a replacement of the latter for a former is not good in English.

I've tested our dictionaries - initially I tried just English [ it's a shame that we don't share a root dictionary here for all en_ and then overlay a US vs. GB etc. impl. ] anyhow the problem is thus:

en_US, en_CA - ok
en_AU, en_GB, en_ZA - bad

No idea of the politics of this and/or whether such terms offensiveness are locale-dependent; I suspect not. So we should just fixup AU, GB, ZA I guess.

It looks like trans-man has the equivalent problem.
Comment 1 Michael Meeks 2013-03-01 11:33:40 UTC
An origin has been speculated in that a tranny is a transistor radio:

http://oxforddictionaries.com/definition/english/tranny

And since neither of these compound-words is in the dictionary, it's just the automated hyphenation code getting tangled up thinking it's some sort of archaic 'radio-woman' equivalent: spell-checkers have limited context & intelligence clearly.
Comment 2 Cor Nouws 2013-03-01 12:16:10 UTC
Known problem for more then a year (at least) with Dutch. But failed to find time to dive into this.
Comment 3 Not Assigned 2013-03-01 14:04:35 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=7e4239060266bf238b5e6692ed10d548c37572d5

fdo#61660 unhelpful dictionary entries



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 László Németh 2013-03-01 14:25:48 UTC
András, many thanks for the correct fix! 

Here is my comment written before the detection of the fix (I suggest to add other words to the dictionary, but maintaining the dictionary is a more general task):

For a quick fix, I suggest to add the word 'trans' to the .dic files of the related dictionaries, because the single 'trans' is allowed in the frequent term 'trans fat' of the popular British/World English scientific media/health care, according to the Oxford Dictionary: http://oxforddictionaries.com/definition/english/trans%2Bfat?q=trans+fat (This will fix the other trans- words, eg. trans-ship, trans-ships, trans-shipping, trans-shipped trans-shipment(s), Trans-Alaska, Trans-Siberian, Trans-Canada, trans-fatty, trans-Pacific.)

I suggest to add also 'transwoman', 'transmen', 'transman', 'transmen', too, because these are the suggested forms by the dictionary:

http://oxforddictionaries.com/definition/english/transwoman?q=trans-woman
http://oxforddictionaries.com/definition/english/transwoman?q=trans-women
http://oxforddictionaries.com/definition/english/transwoman?q=trans-man
http://oxforddictionaries.com/definition/english/transwoman?q=trans-men

Cor: It seems, there is a real problem here: bad priority in the suggestions for the words with hyphen and with non-dictionary part: eg. the non-dictionary word foo-bar with a non-dictionary part (foo) have got higher priority part-oriented suggestions (fox-bar etc.) than results of simple hyphen deletion (eg. foobar) or REP replacements. I will fix this problem.
Comment 5 Not Assigned 2013-03-01 14:46:15 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=33a68182c946334fde90e867f2b5315df9dd7d53&h=libreoffice-3-6

fdo#61660 unhelpful dictionary entries


It will be available in LibreOffice 3.6.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Not Assigned 2013-03-01 14:46:34 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=a0bea3c39ca68fc2b57433b656f284e83312e22d&h=libreoffice-4-0

fdo#61660 unhelpful dictionary entries


It will be available in LibreOffice 4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.