Bug Hunting Session
Bug 61679 - SLIDESHOW: Enhancement request: control over the timing of presentation delay in kiosk mode
Summary: SLIDESHOW: Enhancement request: control over the timing of presentation delay...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA target:6.3.0
Keywords:
Depends on:
Blocks: Slide-Show
  Show dependency treegraph
 
Reported: 2013-03-02 09:59 UTC by libre
Modified: 2019-02-22 12:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
presentation created with powerpoint (550.00 KB, application/vnd.ms-powerpoint)
2013-03-19 09:29 UTC, libre
Details

Note You need to log in before you can comment on or make changes to this bug.
Description libre 2013-03-02 09:59:32 UTC
I'm using Libreoffice in Kioskmode on raspberrypis to display messages on tv screens ( bulletin boards in a school). The presentations are developed in Powerpoint and automatically copied to the raspberry server. However Libreoffice automatically adds a 10 second delay between the display of every series of slides. Since powerpoint is not aware of this feature, we cannot remove it during the creation of the slides. How can I default remove this delay, since it is especially annoying when displaying a presentation of just 1 or 2 slides.
Operating System: Debian
Version: 4.0.0.3 release
Comment 1 Joel Madero 2013-03-18 22:58:51 UTC
Please attach a slideshow that we can see behavior. If you do I can compare powerpoint to Presentation to see if I see two different behaviors. 

Marking as NEEDINFO - once you attach document, mark as UNCONFIRMED and I'll take a look at it.
Comment 2 libre 2013-03-19 09:29:06 UTC
Created attachment 76746 [details]
presentation created with powerpoint

When we continuously play this presentation, created using powerpoint,in kiosk-mode it automatically adds 10 sec delay between two presentations. 
It is possible to remove this delay in Libreoffice, but we want to be able to configure libreoffice to have another default delay between presentations (preferably 0 seconds...)
Comment 3 Joel Madero 2013-04-16 16:43:05 UTC
Hm, so I think we have this: 

Click on Slide Show -> Slide Show Settings -> 

in your presentation it's set to "AUTO" at 00:00:10

you can change this to 00:00:00 and it will be 0 seconds between.

Marking as INVALID as we have the feature already, if you think I am mistaken please correct me and set the bug back to UNCONFIRMED (you may have to set it to REOPENED first then UNCONFIRMED) -- apologies for this, we're working on fixing this issue in FDO.


Thanks!
Comment 4 libre 2013-04-16 16:55:51 UTC
I know it is possible to edit it in Libreoffice. However we create the presentation in powerpoint ( that is unaware of this option ) and play it using a raspberry with debian and libreoffice. The pi starts unattended, grabs the file and starts playing it. Since powerpoint doesn't know this option, we are confronted with the behavior every time we create a new file.  

So either we edit the file on the pi every time there is a new presentation
or we must be able to set a default for every new presentation.
Comment 5 libre 2013-04-18 19:40:07 UTC
Cannot change it to UNCONFIRMED
Comment 6 Joel Madero 2013-04-22 04:51:37 UTC
ah now I understand. So you want one of two things:

a) a default that overrides the setting every time so no manual change is needed

b) the ability to easily change the time within kiosk mode itself (not in edit mode)


Either way this is a valid request. Marking as:


New (confirmed)
Enhancement
Low - the number of users that will benefit from this seems quite low, only users who play a file immediately that is created from within power point - else the user can set the time themselves within Presentation.
Comment 7 dregansa 2013-05-14 16:50:32 UTC
Hi,

I've been attempting a very similar thing for a digital signage project, and as such would find this very useful. Ideally I'd like to be able to specify it from the command line too, since that's how my pi launches libreoffice.

Cheers.
Comment 8 libre 2014-02-13 16:50:50 UTC
Almost a year. Any chance of an update? Pretty please...
Comment 9 Joel Madero 2014-02-13 17:50:37 UTC
Unfortunately we do not have the man power to guarantee ETA's. This is an enhancement and currently most of our developers are tackling some of the nastier regressions that made it into 4.2.0. 

We encourage everyone to (1) submit a patch themselves, (2) find developers who want to try to tackle (and then maybe we can find someone to offer code pointers), or (3) get support. Barring these, then it's really "when we have time" which can be difficult when there are thousands of bugs, enhancements tend to take lower priority
Comment 10 libre 2014-02-13 19:00:19 UTC
I hear you. And don't think I don't appreciate all the hard work that the developers do (mainly in their spare time). Perhaps it is time to download the code and start working  myself....

Keep up the good work!
Comment 11 Joel Madero 2014-02-13 19:39:08 UTC
That would be fantastic - if you need some guidance send me a personal email :)
Comment 12 blockhale 2016-01-07 10:22:38 UTC
No progress in nearly 3 years?

I'm in exactly the same situation. I am setting up an electronic noticeboard which displays a Powerpoint slideshow using the Raspberry Pi and a TV. It picks up a file from the network and displays it until another one is uploaded. Then the slideshow has to be killed, and restarted with the new file. All preprogrammed with scripts without user intervention. Having a delay when the slideshow loops round to the first slide is very unprofessional looking. Otherwise LibreOffice Impress is perfect.

A simple parameter for the default delay value would be sufficient, which could be set to 0 or any other value. I just need a way of keeping this value when LibreOffice is closed and reopened. Even just something on the command line. I don't need to be able to change the value during kiosk mode only between closing and reopening the application.
Comment 13 blockhale 2016-01-07 10:26:52 UTC
Correction - I don't need to be able to change the value between closing and reopening the application. Just a way of permanently setting the default to zero. Anything more would be a bonus.
Comment 14 Joel Madero 2016-01-07 16:07:16 UTC
(In reply to blockhale from comment #12)
> No progress in nearly 3 years?

We don't give ETAs ever. A volunteer has to find the enhancement request interesting enough to tackle, it might never happen, it might happen next week.

As usual your options are:
1) fix it yourself;
2) find someone to fix it;
3) Pay someone to fix it;
4) Wait....

> 
> A simple parameter for the default delay value would be sufficient,

If it's simple I suggest fixing it yourself - the code is readily available and ready to play with.
Comment 15 blockhale 2016-01-07 20:23:30 UTC
(In reply to Joel Madero from comment #14)
> 
> If it's simple I suggest fixing it yourself - the code is readily available
> and ready to play with.

I've seen glib comments like this before and frankly it is an insult. So you want me to learn a programming language and the whole development infrastructure in order to add a simple fix? Do you think this is a sensible use of time for someone who is engaged in using the product in a different but useful way which could itself help others? Horses for courses. Unless users make requests like this the developers aren't going to know which areas are of the project are most wanted, so I make no apology for making this comment.
Comment 16 Joel Madero 2016-01-07 20:25:58 UTC
> I've seen glib comments like this before and frankly it is an insult. So you
> want me to learn a programming language and the whole development
> infrastructure in order to add a simple fix? 
1) You are the one who said it was "simple" not me . . . if you're not a developer than maybe avoid suggesting a fix is "simple"...what might appear as trivial to an end user could be quite hard once you actually dig into the code;

2) If you're not going to fix it, then wait patiently for someone to tackle it (which again, might be never....this is a volunteer based project)
Comment 17 blockhale 2016-01-07 22:18:10 UTC
Ok I was wrong to suggest the fix itself was "simple". My original point was an effort to suggest a small change in operation might suffice. I'm sure there are different ways to achieve the same effect and I thought suggesting what appears to be a small change might persuade a developer who knew this area of the system to have a look at the code to see if it is a simple tweak. Of course this might not be possible and implementation could open a can of worms.

Still I've made my request and I hope someone will see it and consider it, perhaps when they make alterations to a related area of code. I'm not ungrateful to the developers, quite the contrary. I don't wish to offend. Thanks for the hard work you do.
Comment 18 libre 2016-01-08 09:55:45 UTC
a dirty fix/workaround is to edit the document itself:

soffice.bin  --headless --nologo --convert-to odp $FNAME.ppt
unzip $FNAME.odp content.xml
sed -i 's/PT10S/PT00S/g' content.xml
zip --freshen $FNAME.odp content.xml
Comment 19 blockhale 2016-01-08 16:07:46 UTC
Brilliant comment thanks @libre - many thanks. I followed your recipe and it worked nicely in the raspberry pi raspbian distro.

There was a warning when it was re-zipped "zip warning: Local Entry CRC does not match CD: content xml" but the resulting modified .odp file did run ok and there was zero delay. So I'll include this conversion in my scripting.

Interestingly in Linux Mint the converted .odp file was just an uncompressed XML file and I could edit it directly without the unzipping/zipping, but this too worked ok. The --convert-to conversion produced a warning "Warning: failed to read path from javaldx". So I guess there's some sort of issue in the Linux Mint / Ubuntu java implementation and the conversion stopped short of creating a jar archive. It gave the message "convert /path/xxx.ppt -> /path/xxx.odp using OpenDocument Presentation Flat XML". So kudos to LibreOffice for doing the job despite not being able to finalise the compression.

I hope this helps the others seeking a workaround.
Comment 20 Commit Notification 2019-02-22 12:16:38 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/bde5a8623262e50c12a073eb5a78c95211a650a3%5E%21

tdf#61679 tdf#83247: default presentation pause should be 0 s

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Mike Kaganski 2019-02-22 12:19:56 UTC
I call this fixed: it will not add some non-0 pause when opening formats that don't define any pause themselves - which was actually a bug, despite this is marked as enhancement request. Although there's still no means to control the default. If you suppose that there's still a need to control that, please reopen.