Download it now!
Bug 83247 - VIEWING / SLIDESHOW: Pause duration in "Auto" mode defaults to 10s when presentation is opened in PowerPoint
Summary: VIEWING / SLIDESHOW: Pause duration in "Auto" mode defaults to 10s when prese...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium minor
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-29 12:42 UTC by R
Modified: 2019-02-22 12:16 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description R 2014-08-29 12:42:35 UTC
In "Auto" slide show mode (Slide Show > Slide Show Settings under Type) there is a box to set a delay time when reaching the end of a presentation before looping back to the beginning. I want to set this to 0 seconds, however when the file is opened in PowerPoint (which it frequently is - we create slideshows in PowerPoint before they're used on a digital sign system powered by LibreOffice) and saved, it defaults back to 10 seconds. Is there any way you can set the default pause time to 0 seconds please?
Comment 1 Joel Madero 2014-09-02 21:35:56 UTC
From the description this is NOTOURBUG - if I understand you correctly you create a slideshow in LibreOffice and set the timing to 0, you save and close it. If you reopen this slideshow in LibreOffice immediately then the timing is still 0, if you open it with PowerPoint and then save, the timing changes back to 10. Is this correct?

We're not going to change the default timing to 0 - better to figure out why the timing isn't sticking - or to figure out at least if it's even our bug or not
Comment 2 R 2014-09-03 08:30:58 UTC
Yes that is correct.
Comment 3 Joel Madero 2014-09-03 21:20:24 UTC
Yes then this is Microsoft overwriting something if you can reopen in LibreOffice and it still shows 0 - it's something about MSO screwing up the timing.

Marking as NOTOURBUG. Thanks for the input - apologies that we couldn't do more.
Comment 4 Dom 2014-11-02 22:40:04 UTC
If, from Impress, I save a presentation in .ppt format then the wait time will go back to 10 sec when I reopen it in Impress.
This problem does not arise if I choose to save the file in .odp.

I guess Impress is not writing the .ppt file properly?
Comment 5 Buovjaga 2014-11-15 17:10:17 UTC
Saving to .odp works ok.
Saving to .ppt sets it to 10 sec.
Saving to .pptx sets the type back to default!

Win 7 64-bit Version: 4.4.0.0.alpha2+
Build ID: b021b5983c62e266b82d9f0c5c6d8d8900553827
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-12_01:10:08
Comment 6 QA Administrators 2015-12-20 16:15:02 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2017-01-03 19:49:08 UTC Comment hidden (obsolete)
Comment 8 Mike Kaganski 2019-02-22 07:28:23 UTC
This is definitely a bug - or maybe several bugs:

1. In ODF: since PowerPoint seems to not support the pause option in presentations, it simply ignores any value set in presentation:pause attribute [1], and doesn't write it back to ODF. But LibreOffice treats the missing attribute as its "default" 10 s, which is incompliant to the standard which requires that missing attribute be treated as if 0 s pause duration was set.

2. In external formats (namely, PPT), it introduces the (default) delay of 10 s absent in the PPT.

The problem is likely remedied simply by replacing the default of 10 s by 0 s in PresentationSettings::PresentationSettings() [2].

[1] http://docs.oasis-open.org/office/v1.2/os/OpenDocument-v1.2-os-part1.html#__RefHeading__1417722_253892949

[2] https://opengrok.libreoffice.org/xref/core/sd/source/core/drawdoc.cxx?r=e2d2a338#97
Comment 9 Mike Kaganski 2019-02-22 07:30:29 UTC
See also bug 47365 comment 5.
Comment 10 Mike Kaganski 2019-02-22 08:48:55 UTC
https://gerrit.libreoffice.org/68190
Comment 11 Mike Kaganski 2019-02-22 08:54:40 UTC
The change in comment 10 will also change the default delay in new presentations (when no template is used) from 10 s to 0 s. I don't think it's a problematic change, but still want to inform UX people about the change.
Comment 12 Heiko Tietze 2019-02-22 09:12:48 UTC
Zero has the side effect of missing feedback at the end. Test scenario (far-fetched) is one slide where you can click to end which starts over again. 

Not a big deal, and we always help users with their MS issues ;-)
Comment 13 Commit Notification 2019-02-22 12:16:45 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/bde5a8623262e50c12a073eb5a78c95211a650a3%5E%21

tdf#61679 tdf#83247: default presentation pause should be 0 s

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.