Bug Hunting Session
Bug 61680 - Inserting pictures in spreadsheet default to page
Summary: Inserting pictures in spreadsheet default to page
Status: RESOLVED DUPLICATE of bug 86739
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: Other All
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-02 10:14 UTC by p_kongstad
Modified: 2017-07-07 16:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description p_kongstad 2013-03-02 10:14:45 UTC
Today all pictures inserted to Calc is anchored to page.

The basic of spreadsheets are that data is linked to cell addresses, so it is not naturally that pictures should be handled differently.

Also Excel is handling this differently than Calc.

So please consider to default inserting pictures anchored to cell instead of page.

Please allow for dragging from one cell to another cell as well.

In Excel 2010 as an example inserting a picture is inserted with the option 'Move but don't size with cells'
Excel has 3 options available:
Move and size with cells
Move but don't size with cells
Don't move or size with cells
Comment 1 p_kongstad 2013-03-04 06:45:50 UTC
This is also valid for 4.0.1.2 rc
Comment 2 p_kongstad 2013-08-17 13:53:30 UTC Comment hidden (obsolete)
Comment 3 p_kongstad 2014-06-01 17:03:47 UTC Comment hidden (obsolete)
Comment 4 p_kongstad 2014-07-30 19:12:21 UTC Comment hidden (obsolete)
Comment 5 p_kongstad 2014-09-07 11:10:44 UTC Comment hidden (obsolete)
Comment 6 p_kongstad 2014-11-11 22:05:12 UTC Comment hidden (obsolete)
Comment 7 p_kongstad 2014-11-22 09:51:04 UTC Comment hidden (obsolete)
Comment 8 p_kongstad 2015-08-13 19:11:29 UTC Comment hidden (obsolete)
Comment 9 p_kongstad 2016-01-15 10:28:16 UTC Comment hidden (obsolete)
Comment 10 p_kongstad 2016-01-21 14:25:42 UTC Comment hidden (obsolete)
Comment 11 p_kongstad 2016-02-13 10:22:10 UTC Comment hidden (obsolete)
Comment 12 p_kongstad 2016-03-17 21:24:19 UTC Comment hidden (obsolete)
Comment 13 p_kongstad 2016-06-02 20:26:19 UTC Comment hidden (obsolete)
Comment 14 p_kongstad 2016-06-23 06:49:43 UTC Comment hidden (obsolete)
Comment 15 p_kongstad 2016-08-13 12:23:26 UTC Comment hidden (obsolete)
Comment 16 p_kongstad 2017-02-03 18:09:02 UTC
Bug still present in  5.3.0.3
Comment 17 Timur 2017-07-07 07:49:38 UTC
Bug 86739 is the same. I'll mark this one as a duplicate because of your excessive comments and multiple issues mentioned here. No need to write "bug still present" unless something is changed.

"Please allow for dragging from one cell to another cell as well." is another issue and different issues cannot be reported in a single bug. But dragging is possible, if image is anchored to cell. 

Calc has options to protect position and size but it's also another issue.

*** This bug has been marked as a duplicate of bug 86739 ***