Bug Hunting Session
Bug 61685 - Error message instead of all EXTENSIONs updates list
Summary: Error message instead of all EXTENSIONs updates list
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-02 12:38 UTC by Cesar Ramina
Modified: 2015-02-27 22:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
the error screen (21.77 KB, image/png)
2013-03-02 12:38 UTC, Cesar Ramina
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cesar Ramina 2013-03-02 12:38:52 UTC
Created attachment 75778 [details]
the error screen

Problem description: 

When I try to check all updates of extensions, an error occurs. I'm using the language pack for Portuguese Brazil - pt_BR

Steps to reproduce:
1. tools
2. extensions manager
3. check for updates
4. (check)show all updates

Current behavior:

Ocorreu um erro:
Start tag expected, '<' not found
Line: 1
Column: 1

Expected behavior:
show all updates
              
Operating System: Debian
Version: 4.0.1.2 rc
Comment 1 Rainer Bielefeld Retired 2013-03-02 15:32:34 UTC
 [Reproducible] with "LibO  4.0.1.2 rc   -  German UI / German Locale  [Build ID: 84102822e3d61eb989ddd325abf1ac077904985)]"  {tinderbox: @6, pull time  2013-02-28 08:53(?)} on German WIN7 Home Premium (64bit) 

1. Launch LibO
2. Starc Center menu 'Tools -> Exteinsions Manager -> Check for updates'
3. After Message "No Updates ..." check checkbox 'Show all updates'
  Expected: updates shown
  Actual: an empty checkbox in updates list pane, Error message in messages pane.

Error Message:
Start tag expected, '<' not found
Line: 1
Column: 1
Comment 2 Rainer Bielefeld Retired 2013-03-02 15:46:32 UTC
Also a little strange behavior with 3.6.5.2:
After Message "No installable updates are available. To see ignored or disabled updates, mark the check box 'Show all updates'." I check 'Show all updates', get again that lonely checkbox in the "Available Extensions Updates" pane and message "No more details are available for this update." I think that's also wrong, but different to original report.

More info: With 4.0.0.3 an update has been found for me. Bug when I check 'Show all updates' again the lonely checkbox appears, when I click it Iget the start tag message.

Already  [Reproducible] with unzipped  installation of  "LOdev  4.0.0.0.alpha1+   -  ENGLISH UI / German Locale  [Build ID: af60316514f3ae3d4c475819bf86f2af837171e)]"  {tinderbox: Win-x86@6, pull time 2012-11-23 22:10:31} on German WIN7 Home Premium (64bit) with own separate User Profile 

3.7.0.0.alpha0+: can't check 'Show all updates'

Already reproducible with 3.3.3
Comment 3 Rainer Bielefeld Retired 2013-03-02 15:52:30 UTC
The Message might be related to a particular Extension or Update, at least I see it with 3.3.3, but not with 3.4.5
Comment 4 QA Administrators 2015-02-19 15:39:15 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 5 Jean-Baptiste Faure 2015-02-27 22:58:13 UTC
Not reproducible for me with LibreOffice 4.3.6 and LibreOffice 4.4.2.0.0+ (built at home) under Ubuntu 14.10 x86-64.

Setting status to WorksForMe. Please, feel free to reopen if you disagree.

Best regards. JBF