Bug Hunting Session
Bug 61726 - REPORTBUILDER: all reports fail with Java exception IncompatibleClassChangeError
Summary: REPORTBUILDER: all reports fail with Java exception IncompatibleClassChangeError
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: All Linux (All)
: highest blocker
Assignee: Not Assigned
URL:
Whiteboard: target:4.1.0
Keywords:
Depends on: 61564 61725
Blocks: Database-Reports-Builder-MAB
  Show dependency treegraph
 
Reported: 2013-03-03 05:37 UTC by Lionel Elie Mamane
Modified: 2013-03-18 17:46 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
reproduction example (8.17 KB, application/vnd.oasis.opendocument.database)
2013-03-03 05:37 UTC, Lionel Elie Mamane
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lionel Elie Mamane 2013-03-03 05:37:41 UTC
Created attachment 75817 [details]
reproduction example

+++ This bug was initially created as a clone of Bug #61564 +++

Problem description:
All ReportBuilder report executions fail with a Java exception "IncompatibleClassChangeError":

com.sun.star.report.pentaho.SOReportJobFactory$_SOReportJobFactory execute
SEVERE: Detected an IncompatibleClassChangeError


To test / work on this, please make sure:
 1) Use a version where bug 61564 is fixed
 2) Work aroung bug 61725 by commenting out the assertion

Reproduction instructions:
 - Open attachment minimalReportBuilder.odb
 - In the left pane, click "Reports"
 - In the lower right pane, double-click "Contacts"
   (or right-click for menu and choose "open")


See also bug 61564, it contains logs, typescripts, backtraces, etc.

Reported also after a "make clean && make", which puzzles me since Google tells me this error happens when a class has been changed incompatibly and code using it has not been recompiled. A clean/remake should thus make this error disappear, but it does not.
Comment 1 Joel Madero 2013-03-03 17:29:14 UTC
Lionel - as this is your report, marking as NEW.
Comment 2 Joel Madero 2013-03-03 17:34:45 UTC
I would argue that this qualifies for a blocker - marking as such. Lionel - of course if you disagree change it again :-D
Comment 3 m.a.riosv 2013-03-04 00:42:59 UTC
Reproducible with:
Win7x64 Ultimate
Version 4.1.0.0.alpha0+ (Build ID: 8e658ca263808d3466c62b2acfc82d61901fa57)
TinderBox: Win-x86@6, Branch:master, Time: 2013-02-08_22:04:23
Java 1.7.0_15

I thing something is wrong in the file, several options are greyed out, e.g. the wizards. As if the database was in a write protect status.

4.1.0.0 With a new file from scratch, I can reproduce the bug with double click but not with right-click/edit.
4.0.1.2 With a new file from scratch, I can reproduce but not the same bug, with double click opens a writer document but works fine with right-click/edit.

Opening the file in one of the versions, closed the file without closed the program, and open the file in the other version show the same symptoms than the attached file.
Comment 4 DavidO 2013-03-06 00:24:10 UTC
see detailed explanation of the problem and the solution here:

http://lists.freedesktop.org/archives/libreoffice/2013-March/047032.html
Comment 5 Commit Notification 2013-03-06 00:24:55 UTC
David Ostrovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cde76a32058aef5cd19b17f01aebb6715f97ec6b

fdo#61726 java class collision with new idl



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2013-03-11 09:02:36 UTC
David Ostrovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6f28efc2a8a559cc8c37aa883f4de0b59d4fc79c

fdo#61726: rename report-builder package to org.libreoffice.report



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 DavidO 2013-03-18 17:46:58 UTC
<_rene_> _david_: for the minimizer, please add it to the impress gid (gid_Module_Prg_Impress_Bin). (like gid_File_Lib_PresenterScreen)
<_rene_> _david_: that will make it automatically end up in impress ;)
<_david_> _rene_, will do!