Download it now!
Bug 61840 - PIVOTTABLE: Formating numbers in pivot table does not work
Summary: PIVOTTABLE: Formating numbers in pivot table does not work
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 64581 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-03-05 09:05 UTC by Thomas Thym
Modified: 2014-06-21 13:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Testfile with data pilot tab (9.38 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-03-05 09:05 UTC, Thomas Thym
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Thym 2013-03-05 09:05:21 UTC
Created attachment 75943 [details]
Testfile with data pilot tab

Since LO 4.0.0 the formatting of numbers in calc data pilot tables does not work anymore (regression).

Steps to reproduce:
1. Create a data pilot (or use the file attached).

2. Go to the format template (F11) and right-click Datapilot-Result (or -Value) and select "edit".

3. Change the number format (e.g. to 0 digits or 1'000 - marking).

4. The format does not change.

Expected results:
The format should be changed as edited (like it worked in LO 3.6.x and before)

Additional Information:
The change of other formating elements, e.g. background color, font etc. works fine.
Comment 1 Thomas Thym 2013-03-07 13:44:12 UTC
This bug also exists in LO 4.0.1.2 on openSUSE 12.2 (64-bit).
Comment 2 Thomas Thym 2013-03-08 10:02:05 UTC
...and on LO 4.0.1.2 on Windows XP (32-bit)
Comment 3 Jacques Guilleron 2013-03-09 16:39:26 UTC
Hello Thomas,

After your setting, you can use Data > Pivot Table > Refresh.

Regards.

Jacques Guilleron
Comment 4 Thomas Thym 2013-03-10 13:45:17 UTC
Hello Jacques

Thanks for your quick answer.

I tested "refresh". Unfortunately it has no effect. Nothing happens.

After changing the number format manually and pressing "refresh" the original (wrong) format comes back. 
All other format conditions (which I have tested), e.g. background color, work just fine. It's only the numbers format.

Cheers,
Thomas
Comment 5 Jacques Guilleron 2013-03-11 18:27:32 UTC
Hello Thomas,

I confirm your report. With LO 3.6.4.3, news settings for number format update immediatly.
With LO 4.0.1.1 and LO 4.0.2.0+, no update.

I set status to NEW.
OS: Windows 7 Home Premium

Regards.

Jacques Guilleron
Comment 6 Jacques Guilleron 2013-05-14 13:38:51 UTC
*** Bug 64581 has been marked as a duplicate of this bug. ***
Comment 7 Thomas Thym 2014-02-21 16:32:31 UTC
I just checked if the bug is still in 4.2.0.4. Sadly the bug is still here. :-(
Comment 8 Kohei Yoshida 2014-02-22 16:47:45 UTC
This is actually not a bug because we aren't supposed to allow custom number formats to pivot tables.  Pivot tables currently can only take number formats from the source range.  Previously this was "allowed" but that was not intentional.  It was actually an oversight on our part.

To allow custom cell formats (which includes number formats), we would need to extend pivot table to allow storage of custom cell formats.  And that's a feature request which would involve ODF extension, pivot core change, and the whole nine yard.
Comment 9 Jacques Guilleron 2014-06-21 13:05:51 UTC
Following the Comment 8,
I close this report as NOTABUG.

Jacques