Bug 61841 - EDITING: New Radio Buttons by Copy/Paste will not work in new document
Summary: EDITING: New Radio Buttons by Copy/Paste will not work in new document
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-05 09:21 UTC by Rainer Bielefeld Retired
Modified: 2015-06-14 13:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample Document (24.44 KB, application/vnd.oasis.opendocument.text)
2013-03-05 09:21 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-03-05 09:21:19 UTC
Created attachment 75944 [details]
Sample Document

Steps how to reproduce [Reproducible] with  "LibreOffice 3.6.5.2 " German UI/ German Locale [Build-ID: 5b93205] {pull date 2013-01-18} on German WIN7 Home Premium (64bit):

1. open attached sample document
2. If necessary, menu 'View -> Toolbars -> Enable Form Controls"'
3. If necessary disable form controls edit mode
4. Click between table and horizontal line on top of page
5. <control+a> to select all
6. <control+c> for 'Copy'
7. Menu 'File -> New -> Writer Documents
8. Click into new Writer document
9. If necessary, menu 'View -> Toolbars -> Enable Form Controls"'
10. If necessary disable form controls edit mode
11. Try radio buttons, 
    Expected: both should work, only 1 checked always
    Actual: not reliable, sometimes you can check 1, sometimes none, and 
            sometimes it works.

This works reliable with OOo 3.1.1 and AOOo 3.4.1, but is already broken with LibO 3.3.3. (Using attached sample document)

Copy / Paste to the same document generally works.
Comment 1 A (Andy) 2013-04-11 20:13:47 UTC
not reproducible with LO 4.0.2.2 (Win7 Home, 64bit)

@Rainer: Does this issue still persist for you with the latest release of LO?
Comment 2 Rainer Bielefeld Retired 2013-04-11 20:57:58 UTC
(In reply to comment #1)
Yes, still appears, but still difficult to reproduce. I have some new fragments of knowledge, hope I will find the time next days to sort and contribute them here.
Comment 3 Jorendc 2013-11-19 18:26:52 UTC
I can confirm this behavior, tested using Mac OSX 10.9 with LibreOffice Version: 4.2.0.0.alpha1+
Build ID: 9c45345a680f7444df251f9403c7d56572380f21
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2013-11-18_12:43:03

I followed Rainer steps and only can check one radio button. Clicking on the other one doesn't result in any action.

Kind regards,
Joren
Comment 4 QA Administrators 2015-04-19 03:22:03 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 5 Gordo 2015-06-14 13:10:11 UTC
Could not reproduce.

Windows Vista 64
Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16

4.1.6.2