Bug Hunting Session
Bug 61866 - Background colour in tables can only be cleared in the same way as applied
Summary: Background colour in tables can only be cleared in the same way as applied
Status: RESOLVED DUPLICATE of bug 82504
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables
  Show dependency treegraph
 
Reported: 2013-03-05 16:58 UTC by john.pratt
Modified: 2017-07-31 21:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example produced to show the types (8.85 KB, application/vnd.oasis.opendocument.text)
2013-03-05 16:58 UTC, john.pratt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description john.pratt 2013-03-05 16:58:34 UTC
Created attachment 75975 [details]
Example produced to show the types

Backgrounds seem to be able to be applied to either text or cells.  That makes sense, although it is confusing using the same button for both.  But, if I want to remove the background (within a table in writer) that I have applied I would expect to be able to remove the background by highlighting the whole area, selecting background and changing to none.  This only works if the background was originally applied to whole cells (by selecting more than one cell).

This is similar to bug 47853 but I don't think it is the same.

1. Open an attachment
2. Highlight a table
3. Using the background button on the toolbar set the background to none

Expected behaviour: all background colour is removed
Actual behaviour: only background colour applied by selecting multiple cells first is removed*.

* or by selecting multiple cells with the mouse and reducing back to one cell before releasing the mouse button.

This can be particularly confusing as some cells may have had both methods of applying backgrounds applied to it, so it looks like nothing has happened when you try to remove it.
Comment 1 Joel Madero 2013-03-18 19:22:52 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version 3.6.5.2 
Platform: Bodhi Linux 2.2 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm this problem on an earlier release I am changing the version number as version is the earliest version that we can confirm the bug, we use comments to say that the bug exists in newer versions as well.

Marking as:

New (confirmed)
Minor - doesn't prevent high quality work, slows it down a little
Low - default, seems appropriate, really easy to workaround the issue


+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 QA Administrators 2015-02-19 15:37:37 UTC Comment hidden (obsolete)
Comment 3 Jean-Baptiste Faure 2015-02-28 19:44:34 UTC
For me that is not a bug. The background buttons in the table toolbar and in the properties tab of the sidebar, change the background color of the selected object : character, paragraph or cell. You may not want to remove all these background colors by the same action because the 3 colors might be different.

Set cc to ux-advise.

Best regards. JBF
Comment 4 Yousuf Philips (jay) (retired) 2015-03-01 06:54:39 UTC
This relates to bug 82504 which i have filed and the correct behaviour of the background button when inside of a cell should be to fill the cell and not to fill the paragraph color.
Comment 5 Robinson Tryon (qubit) 2016-08-25 04:44:53 UTC Comment hidden (obsolete)
Comment 6 Heiko Tietze 2017-07-31 15:38:21 UTC
As you say, it makes sense to have different ways to colorize. The issue is the control as handled in bug 82504.

*** This bug has been marked as a duplicate of bug 82504 ***