Bug 61870 - particular FORMCONTROLS disable focus on last caret position at FILESAVE
Summary: particular FORMCONTROLS disable focus on last caret position at FILESAVE
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2013-03-05 18:17 UTC by Rainer Bielefeld Retired
Modified: 2015-12-21 15:14 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:

Sample Document Showing Bug (505.19 KB, application/vnd.oasis.opendocument.text)
2013-03-05 18:17 UTC, Rainer Bielefeld Retired
A table in a text file I am building (40.35 KB, application/vnd.oasis.opendocument.text)
2013-03-06 13:53 UTC, mannunshesh mekenok

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-03-05 18:17:53 UTC
Created attachment 75978 [details]
Sample Document Showing Bug

Precondition for tests is that in simple normal documents it works for you that when you open a document caret is at the same position as when you closed the document and focus is on flashing caret.

Steps how to reproduce with  "LibreOffice " German UI/ German Locale [Build-ID: 5b93205] {pull date 2013-01-18} on German WIN7 Home Premium (64bit):

1. Open attached sample document
2. on page 9 before the first character of the text line below the picture
   insert a comment with a simple "x" as text 
   > comment will additionally show your name as Author
3. Click before first "i" second text line below picture
4. Save with new name, close and reopen document (form menu "File -> 
   Recent documents")
   Expected: caret flashing before first "i" second text line below picture,
             focus on caret
   Actual: Focus at top of page (more or less), may be no caret visible
           The first moment it seemed that the focus would be somewhere nearby
           picture, but then it switches to top of document.

What might be the reason?

10. Continue after step 4:
11. If necessary, menu 'View -> Toolbars -> Enable Form Controls"'
12. If necessary enable form controls edit mode
13. Click big button at top of page
    > Control Points appear
14. <Del> to delete
14. Proceed analogous to steps 3, 4 to save document with an additional comment
    > Now it works fine, caret and focus at latest caret position

Additional info:
So the reason for the problem is the button. I did not yet test whether the problem appears with other documents or whether additional conditions are precondition for the bug.
The sample document is based on a document with history back to OOo 1 (possibly), I did not yet test a newly created sample document.
I did not yet test with what version that problem appeared
Comment 1 Rainer Bielefeld Retired 2013-03-05 21:36:33 UTC
Can you please try to reproduce my results?
Comment 2 mannunshesh mekenok 2013-03-06 13:53:10 UTC
Created attachment 76016 [details]
A table in a text file I am building

File on which the cursor problem happens
Comment 3 mannunshesh mekenok 2013-03-06 13:56:55 UTC
The file is a text file containing a table.

I enter data on a new row at the bottom of the table.
Save file.
Open file
Expected: the cursor is at the last point of data entry after the last entered character in the last row.
What actually happens: the cursor is at the beginning of the empty line above the top of the table - the first line of the file.

Try adding another 'm' after the three I added in the last row.
The cursor should be after the 'm' you entered. If you see my problem, the cursor will be at the start of the empty line above the table.
Comment 4 raal 2014-12-15 14:16:27 UTC
I can confirm with LO 4.3.4, win7 with both cases.
Setting as duplicate of bug 80960

*** This bug has been marked as a duplicate of bug 80960 ***
Comment 5 tommy27 2014-12-17 06:28:00 UTC
I'm not sure this is a duplicate of bug 80960

the current bug has been reported already in LO 3.6.5 whilst bug 80960 just affects the 4.3.x branch and has not been reported in earlier release.

so maybe these are different issues.
I add Cor Nows to CC list so he can tell if the bug is the same or not.
if not, we should revert status to NEW.
Comment 6 Cor Nouws 2014-12-17 14:19:54 UTC
(In reply to tommy27 from comment #5)

> so maybe these are different issues.
> I add Cor Nows to CC list so he can tell if the bug is the same or not.
> if not, we should revert status to NEW.

Indeed. Te description of this bug explicitly tells "the reason for the problem is the button"
Comment 7 Cor Nouws 2014-12-17 14:20:07 UTC
setting back to new
Comment 8 QA Administrators 2015-12-20 16:10:57 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)


2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 

4b. If the bug was not present in 3.3 - add "regression" to keyword

Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-12-20
Comment 9 mannunshesh mekenok 2015-12-21 14:40:59 UTC
I retested this in Version: Build ID: 430m0(Build:2).

The problem did not occur.

Thanks for the fix.
Comment 10 tommy27 2015-12-21 15:14:03 UTC
nice to hear that.
however correct status is RESOLVED WORKSFORME since we don't know the exact committ that fixed it.