Download it now!
Bug 61923 - EDITING: Word completion adds fullstop when a word has been used followed by a fullstop.
Summary: EDITING: Word completion adds fullstop when a word has been used followed by ...
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha1
Hardware: Other All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:4.1.0.0.beta2 target:4.2.0 tar...
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-03-06 22:11 UTC by pavel223344
Modified: 2013-11-20 03:27 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Attachment 1: LibO4 (4.52 KB, image/png)
2013-03-06 22:11 UTC, pavel223344
Details
LibO3.6 (3.63 KB, image/png)
2013-03-06 22:14 UTC, pavel223344
Details
LibO4 (4.52 KB, image/png)
2013-03-06 22:17 UTC, pavel223344
Details
LibO3.6 (3.63 KB, image/png)
2013-03-06 22:18 UTC, pavel223344
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pavel223344 2013-03-06 22:11:39 UTC
Created attachment 76055 [details]
Attachment 1: LibO4

Word completion adds a full stop to word suggestions if the word has occured in the document followed by a full stop. 

To repeat:
1. Enter a long word followed by a full stop (as if in the end of a sentence).
2. Enter the same word again. After a few characters word completion pop ups suggesting the word with a full stop added. 

Expected behaviour: The word should pop up without added full stop.

In LibO 3.6 the word pop ups without a full stop so this is a regression. 

The word is correctly given, without a full stop, in the list of words collected for word completion. The user can't delete faulty words.

In practice this makes word completion unusable since you have to check every completion and if the full stop appears in the wrong place you have to correct several characters. 

Attachment 1: LibO 4. Word completion adds a full stop after the word "forskarliv" i.e. "forskarliv." (Swedish)

Attachment 2: LibO 3.6 Word completion suggests "forskarliv" without a full stop. (Correct behaviour)
Comment 1 pavel223344 2013-03-06 22:14:07 UTC
Created attachment 76057 [details]
LibO3.6
Comment 2 pavel223344 2013-03-06 22:15:08 UTC
Comment on attachment 76055 [details]
Attachment 1: LibO4

>PNG
>
>���
IHDR���¾���I���k���sBITÛáOà���	pHYs��Ä��Ä+��µIDATxíyT×Ç3	!$컢"*D(
>T5 *TPÜ«µVEëV´hÝê³­µUÛª]´V«µbÜû¬­jÝeÓ*.ì5aȾÍ}lÂþù'gró[îürÉ|Cùàÿë�(^U¨Ò¡ 	U:$¡J$TéP*
>P¥CA¥Äw÷/>vÕuIGGôÒP¤oNnuIÖKBY~bó0;ÌéíKâvòÞ.Eik&öÀ°Ðâ%4
Yáõ¼0|ø/5-/"}$·RúôXpI(ºñ¯õ¥>s~wëAnË^°ÍÐÒ¾²ä+î¾ðX¿úñÞÁ¸ãì¢v
>CÇÅKÊZ9Ã9ÀW¿�Í áÏx6>ìH5Ñ|ÈÀ¨#/:y¼ÄÁ¿{ðOGÙSç~AC{Û¶6
ÒæEhGûªÇçxÙu¤¾ñmGeqLfÓzHt¨«¨SÓÞi¦ßòôÐæE0Õ>N§wPýµó·dƽfobY¶pÑVTfÇhôY¡¶ö¸¤ªÌÚ0ÒÀÂgXDDìªË
ðöî9C6óÆƬjìÁîY,ÀyüïOâa	Àö_xò©
>©ÝüîÝ0[pYBÊ'g7N
>;zøÀý&ªÐkcÈø¾¤`x%ÿ´oUì�7ß·¤OyáÁ¤�˸÷Ìo ¸àðºøvþI²/·´¯;aI^<j_häøISb¬¡q6Ñ!åÓ+GD3|`ÿ¸^Ø:ú÷ëÜ%§øÂõ£8!£cc¹^³ö=j¹h+ky¶qÑyC9ÃÜ"cúvsd193¾¼Y§Fú&Ñu!1Òcvý²#c¾(¢âÌçs_³¾
>$:!=k°aîQ!ó
¬uDæ8áA{*T!$º²¨+tg!eñÎ ºË;Y
HYºsæ0ù×bÜÿ:Üly¨@©Ê¿	Ä5$û{?Ã#á5B¯¾ÿU¡i·1j,¯8t!÷â¶Y²%;Q|5¹ØÄ®Õ̾ÂKCæfÔkÛ×)ñ͸græ3i-D!ºô»Û¬z²ô`Ê÷H|m¡;ÎùªDBâkׯkt9Ïý«umf­eÜ8ÂÌvXÐ
>5BHVrh8¿}®Ðí´\é1iNJwÜwóBÉî¬õ¦õÝT GÚ!5¯u¤_Oði¶hcèäï;Rá=elw�z°.UYÈ�0§Yyí×Õª´>(Íûf×í®³9â��,λ©c\é¦Ç_6høâÝïs¬GÆ
>\ÔWxjû¿ù�ª¿ò}ÞС­.ÌÄ9_ï+éõNb¨½öDe0¨²¾öanÝkægs{[è¸^û¯v�@wðrÂüUk.LËÚD0º%�À²GüêÕÇöæh¶pÍö.¤pa~飪<³*µdîî@k¬ôñý*TøCâóL¬åÓ	:wiÐè8 ¤}óB¿.ÆV^A>æ§1FCcô½<tÃíéeSmÎï-Ù`¬Ê4õïÖ@Wÿ®¦aè="Åß}_̤å+çôÐúÝ=¼iÓáûÈÞ+ÏU£ÐÖ]µÉ0ºúuúÒÇbNC|.Ìí1]$ëÏ¿x4ÙËä`�ø-Ùwb®GñIUÖ¦�BE Vv¤k {NH·,~Ç{1½§l÷a´Ú*5`8®á0�¶å?~|ÿw;¶/u0w/mló[âk+GϹrçʲ>õ'¹¿NnÃEÛî$×ÛÈÖ`J*¥ÀÒ®ãÐXF`^é¹Ë9*;ðɨ)¾ws­_³k?¨È­å�c÷ä¸CéÕâÖ>HÖøspÈ÷¦:?üzÍƽ´·âº·ñ- Ùzug¡ü'
>SÂPÕó	·ÁSR¿ÏÊùqø·ýy-.ì©«s®òC=uF£.ÚtGùüÇÐ}°7ÛTFzÿå­]¿næ¢ë9÷6%ýP¢l£tXþ³&º?ý!õÛìz�@-(M\­8æû
>ö-ý$㩦UBç&o¸àeá½·TiÀMÈây=+O¥;¿åÖæÕ&èh»Â]Ê@)|&#!¾²nÅé*�peåÚÇ[°DMq¥pkwgàÆÕÿȪ¦ ¯nËEÛY7o#åfêÌ?8sýtgõV:Ö@Ѻ;%gÏI!­*çKcnÇáüÍ.¥.=­­ ¼ðçÑ�VSr´Dú¯gv·¤Y¹z·$­T\vtÕH[ÀûÏÞvþé³;?.·Úy»¯çýúQÂ0ÞWí¹^«\ÝÏÁÂÂÆÝ{@ÐèäH^ÌkÙF¥g\T¶b-àý¦¯ýáF­!ÉíÍal`ýÍðemEáö`=¿&ÜÒþ®´=ZÞoÚýÙujTUcz[ãLW èy³}1püàJ?Gøƪp_¿×GG5$hüU*ÄÙÙÀðà[wöìÚ¡�îþãWlèöaËÓËÈÓ×´µ¢¥ñõW¦¬(M[6>|DwÄð`N_ÿèNW(ëv³¦0Òc!ÿTÒ@+�º':)erW õºõfÑRTâ'ë¦tpÿùµìÁ1¶�¶êô÷&«Jw.Þ{qe¶ÿ3x%R&s͸#¦­Mý+vÇnýNįuªÿ?ÞZÊÎ>êÈü]ÁöímGÓ}Ã{üôº;½t£Ý×G4üÃwb^ÍÒ¡èPw	R*
>P¥CAªt(HBI¨Ò¡ 	U:$¡J$ý7¬WtÁÿ:f2&¹@û]ò¥F
>P¥CA[:/E¬nDál­èÌIðRÒÁ<<­×uû3i¦ú ñãîì¥á®ç¢m|;ÙOé/µt¤9&~(_vôó¡XÕv{Ã0{OMIÌ&¥eôOIÒ«EV
Y	^6Þ1G®ÒÈËI=®zFzÁøÅiê¦û38Χ¸ì`¶ 1)òÕÛòôNÔU÷ëÔáù#¦õ¨âÉÅï>>øPð\|Å@é¼X½ý`ú-OÏØû¦ùwÜuÊtP飺ٲ~JAp?æ»&uZ°'ì9ɧïïY9$üøñá<ºM½ìém	êêÛ&í/ÍýòÍ1o,=-hÒ¨«.l[¾îßÕDþic"ãV_¬èȲ¨Á¯GF
äD,M+Èî_ÂÆz,:´u{ÿÙ2P=ýíý¨×B#£Çù°¯Lkj@¢¼Ï¸¡	Û3+Õ ÍÝÀ1È;ð­ýr!êní^n¹&\©+úia %¹F§¸-D ¹¶~RO{ÎÂCŤ/&¦:�`xð@oF:|4ÌaO¤ý]Nærl¤m¼Ö»¿Ãw#6:|7Æé}/`^¶;âÜ
bFùÙãà 5o[;X-
>w=c;Ó"~wKjiauëf½~¬ëî�fΫǶ2<ß½"B)l�oe6hî7®Ö«o®èÅèÿa¾!D4\^ÞÖ+å¦éKÊ
¨»
)}ë+½u
6h?¢ ØÛ¨LÝ0&¥´àòøÑY4åËãϸ!þüw>'XQAUuxü±gë3ó¹<>'XtWôÞ	>Ç3WIÈ$ñ¹éU_=CÊZÑGYÕKó¥?4¾+/:ÆçòøÓr-y|î±ãR$®xÇãsy|îñ5k.¯9¿FÓ{apÃêñܹ*ýØ�`Ñ5$À¾6'[к,HIÞî{NÜÏ
>�0×æÌìQ|`wfÖ««»[*ÀÒÛ$:©Ns��Óp¶­7Ã�åÂ3¢f#4K˹~´39âGa£Q�@(!Î~>ZÉ/W«î6¤Õ·º¾V«N«X]XC��l'+ïé=sNÓ 5´5«Çi)=RÉUÀ´a1"qÙÝJpêåÜX×¾®Py·LWͤMHJ¢÷õ÷o,Ùù¸i'$ù['Ä}«`[6Ý·+ºûsêô7â¦Íz+qk®Zÿ:)ÉlmËè3{y¨*c{z
>Õß[3×Dѵié��´VrZl± ÂeÏë6±.xó÷NjoÉ&yÀzt³þàuû5íö1ôÌtUz-*Ê$÷0F¼x@Úµ­$9uÀÔ¡wç«ÕÝâ]Q9Êͬë
>îÝ6°ãÆì÷å?½qduH]Ú¢Qg¦7.¶PÎQYÒ'£ª¾ZðÅ]ͲB|måè9Ùz$íàoß qî9!e+{Ç{eg§L7]tmr:H©øæ\UòuqóÝ0§U8Þ¦%£XkÉZæC×xe:Ù|ĸ»~ÓÍú/ªÈ-|ÕRù/|Ô§7ÓŤË2Ew§¹Ò¡w¹k­oÞGÓc'Nù%ræT²îcBZc÷ðwª¢êÆÑS!(ÛÀ,ýÎ6¦îÖQ8Wzy2u2éÐ4GxP!Þz±æÓ*,Ø®õ¢ñÁréW?Û1l��;{GêôÅN6"rÉê­Ys|­r¹ 5
>FJGr}uüÇ
ÑI³§Ï=stOyÙQ)²!Xùoû¥ýrO
>�¨!{ß¡rï·çsXú-
¨»5oh+ª*½ÍBWt­,Ü1ÂÎvøö­æcz:L'ëw�25ÔÐó
 @åE
Geó8LG¤2Bͤ÷gaw·ÇIï$µ3b<Ôø]@ æz2åÙ,CêñÜzeåÙ¥þÚ3ÇÛ§«4OèjVG_6­·õÄêHZ¶$"`ȨqcÂE.;R$5¤Fzên9ÿü}óð¥?=ª¼¬§ô>u°¥Ay1ïã:s©¶Ä]óÜOmѵâáa66ö?kmLKédÄåñÇeòóe×*Lº Ì#$}Yq´j@¸ý¨î­S5«Õ5u²#weuÈX·ì(OéÁ[5qé|.OðæUáéjÊóõn	OW©²î×'lÜIqyüYy¢h{´jg!®j}´ÝwXFtXÊòsæÜK>þq¨
@îî
>XÁþÿG¬CûWó«ËÿÕM«R|9¡÷{ÙÍO]ãbó[]ûÕpç ñÏôã\_ó¢é¿æHÇ×ùßÊù})1:k(Ò¸÷D²Giþf5m¹O{ÑH5-7R­×¼àòé.O i :àxÓëüLXDÍ¥ÏWØ8YãJá3¹{TÊÔî/°·y -i××
2&¹i^tðq�8ïí	¥9§ I'¸ïâÕ*
>P¥CAªt(HBI¨Ò¡ 	U:$¡J$TéP*
>P¥CAªt(HBI¨Ò¡ 	U:$¡J$TéP*
>P¥CAªt(Hò_{Á+É3����IEND®B`
Comment 3 pavel223344 2013-03-06 22:17:39 UTC
Created attachment 76058 [details]
LibO4
Comment 4 pavel223344 2013-03-06 22:18:44 UTC
Created attachment 76059 [details]
LibO3.6
Comment 5 Cor Nouws 2013-03-30 20:53:02 UTC
Hi Pavel.

Thanks for the issue. Confirmed.

Pls note that the words are listed without full stop in Tools > Autocorrect options > ..
Comment 6 Cor Nouws 2013-03-30 20:55:05 UTC
problem in 400alpha1 already
Comment 7 Cor Nouws 2013-03-30 21:28:35 UTC
was OK in 3.6
Comment 8 Michael Stahl (CIB) 2013-06-04 21:42:02 UTC
fixed on master.
Comment 9 Commit Notification 2013-06-04 21:49:23 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=452b2172c37537aa059d08307b4592adecc20960&h=libreoffice-4-1

fdo#61923: sw: word completion: do not add trailing '.'


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2013-06-04 21:49:43 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=246d7e280ea8b7d1e27e14a6568d2a65cc8c9e7b

fdo#61923: sw: word completion: do not add trailing '.'



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Cor Nouws 2013-06-04 22:16:15 UTC
(In reply to comment #10)
> Michael Stahl committed a patch related to this issue.


thanks Michael - great that this improves again!
Comment 12 Commit Notification 2013-06-06 08:32:25 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fe86346c4900914da1e0ebf87f97a0044640490e&h=libreoffice-4-0

fdo#61923: sw: word completion: do not add trailing '.'


It will be available in LibreOffice 4.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Kumāra 2013-07-15 08:55:48 UTC
I've very little knowledge in programming. Hope this makes sense.

The feature works perfectly fine in LO3. So, instead of trying to fixed the existing LO4 code, can't we just copy the relevant code from LO3?

I'm suggesting this because there seems to be one issue after another with this since LO4, and copying from LO3 *might* be a more elegant move.

If this is a stupid idea, please ignore. :-p
Comment 14 Tomaz Vajngerl 2013-07-15 10:01:45 UTC
(In reply to comment #13)
> I've very little knowledge in programming. Hope this makes sense.
> 
> The feature works perfectly fine in LO3. So, instead of trying to fixed the
> existing LO4 code, can't we just copy the relevant code from LO3?
> 
> I'm suggesting this because there seems to be one issue after another with
> this since LO4, and copying from LO3 *might* be a more elegant move.
> 
> If this is a stupid idea, please ignore. :-p

If this feature was working perfectly fine in LO3 it would not be replaced with a different solution in LO4 (for me previous implementation did not work for every word) - so copying the code from LO3 does not make sense.

The new implementation has had bugs but were fixed - currently I don't know of any more reported bugs.

Regards, Tomaž
Comment 15 pavel223344 2013-07-19 15:52:25 UTC
The feature worked well in OOo and LO 3 for many years. The new
implementation broke something that did not needed to be fixed.


2013/7/15 <bugzilla-daemon@freedesktop.org>

>   *Comment # 14 <https://bugs.freedesktop.org/show_bug.cgi?id=61923#c14>on bug
> 61923 <https://bugs.freedesktop.org/show_bug.cgi?id=61923> from Tomaz
> Vajngerl <quikee@gmail.com> *
>
> (In reply to comment #13 <https://bugs.freedesktop.org/show_bug.cgi?id=61923#c13>)
> > I've very little knowledge in programming. Hope this makes sense.
> >
> > The feature works perfectly fine in LO3. So, instead of trying to fixed the
> > existing LO4 code, can't we just copy the relevant code from LO3?
> >
> > I'm suggesting this because there seems to be one issue after another with
> > this since LO4, and copying from LO3 *might* be a more elegant move.
> >
> > If this is a stupid idea, please ignore. :-p
>
>
> If this feature was working perfectly fine in LO3 it would not be replaced with
> a different solution in LO4 (for me previous implementation did not work for
> every word) - so copying the code from LO3 does not make sense.
>
> The new implementation has had bugs but were fixed - currently I don't know of
> any more reported bugs.
>
> Regards, Tomaž
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 16 Tomaz Vajngerl 2013-07-19 17:18:22 UTC
(In reply to comment #15)
> The feature worked well in OOo and LO 3 for many years. The new
> implementation broke something that did not needed to be fixed.
> 

As I already said the old implementation did not always work for me but anyway even so the new implementation is better. Why - because it can search for the word faster and the stored words consume less memory. Sometimes we need to change or replace something which is (generally) working for the reason that the LO becomes faster, more lightweight and better maintainable and sometimes we break something in the process - shit happens - we don't do this intentionally.

But by your "logic" we should just fix bugs and functionality without touching anything that is already working - if we would work like that sooner or later nobody would want to work on LO because it would be harder and harder to maintain, harder and harder to add new features and LO would become slower and never faster. If this is how you want us to work then I don't want to work on LO even if I get paid, not like now - afternoon in my free time.

I am sorry that the bug caused you problems but please never say ".. broke something that did not needed to be fixed .." if you don't know what you are talking about.

Now I need to go calm myself down.
Comment 17 Kumāra 2013-07-20 03:34:02 UTC
(In reply to comment #14)
> If this feature was working perfectly fine in LO3 it would not be replaced
> with a different solution in LO4 (for me previous implementation did not
> work for every word) - so copying the code from LO3 does not make sense.

Like I said, it may be a stupid idea. :-)

 
> The new implementation has had bugs but were fixed - currently I don't know
> of any more reported bugs.

Great! Thanks answering and of course for your contribution to LO.
Comment 18 Cor Nouws 2013-07-30 21:30:32 UTC
works fine in 4.1.0