Bug 61986 - FILTER: Excel cell comments are set to white text when opened in Calc
Summary: FILTER: Excel cell comments are set to white text when opened in Calc
Status: RESOLVED DUPLICATE of bug 51300
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: All Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: needsDevEval
Depends on:
Blocks:
 
Reported: 2013-03-07 21:37 UTC by Nick T
Modified: 2015-12-18 10:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Simple .xls spreadsheet to show issue with importing cells with comments (18.00 KB, application/vnd.ms-excel)
2013-03-18 19:28 UTC, Nick T
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nick T 2013-03-07 21:37:18 UTC
Problem description: 

When an Excel spreadsheet with cell comments is imported into Calc, the colour of the text in cell comments is set to white.  On the default light yelloy of comments popouts, this is invisible and it looks as if no comments have been imported.

Steps to reproduce:
1. Add a comment to a cell in a spreadsheet using Excel and save file.
2. Open file in LibreOffice calc and view the comment.

Current behavior:
Text is set to white and is therefore unreadable on the default light yellow comment/note background.

Expected behavior:
Imported text should be set to either black or "automatic".

This faulty behaviour is also discussed in the OpenOffice forum at http://forum.openoffice.org/en/forum/viewtopic.php?f=9&t=41232
This includes a python macro that could be used as a workaround.
Operating System: Ubuntu
Version: 4.0.1.1 rc
Comment 1 Joel Madero 2013-03-18 19:04:48 UTC
Please attach a file as many of us don't have Excel to create files. 

Marking as NEEDINFO. Once you attach file, mark as UNCONFIRMED and we'll take a look.
Comment 2 Nick T 2013-03-18 19:28:57 UTC
Created attachment 76707 [details]
Simple .xls spreadsheet to show issue with importing cells with comments
Comment 3 Nick T 2013-03-18 19:32:50 UTC
I have uploaded a simple file to show the issue.
Having checked, I can also confirm that this issue only relates to comments in cells imported from .xls format worksheets.  Cells with comments imported from later .xlsx worksheets do not have this issue.
Comment 4 Joel Madero 2013-03-18 19:39:41 UTC
Thank you for the updated info & attachment. I have been able to confirm the issue on:
Version 3.6.5.2 
Platform: Bodhi Linux 2.2 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm this problem on an earlier release I am changing the version number as version is the earliest version that we can confirm the bug, we use comments to say that the bug exists in newer versions as well.

Marking as:

New (confirmed)
Minor - doesn't prevent high quality work, just slows it down a little
Normal - inconsistent between xls and xlsx, comments quite common

Keywords - ProposedEasyHack


+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 5 papukaija 2013-06-06 16:08:19 UTC
Thanks for the report. This bug looks like a duplicate of bug 51300 which has been fixed in LibreOffice 4.0.4 and newever. I have marked it accordingly. Thanks.

*** This bug has been marked as a duplicate of bug 51300 ***
Comment 6 Robinson Tryon (qubit) 2015-12-18 10:14:18 UTC
Migrating Whiteboard tags to Keywords: (ProposedEasyHack -> needsDevEval)
[NinjaEdit]