Bug 61991 - “Crop Image” toolbar command for conveniently crop images isn’t available in Writer and Calc
Summary: “Crop Image” toolbar command for conveniently crop images isn’t available in ...
Status: RESOLVED DUPLICATE of bug 34555
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: All All
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 74099 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-03-07 22:43 UTC by all_web
Modified: 2014-03-29 16:48 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (57.75 KB, image/png)
2013-03-08 13:43 UTC, Adolfo Jayme
Details

Note You need to log in before you can comment on or make changes to this bug.
Description all_web 2013-03-07 22:43:34 UTC
Srs.
Si draw e impress tienen la opcion de recorte de imagenes con el icono de recorte en forma de tijeras? porqué writer y calc no lo tiene habilitado, y aun siguen usando el recorte por tanteo dentro del menu herramientas.?? Porfavor algo tan simple pero muy usado,
Comment 1 Adolfo Jayme 2013-03-08 13:43:58 UTC
Created attachment 76162 [details]
screenshot

This is a complaint, but I’ve toned it down while translating it:

“Draw and Impress have a convenient, visual Crop command (scissors), which is not available in Writer and Calc. Can you please add it? Thanks.”
Comment 2 Joel Madero 2013-04-15 02:03:07 UTC
Indeed I see the point. 

In the future all_web please do not post in another language, get the translation first, we usually close these as INVALID as it is against our policy for bug reporting.


Marking:
New (confirmed)
Enhancement
Highest - In my opinion very useful and not good that our toolbars function differently. It is a common task to want to crop an image, having the toolbar function the same would be convenient.

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 3 Björn Michaelsen 2014-01-17 00:43:35 UTC
(This is an automated message.)

LibreOffice development currently prioritizes bugs with the so called MAB (most annoying bugs) -- as this bug has not run through that process (including writing a short rationale for this bug being a candidate and other who are watching the tracker bug silently approving that rationale etc.) its priority is set to high. Note this is effectively no change in the urgency assigned to this bug, as we are currently not making a difference between high and highest and severity is untouched.

You can find out more about MABs and how the process works by contacting libreoffice qa on irc:

 http://webchat.freenode.net/?channels=libreoffice-qa

The QA wiki page also gives you hints on how to get in contact with the team (if IRC fails you, your next best choice is the mailing list):

 https://wiki.documentfoundation.org/QA
Comment 4 Tomaz Vajngerl 2014-01-27 07:35:04 UTC
*** Bug 74099 has been marked as a duplicate of this bug. ***
Comment 5 Tim Deaton 2014-01-28 14:48:02 UTC
[Because I created issue 74099 (marked as a duplicate of this bug) and because of Bjorn's comment about "writing a short rationale", I decided to copy my statement from issue 74099 below.  Thanks to Tomaz for noticing the duplication. -- Tim]

I have long found that when I need to print something from the computer screen, the easiest way to do it was to hit PrintScreen, then paste it into an Excel spreadsheet, then crop and resize it till I have what I want.  For instance, I frequently want to crop & overlay two Google Maps screenshots so they fit together.  Or save an entire year of cropped screenshots of payroll tax confirmation screens on the same spreadsheet page.  (For me, Excel does these things far more easily than Word or Paint.)

For years I've occasionally tried the same thing using first OpenOffice Calc 3.x and now LibreOffice 4.0.x, and found that it is much more difficult.  Calc brings up a window with measurements you can change, and its own small snapshot of the graphic that shows where you are moving the borders to.  It works, but it is hard to get it just right.  You cannot see it well, and must repeatedly invoke the tool, change the measurements, and quit the tool to see what you've really got.  It takes several iterations to get it where you want it.

Excel's cropping tool (at least as far back as Excel 97) allows the mouse to grab the handles on the graphic's edges and drag them where you want them, which is far easier both to see and to do.

PLEASE add a mouse tool that can be used directly on the image in the spreadsheet.  The cropping icon could still bring up the window (for those who prefer it), and then a button in that window could replace the window with the mouse tool.

Thanks,
Tim
Comment 6 tommy27 2014-03-29 16:48:39 UTC

*** This bug has been marked as a duplicate of bug 34555 ***