Bug 62045 - FILESAVE: Inconsistent Column Width & Freeze After Save
Summary: FILESAVE: Inconsistent Column Width & Freeze After Save
Status: RESOLVED DUPLICATE of bug 49742
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: Other Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-09 04:37 UTC by ign_christian
Modified: 2013-06-05 15:22 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
spreadsheet file with many workbooks (141.50 KB, application/vnd.ms-excel)
2013-03-11 06:19 UTC, ign_christian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ign_christian 2013-03-09 04:37:07 UTC
Problem description: 
It seems that filesave not exactly saving information about column width & freeze window. I can't attach a file because this inconsistent behaviour. One time it is saved correctly, another time column width change & freezed column/row disappear.

Steps to reproduce:
1. Open any microsoft excel 97/2000/xp/2003 file (.xls) -> we call it bug.xls
2. Create some data with some columns, freeze a row and/or column
3. Save & close the file (bug.xls)
4. Open other file(s), do some changes, & save the file(s)
5. Open bug.xls, see if any changes with column width and/or freezed row/column
6. If no changes, keep bug.xls file and try opening another time or repeat from step 1 with other changes to the file (add columns or change freezed row/column)

Current behavior: inconsistent column width & freeze can disappear after filesave (and opening another time)

Expected behavior: consistent column width & freeze after filesave

Note: using ubuntu 12.04.2 lts 32bit (updated yesterday), this bug also happen with win7 home premium 32bit (using LO 3.6.5.2 & LO 4.0.1.2)

              
Operating System: Ubuntu
Version: 3.6.5.2 release
Comment 1 ign_christian 2013-03-11 06:19:35 UTC
Created attachment 76317 [details]
spreadsheet file with many workbooks

I'm trying to create a sample file with many workbooks that has column width fitted and column-row freezed in everyworkbooks.

However as I explained before, this behaviour is predictable. One should try few times opening and saving that file on different time while in-between working on different files/documents.
Comment 2 ign_christian 2013-03-30 04:36:59 UTC
It seems that if a spreadsheet created/saved and then reopened with same LO version, column width has 'more' consistent behaviour. But if you upgrade LO, that format absolutely broken..

Found that if you only change column/row to freeze/unfreeze, file would not be saved. Probably freeze settings not saved properly on the file?
Comment 3 ign_christian 2013-05-07 13:20:43 UTC
Freeze function still can't be saved in LO 4.0.3.3
Comment 4 ign_christian 2013-05-09 08:59:45 UTC

*** This bug has been marked as a duplicate of bug 61060 ***
Comment 5 ign_christian 2013-06-05 15:22:37 UTC

*** This bug has been marked as a duplicate of bug 49742 ***