Download it now!
Bug 62097 - UI: More intuitive text for menu 'Insert - File'
Summary: UI: More intuitive text for menu 'Insert - File'
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Prashant
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-10 11:33 UTC by Rainer Bielefeld Retired
Modified: 2015-11-30 14:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Mockup (88.74 KB, application/pdf)
2013-03-10 11:33 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-03-10 11:33:52 UTC
Created attachment 76265 [details]
Mockup

Writer menu 'Insert -> File ...' allows to insert contents of a text file contents from existing .odt, .doc and similar at the cursor position. No other file type will be accepted (see help), and so the menu item text should be more specific "Text file ..." instead of "file ...".

Of course also Help and Documentation has to be adapted.

Inherited from OOo and still in current Master
Comment 1 Jiri Blecha 2013-03-15 16:02:08 UTC
Hi Rainer,

I would like to fix this bug. I think that I won't have a problem with changing the text but I don't know how to adopt Help or Documentation.
Can you tell me where could I find those information?

Thanks,
Bleska
Comment 2 Jan Holesovsky 2013-04-15 12:08:09 UTC
Jiri: The help lives here: http://cgit.freedesktop.org/libreoffice/help/

You have to git grep there a bit to find out what to change.  Hopefully the xml format is enough self-descriptory, but if not, this could help:

http://www.openoffice.org/documentation/online_help/OOo2HelpAuthoring.pdf

But recently I saw somebody's sent a patch for this issue too:

https://gerrit.libreoffice.org/#/c/3309/
Comment 3 QA Administrators 2015-09-04 02:49:57 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.0.5 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-09-03
Comment 4 Buovjaga 2015-11-30 14:16:25 UTC
It is now "Document". WFM.