Bug 62126 - File formatting destroyed when Section Break removed
Summary: File formatting destroyed when Section Break removed
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-10 21:34 UTC by Popins
Modified: 2014-06-25 05:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
File from description with section break already removed (47.58 KB, application/zip)
2013-03-10 21:34 UTC, Popins
Details
console + bt with symbols on master sources (5.26 KB, text/plain)
2013-07-21 12:28 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Popins 2013-03-10 21:34:37 UTC
Created attachment 76292 [details]
File from description with section break already removed

Problem description: Download the file of Bug 61763, mentioned in the description (direct link = http://www.europass.si/files/userfiles/europass/dokumenti/Europass%20CV%20nov.doc )

Steps to reproduce:
1. Open that file in MS Office
2. Remove Section Break
3. Save and close
4. Open that file in LibreOffice (or open attached file)
5. File -> Save As
6. Save file as .docx
7. Close file
8. Re-Open that file in LibreOffice

Current behavior: File is garbled, content is lost, formatting is lost

Expected behavior: File should be same as .doc
Comment 1 Popins 2013-03-10 21:38:55 UTC
Comment on attachment 76292 [details]
File from description with section break already removed

Edited Mimetype
Comment 2 Julien Nabet 2013-07-21 12:21:29 UTC
Comment on attachment 76292 [details]
File from description with section break already removed

typo
Comment 3 Julien Nabet 2013-07-21 12:28:47 UTC
Created attachment 82776 [details]
console + bt with symbols on master sources

On pc Debian with master sources updated today, here the result of my tests:
1) Open file attached to the bugtracker.
File opened ok but I noticed this log repeated a dozen of times:
warn:legacy.osl:14568:1:sot/source/sdstor/stgdir.cxx:419: Trying to resize readonly stream by seeking, could be a wrong offset!

2) Save to docx
File saved ok but noticed a lot of these (a hundred times?):
warn:legacy.osl:14568:1:sw/source/core/doc/fmtcol.cxx:637: <SwTxtFmtColl::GetAssignedOutlineStyleLevel()> - misuse of method

3) quit LO
OK

4) open docx
KO. segfault. See console logs + bt attached.
Comment 4 Julien Nabet 2013-07-21 12:30:42 UTC
Miklos: should I file a new bug for the crash or all the problems are linked here? (see my previous comment for more information)
Comment 5 Joel Madero 2014-06-25 05:01:46 UTC
I opened the attached file with 4.3.0.1 rc and saved as a docx then reopened the file. I do not see the garbled text/format.

Setting to WFM - if you see this problem with 4.3.0.1 rc or newer (when 4.3 release comes out soon) please set to UNCONFIRMED and provide a PDF of what you see. Thanks!
Comment 6 Julien Nabet 2014-06-25 05:25:47 UTC
pdf or a simple image file (png/jpg/tif etc.)