Bug Hunting Session
Bug 62168 - Print and display hyperlinks as QR codes option
Summary: Print and display hyperlinks as QR codes option
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: shubhamgoyal
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Hyperlink
  Show dependency treegraph
 
Reported: 2013-03-11 14:16 UTC by john.libreoffice
Modified: 2019-08-06 09:00 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description john.libreoffice 2013-03-11 14:16:02 UTC
Allow the hyperlinks in a document/presentation to also be displayed as QR codes, so when a document is printed out/projected, the link can be visited easily without the need to type in links, which can sometimes be quite gibberish (I am aware of url shortener services, but those thing are external dependencies which can change too easily)

there are already some FLOSS libraries which implement this, but are unfortunately not integrated

Thanks
Comment 1 Robinson Tryon (qubit) 2013-11-25 02:22:46 UTC
Neat idea.

I don't see any other existing request, so setting status -> NEW.

John - Do you have any experience hacking on LibreOffice or similar projects? Would you be interested in integrating QR Code support into our codebase?

Cheers,
Comment 2 Xisco Faulí 2019-07-18 11:44:19 UTC
Hi shubhamgoyal,
is this issue being implemented as part of the GSOC program ?
Comment 3 shubhamgoyal 2019-07-18 13:11:12 UTC
 (In reply to Xisco Faulí from comment #2)
> Hi shubhamgoyal,
> is this issue being implemented as part of the GSOC program?

No, currently the issue is not implemented.
As a part of GSoC program, we will be able to generate a QR code for any text.

A generated QR code as a hyperlink is not part of the GSoC project.

However, After the GSoC time-period, we can take a look at this feature request. :)
Comment 4 shubhamgoyal 2019-07-18 13:13:14 UTC
Unassigning Myself, If someone others may like to work parallelly.
Comment 5 Heiko Tietze 2019-08-06 07:44:25 UTC
This enhancement request has been done during this year GSoC. Can we resolve it as fixed?
Comment 6 Samuel Mehrbrodt (CIB) 2019-08-06 08:52:35 UTC
(In reply to Heiko Tietze from comment #5)
> This enhancement request has been done during this year GSoC. Can we resolve
> it as fixed?

Yes, let's file separate bugs for further enhancements.