Bug 62205 - UI: No scrollbars in Calc preview
Summary: UI: No scrollbars in Calc preview
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Scrollbars
  Show dependency treegraph
 
Reported: 2013-03-12 07:36 UTC by stragu
Modified: 2019-06-16 05:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example of a spreadsheet where this bug occurs. (18.17 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-05-30 01:22 UTC, stragu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stragu 2013-03-12 07:36:08 UTC
Problem description:

No scrollbars are available when zooming in Calc preview.

Steps to reproduce:
1. Create a new spreadsheet
2. Add some content
3. Preview the document before printing
4. Zoom in

Current behavior:

No scrollbars are available.

Expected behavior:

Scrollbars should be available to be able to navigate in the preview without using the mouse/touchpad vertical and horizontal scrolls.
              
Operating System: Ubuntu
Version: 3.6.5.2 release
Comment 1 Joel Madero 2013-05-29 21:14:24 UTC
With 4.0.3.3 I have scroll bars when you zoom in enough (you have to zoom in, they aren't there by default). If you just want to use them to go to next page you use the buttons on the top that read "Next Page" and what not. 


Marking as NOTABUG as the buttons are there to navigate without scrolling with mouse, also you get the bars when you zoom in enough if navigating within one page.

Thanks for the report.
Comment 2 stragu 2013-05-30 01:22:01 UTC
Created attachment 80001 [details]
Example of a spreadsheet where this bug occurs.

Hi Joel. Thanks for checking.

I could reproduce the bug in LO 4.0.3.3 on Ubuntu 13.04 64bits, with the particular document I attached. I also tried to reset my user profile to no avail.

However, I could not reproduce this with another document, but if I find something consistent I will let you know (I am pretty sure I had this problem before with other documents.

Please have a look at the document and let me know.

Cheers
Comment 3 stragu 2013-10-30 04:50:04 UTC
I just tested this with the attached document in LO 4.1.2.3 as well as another document I am working on, and I get the same result: zooming in does not give me scrollbars.
I am using Ubuntu 13.10 now.
Comment 4 Joel Madero 2014-11-06 17:50:26 UTC
Never confirmed - moving to UNCONFIRMED so QA looks at it. Thanks
Comment 5 A (Andy) 2014-11-06 22:36:02 UTC
Reproducible with LO 4.3.3.2, Win 8.1.

Steps done:
1. Open CALC
2. Write any word in cell A1 
3. Go to FILE -> PAGE PREVIEW
4. Zoom for instance to 140% with the magnifier icon in the toolbar at the top or the zoom-bar downright

Result:
You can scroll with the mouse wheel, but there is no scrollbar available to scroll.  Without the mouse wheel you have no opportunity to scroll.
Comment 6 stragu 2014-11-07 02:11:11 UTC
I can confirm this in Ubuntu 14.04.1 64 bits with LO 4.2.7.2, following my original description, or using the provided file, or following Andy's instructions.
I tested with: 
- using the zooming buttons in the upper toolbar;
- using the zooming buttons in the bottom status bar;
- using ctrl+scroll.

In every case, no scrollbars appeared, although I have to point out an inconsistency: the first time I tried (following Andy's instructions), I DID get the scrollbars... But I tried it a dozen times after (with new documents too) and they never appeared again.

Very confusing.
Comment 7 QA Administrators 2015-12-20 16:20:41 UTC Comment hidden (obsolete)
Comment 8 stragu 2015-12-24 10:14:35 UTC
I reproduced this with the following version:

Version: 5.0.3.2
Build ID: 1:5.0.3~rc2-0ubuntu1~trusty2
Locale: en-GB (en_GB.UTF-8)

On KXStudio 14.04.
Comment 9 QA Administrators 2017-01-03 19:57:41 UTC Comment hidden (obsolete)
Comment 10 stragu 2017-01-04 08:02:18 UTC
Reproduced with example document on KXStudio 14.04

LO details:

Version: 5.2.3.2
Build ID: 1:5.2.3~rc2-0ubuntu1~trusty1
CPU Threads: 2; OS Version: Linux 3.13; UI Render: default; 
Locale: en-GB (en_GB.UTF-8); Calc: group
Comment 11 stragu 2017-08-18 23:00:45 UTC
Confirmed on current still version:

Version: 5.3.5.2
Build ID: 50d9bf2b0a79cdb85a3814b592608037a682059d
CPU Threads: 2; OS Version: Linux 3.13; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: en-GB (en_GB.UTF-8); Calc: group
Comment 12 QA Administrators 2018-08-19 02:37:18 UTC Comment hidden (obsolete)
Comment 13 stragu 2018-08-20 02:47:03 UTC
Confirmed using both the example document and the steps listed by A (Andy) in comment #5, on a new computer with Ubuntu Budgie 18.04 and the following LibreOffice version details:

Version: 6.0.3.2
Build ID: 1:6.0.3-0ubuntu1
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-AU (en_GB.UTF-8); Calc: group

Could someone check on 6.1 or 6.2?
Comment 14 stragu 2019-06-16 05:43:56 UTC
It seems this is fixed in the 6.3 branch. Just tested with:

Version: 6.3.0.0.beta1
Build ID: a187af327633f5f00363be5131bd21a13e0f1a7b
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-AU (en_AU.UTF-8); UI-Language: en-US
Calc: threaded

It is still present in 6.2.4.2, but I am marking it as fixed (that's how it works, right?)