Download it now!
Bug 62208 - FORMATTING: Conditional format display differs from configuration
Summary: FORMATTING: Conditional format display differs from configuration
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2013-03-12 08:03 UTC by Daniel Schmidt
Modified: 2018-06-15 16:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice spreadsheet document with a test case and the bugdescription (86.41 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-03-12 08:03 UTC, Daniel Schmidt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Schmidt 2013-03-12 08:03:32 UTC
Created attachment 76366 [details]
LibreOffice spreadsheet document with a test case and the bugdescription

Problem description: 
If a row is inserted between rows that are conditional formatted the new rows display behaviour is not as configured in conditional format dialog.

Steps to reproduce:
1. Open attached sheet
2. Insert a new row before row 13
3. Insert "!" in cell A and "test" in cell B of the new row

Current behavior:
"test" in column B is diplayed in red. The conditional format dialog shows no format configuration for the new row. If you save the document and reopen it, the "test" is diplayed again in black.

Expected behavior:
1. Either the new row should have the same conditional format as the rows on top/bottom or
2. the new cell in Column "B" mustn't display in red.
              
Operating System: All
Version: 4.0.1.2 release
Comment 1 Jacques Guilleron 2013-03-12 13:47:42 UTC
Hello Daniel,

if you select range B12:B30 instead of cells one by one, and apply your formula, which result ?

Regards,

Jacques
Comment 2 Daniel Schmidt 2013-03-13 06:20:12 UTC
(In reply to comment #1)
> Hello Daniel,
> 
> if you select range B12:B30 instead of cells one by one, and apply your
> formula, which result ?
> 
> Regards,
> 
> Jacques

Hi Jacques,

what I wanted is, to format B12 dependent on A12, B13 dependent on A13 and so on. So I first added the conditional format only to B12 and then I copied the format with the copy-format function.

How do I have to write the formula for cell range B12:B30 to reach the relative dependence to the respective cell in column A?

Thank you! Have a nice day!

Best regards,
Daniel
Comment 3 Jacques Guilleron 2013-03-13 10:20:23 UTC
Hi Daniel,

Just think for one cell your conditional format in the same way, but before you leave the dialog box you set it, look at the bottom where this is applied and select or write the range you want. For a long time, it wasn't possible but now, it is. That simplify significantly writing and reading for conditional format.

Now, since we have a whole range instead of cell by bell setting, introduce a new line betwween these boundaries which have the same condition is quite easy.

Best regards.

Have a nice day too.

Jacques
Comment 4 Daniel Schmidt 2013-03-15 07:24:11 UTC
(In reply to comment #0)
> Created attachment 76366 [details]
> LibreOffice spreadsheet document with a test case and the bugdescription
> 
> Problem description: 
> If a row is inserted between rows that are conditional formatted the new
> rows display behaviour is not as configured in conditional format dialog.
> 
> Steps to reproduce:
> 1. Open attached sheet
> 2. Insert a new row before row 13
> 3. Insert "!" in cell A and "test" in cell B of the new row
> 
> Current behavior:
> "test" in column B is diplayed in red. The conditional format dialog shows
> no format configuration for the new row. If you save the document and reopen
> it, the "test" is diplayed again in black.
> 
> Expected behavior:
> 1. Either the new row should have the same conditional format as the rows on
> top/bottom or
> 2. the new cell in Column "B" mustn't display in red.
>               
> Operating System: All
> Version: 4.0.1.2 release

(In reply to comment #3)
> Hi Daniel,
> 
> Just think for one cell your conditional format in the same way, but before
> you leave the dialog box you set it, look at the bottom where this is
> applied and select or write the range you want. For a long time, it wasn't
> possible but now, it is. That simplify significantly writing and reading for
> conditional format.
> 
> Now, since we have a whole range instead of cell by bell setting, introduce
> a new line betwween these boundaries which have the same condition is quite
> easy.
> 
> Best regards.
> 
> Have a nice day too.
> 
> Jacques

Hi Jacques,

thank you for your reply. At the time I created the list, I had a mistake in the conditional format range.

Now I have one conditional format rule. The behaviour now is correct. New cells, that are inserted in the previously defined range are included in the range and the range is increased.

Thank you for your help.

The problem I mentioned in this report:
With the original used conditional format configuration, the diplaying of the new line DIFFERS from the configuration! And this changes not before reloading the document.

So I think this is really a bug. Can you reproduce this problem? Please set the status to confirmed (sorry, I'm new here and not familiar with the handling of the workflow of the bug reports).

Thank you!

Best regards,
Daniel
Comment 5 Daniel Schmidt 2013-03-15 07:25:17 UTC
The problem I mentioned in this report:
The diplaying of the new line DIFFERS from the configuration!

This doesn't change before reloading the document.
Comment 6 Jacques Guilleron 2013-03-15 14:54:05 UTC
Hi Daniel,

Clearly, yes. Those two cases aren't managed.
I set your report to NEW.

Regards.

Jacques Guilleron
Comment 7 Markus Mohrhard 2013-12-02 22:51:26 UTC
This should have been fixed in a later version. 4.0.1 is nearly a year old and even the 4-0 branch is EOF.
Comment 8 QA Administrators 2015-04-19 03:19:56 UTC Comment hidden (obsolete)
Comment 9 Buovjaga 2015-06-15 08:16:24 UTC
(In reply to Daniel Schmidt from comment #0)
> Created attachment 76366 [details]
> LibreOffice spreadsheet document with a test case and the bugdescription
> 
> Problem description: 
> If a row is inserted between rows that are conditional formatted the new
> rows display behaviour is not as configured in conditional format dialog.
> 
> Steps to reproduce:
> 1. Open attached sheet
> 2. Insert a new row before row 13
> 3. Insert "!" in cell A and "test" in cell B of the new row
> 
> Current behavior:
> "test" in column B is diplayed in red. The conditional format dialog shows
> no format configuration for the new row. If you save the document and reopen
> it, the "test" is diplayed again in black.
> 
> Expected behavior:
> 1. Either the new row should have the same conditional format as the rows on
> top/bottom or
> 2. the new cell in Column "B" mustn't display in red.

Still reproduced, except the text is not displayed in black after reloading document.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 01a189abcd9a4ca472a74b3b2c000c9338fc2c91
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-14_07:46:28
Locale: fi-FI (fi_FI)
Comment 10 QA Administrators 2016-09-20 10:00:30 UTC Comment hidden (obsolete)
Comment 11 Mike Kaganski 2018-06-15 14:21:03 UTC
Cannot reproduce with Version: 6.0.5.1 (x64)
Build ID: 0588a1cb9a40c4a6a029e1d442a2b9767d612751
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: ru-RU (ru_RU); Calc: CL
Comment 12 Mike Kaganski 2018-06-15 14:26:23 UTC
(In reply to Buovjaga from comment #9)
> Still reproduced, except the text is not displayed in black after reloading
> document.

I'm afraid that that was not the case: that the text stayed red indicates that the newly inserted line had the conditional formatting as it should. Most possibly, it simply shared the formatting with A12, which simply had its range extended; that's why the newly inserted line could have no separate entry in the dialog.
Comment 13 Buovjaga 2018-06-15 16:06:11 UTC
Ok, let's close then.