Download it now!
Bug 62273 - : Inkscape SVG image Import. Hidden layers.
Summary: : Inkscape SVG image Import. Hidden layers.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA bibisected40 target:4.2.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-03-13 04:10 UTC by titghhax
Modified: 2014-04-29 16:20 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
this archive contains svg file with hidden layers and odt file with imported svg (193.03 KB, application/zip)
2013-03-13 04:10 UTC, titghhax
Details

Note You need to log in before you can comment on or make changes to this bug.
Description titghhax 2013-03-13 04:10:01 UTC
Created attachment 76451 [details]
this archive contains svg file with hidden layers and odt file with imported svg

Problem description: 
Import of Inkscape SVG images does not works as in 3.6 version.
Hidden layers of SVG file when importing are not hidden.

Steps to reproduce:
1. Insert > Image > From file...
2. Select Inkscape SVG file

Current behavior:
Hidden layers in imported image are displayed

Expected behavior:
In imported svg image hidden layers are not displayed as in version 3.6
              
Operating System: Windows XP
Version: 4.0.1.2 release
Last worked in: 3.6.5.2 release
Comment 1 Szuhánszky Tamás 2013-04-22 09:58:25 UTC
Hi!

I could reproduce this behavior with 4.0.1.2, 4.0.2.2 and master.
Operatin system: Windows 7 64 bit

In 3.6.5.2 the hidden layer aren't displayed, but it's part of the inserted picture, concluded from the size of the inserted picture.
Comment 2 Joel Madero 2013-04-22 18:08:24 UTC
Please attach a svg that we can test with - difficult to find them laying around online :)

Marking as NEEDINFO, attach picture and mark as UNCONFIRMED and we will investigate.

Thanks!
Comment 3 Joel Madero 2013-04-22 18:08:54 UTC
haha nevermind, sorry I see the document -- my mistake! changing to UNCONFIRMED
Comment 4 Joel Madero 2013-04-22 18:22:53 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version: 4.1.0.0.alpha0+Build ID: 6e3e6ef7257e93743a72719581ef6fe0016e58e
Date:   Thu Apr 11 15:24:38 2013 +0200 
Platform: Bodhi Linux 2.2 x64

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Normal - can prevent high quality work
Medium - default seems appropriate, svg's are pretty rare but this is a regression

Keywords - regression (works fine in 3.6.6.2 release)

Whiteboard Status - bibisectrequest

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 5 Joel Madero 2013-05-02 20:57:09 UTC
Unfortunately because other issues with SVG images bibisect isn't as useful as it could be. Still, here it is:

The first bad commit could be any of:
47498a36f7af8f54e6e3dda89cd4708802a409e6
9ec4be63ed5281f2e9364b140da69291c7abc348
769583027b0158ac4b497355b0495fca5c54f53b
7b32edd2389319e0d394368c4109201528c41f7e
6095212a5bd192017c6a20ee10de26a163372e8c
915b1e16f20d5ce2a32f911ef051103455600845
b17eb9ea515cf4b5bf60dd2b6860febf0806a9bd
fb4214f9d134b556582a4a5280e5458de5f8eebd
5dddcff8ae35692d89751ae98ab8acbbf802b5b4
9a5620ca6473969359f262802c76daf35cbcbb5d
fad6aba1675531a031872af655be5756c5012cb9

# bad: [5b4b36d87517a6ea96ff8c84c46b12f462fc9a1a] source-hash-8450a99c744e9005f19173e4df35d65640bcf5c4
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [16b0b88cbd4ef0f51816e97277e40c5cf78f7bf9] source-hash-099198a4224778fe6e43f5dc13b5b9b1b4dc828c
git bisect good 16b0b88cbd4ef0f51816e97277e40c5cf78f7bf9
# good: [f28b8f9a6c47fa59bf98fffe937a2f2db7a2445a] source-hash-a581d31b227623e09d2970a91214fda398f98eda
git bisect good f28b8f9a6c47fa59bf98fffe937a2f2db7a2445a
# good: [114fd3b76bcba890e6d702d00cef910f1493c262] source-hash-64ab96cd15e52da88781e720d6f031dbcd0ba902
git bisect good 114fd3b76bcba890e6d702d00cef910f1493c262
# skip: [47498a36f7af8f54e6e3dda89cd4708802a409e6] source-hash-19f4ebd8a54da0ae03b9cc8481613e5cd20ee1e7
git bisect skip 47498a36f7af8f54e6e3dda89cd4708802a409e6
# bad: [99fa32bfa0d6116217da0834f3a630b3775aa16a] source-hash-246ffb108c7e1f762f8d497750ad2414b85b99ef
git bisect bad 99fa32bfa0d6116217da0834f3a630b3775aa16a
# skip: [9a5620ca6473969359f262802c76daf35cbcbb5d] source-hash-ae4e4a11d4300f7448cb6bd170fcb034542caddc
git bisect skip 9a5620ca6473969359f262802c76daf35cbcbb5d
# skip: [6095212a5bd192017c6a20ee10de26a163372e8c] source-hash-a599f5b4b51848e3b397d471c9d12b373caadcef
git bisect skip 6095212a5bd192017c6a20ee10de26a163372e8c
# skip: [b17eb9ea515cf4b5bf60dd2b6860febf0806a9bd] source-hash-b6c016da23d309b4ac7d154bc33a22397974ed73
git bisect skip b17eb9ea515cf4b5bf60dd2b6860febf0806a9bd
# skip: [fb4214f9d134b556582a4a5280e5458de5f8eebd] source-hash-683758efb22d08a4cf211a6d985148f513da2a90
git bisect skip fb4214f9d134b556582a4a5280e5458de5f8eebd
# skip: [915b1e16f20d5ce2a32f911ef051103455600845] source-hash-9210b95bcfd65ae558f445666d9b880e794d4c74
git bisect skip 915b1e16f20d5ce2a32f911ef051103455600845
# good: [7f50375c2cf8bf1e026f61f11ae9666648687164] source-hash-d281a19e1d06856f863788f3344ad42ed1566669
git bisect good 7f50375c2cf8bf1e026f61f11ae9666648687164
# skip: [5dddcff8ae35692d89751ae98ab8acbbf802b5b4] source-hash-d85fd8a85501547d5bb87822d2589a07aed7f2d6
git bisect skip 5dddcff8ae35692d89751ae98ab8acbbf802b5b4
# skip: [9ec4be63ed5281f2e9364b140da69291c7abc348] source-hash-a1ac2538e9b287444500618ab4d2f0f06c25cf34
git bisect skip 9ec4be63ed5281f2e9364b140da69291c7abc348
# skip: [7b32edd2389319e0d394368c4109201528c41f7e] source-hash-44b96a2fce52b6e3e683dc917fab219cf75001db
git bisect skip 7b32edd2389319e0d394368c4109201528c41f7e
# skip: [769583027b0158ac4b497355b0495fca5c54f53b] source-hash-a43a76cd5aa2f145f2cb43fcdbc8f21fb6c89af0
git bisect skip 769583027b0158ac4b497355b0495fca5c54f53b
# good: [e2e46267c18c2706de771a08472ebfce19f68520] source-hash-4316e643ef345b0f673b4a03a80a4b7cb3185588
git bisect good e2e46267c18c2706de771a08472ebfce19f68520
# bad: [fad6aba1675531a031872af655be5756c5012cb9] source-hash-d38a2e3ea04d354492df18aa16d2304babe87dfb
git bisect bad fad6aba1675531a031872af655be5756c5012cb9
Comment 6 Robinson Tryon (qubit) 2013-10-23 16:50:02 UTC
Removing comma from whiteboard (please use a space to delimit values in this field)
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Whiteboard#Getting_Started
Comment 7 Michael Stahl (allotropia) 2014-04-29 16:20:07 UTC
was fixed in 4.2.0 by commit b7a425aab6122b5848362815e5fe665c7e38da05